fails to dump with latest kpti fixes

Bug #1750021 reported by Thadeu Lima de Souza Cascardo on 2018-02-16
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Thadeu Lima de Souza Cascardo
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
Thadeu Lima de Souza Cascardo
makedumpfile (Ubuntu)
Undecided
Thadeu Lima de Souza Cascardo
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
Thadeu Lima de Souza Cascardo

Bug Description

When commit 83e3c48729d9ebb7af5a31a504f3fd6aff0348c4 ("mm/sparsemem: Allocate mem_section at runtime for CONFIG_SPARSEMEM_EXTREME=y") was backported, it broke the exporting of mem_section on vmcoreinfo.

makedumpfile will fail to dump in that case. Backporting a kernel fix will make it work again, but that means that some kernel versions won't be dumpable. A solution for makedumpfile should be done as well.

Cascardo.

break-fix: 83e3c48729d9ebb7af5a31a504f3fd6aff0348c4 a0b1280368d1e91ab72f849ef095b4f07a39bbf1

Linux needs commit a0b1280368d1e91ab72f849ef095b4f07a39bbf1 ("kdump: write correct address of mem_section into vmcoreinfo").

Changed in makedumpfile (Ubuntu):
status: New → In Progress
assignee: nobody → Thadeu Lima de Souza Cascardo (cascardo)
Changed in linux (Ubuntu):
assignee: nobody → Thadeu Lima de Souza Cascardo (cascardo)
status: New → Confirmed

I intend to send this fix upstream and test it with more kernel versions. At least added with a 4.13 kernel without the patch and one with the patch.

Now building on my ppa:

sudo add-apt-repository ppa:cascardo/ppa
sudo apt-get update

tags: added: patch
tags: added: kernel-da-key
description: updated
tags: added: kernel-bug-break-fix
removed: kernel-da-key
Changed in linux (Ubuntu Bionic):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Xenial):
status: New → Invalid

Xenial does not have 83e3c48729d9ebb7af5a31a504f3fd6aff0348c4. Though, linux-hwe 4.13 has been shipped for Xenial. So, on the kernel side, there is nothing to fix on our 4.4 kernels, but on the makedumpfile side, that still needs to be fixed if we want to have some of those kernels dumpable.

Changed in linux (Ubuntu Artful):
status: New → Fix Committed
Stefan Bader (smb) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-artful' to 'verification-done-artful'. If the problem still exists, change the tag 'verification-needed-artful' to 'verification-failed-artful'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-artful
Launchpad Janitor (janitor) wrote :
Download full text (18.9 KiB)

This bug was fixed in the package linux - 4.13.0-38.43

---------------
linux (4.13.0-38.43) artful; urgency=medium

  * linux: 4.13.0-38.43 -proposed tracker (LP: #1755762)

  * Servers going OOM after updating kernel from 4.10 to 4.13 (LP: #1748408)
    - i40e: Fix memory leak related filter programming status
    - i40e: Add programming descriptors to cleaned_count

  * [SRU] Lenovo E41 Mic mute hotkey is not responding (LP: #1753347)
    - platform/x86: ideapad-laptop: Increase timeout to wait for EC answer

  * fails to dump with latest kpti fixes (LP: #1750021)
    - kdump: write correct address of mem_section into vmcoreinfo

  * headset mic can't be detected on two Dell machines (LP: #1748807)
    - ALSA: hda/realtek - Support headset mode for ALC215/ALC285/ALC289
    - ALSA: hda - Fix headset mic detection problem for two Dell machines
    - ALSA: hda - Fix a wrong FIXUP for alc289 on Dell machines

  * CIFS SMB2/SMB3 does not work for domain based DFS (LP: #1747572)
    - CIFS: make IPC a regular tcon
    - CIFS: use tcon_ipc instead of use_ipc parameter of SMB2_ioctl
    - CIFS: dump IPC tcon in debug proc file

  * i2c-thunderx: erroneous error message "unhandled state: 0" (LP: #1754076)
    - i2c: octeon: Prevent error message on bus error

  * hisi_sas: Add disk LED support (LP: #1752695)
    - scsi: hisi_sas: directly attached disk LED feature for v2 hw

  * EDAC, sb_edac: Backport 1 patch to Ubuntu 17.10 (Fix missing DIMM sysfs
    entries with KNL SNC2/SNC4 mode) (LP: #1743856)
    - EDAC, sb_edac: Fix missing DIMM sysfs entries with KNL SNC2/SNC4 mode

  * [regression] Colour banding and artefacts appear system-wide on an Asus
    Zenbook UX303LA with Intel HD 4400 graphics (LP: #1749420)
    - drm/edid: Add 6 bpc quirk for CPT panel in Asus UX303LA

  * DVB Card with SAA7146 chipset not working (LP: #1742316)
    - vmalloc: fix __GFP_HIGHMEM usage for vmalloc_32 on 32b systems

  * [Asus UX360UA] battery status in unity-panel is not changing when battery is
    being charged (LP: #1661876) // AC adapter status not detected on Asus
    ZenBook UX410UAK (LP: #1745032)
    - ACPI / battery: Add quirk for Asus UX360UA and UX410UAK

  * ASUS UX305LA - Battery state not detected correctly (LP: #1482390)
    - ACPI / battery: Add quirk for Asus GL502VSK and UX305LA

  * support thunderx2 vendor pmu events (LP: #1747523)
    - perf pmu: Extract function to get JSON alias map
    - perf pmu: Pass pmu as a parameter to get_cpuid_str()
    - perf tools arm64: Add support for get_cpuid_str function.
    - perf pmu: Add helper function is_pmu_core to detect PMU CORE devices
    - perf vendor events arm64: Add ThunderX2 implementation defined pmu core
      events
    - perf pmu: Add check for valid cpuid in perf_pmu__find_map()

  * lpfc.ko module doesn't work (LP: #1746970)
    - scsi: lpfc: Fix loop mode target discovery

  * Ubuntu 17.10 crashes on vmalloc.c (LP: #1739498)
    - powerpc/mm/book3s64: Make KERN_IO_START a variable
    - powerpc/mm/slb: Move comment next to the code it's referring to
    - powerpc/mm/hash64: Make vmalloc 56T on hash

  * ethtool -p fails to light NIC LED on HiSilicon D05 systems (LP: #1748567)
    - net...

Changed in linux (Ubuntu Artful):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package makedumpfile - 1:1.6.3-2

---------------
makedumpfile (1:1.6.3-2) unstable; urgency=medium

  * Add support for SPARSEMEM_EXTREME mem_section as a pointer. (LP: #1750021)
  * Add an autopkgtest that test that a crash produces a compressed dump
    file.
  * Create initrd for previously installed kernels. (LP: #1751329)

 -- Thadeu Lima de Souza Cascardo <email address hidden> Mon, 05 Mar 2018 09:28:55 -0300

Changed in makedumpfile (Ubuntu Bionic):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers