update makedumpfile tool version to v1.6.3

Bug #1746299 reported by bugproxy on 2018-01-30
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
High
Canonical Kernel Team
makedumpfile (Ubuntu)
High
Thadeu Lima de Souza Cascardo
Xenial
High
Canonical Kernel Team
Artful
High
Canonical Kernel Team
Bionic
High
Thadeu Lima de Souza Cascardo

Bug Description

[Impact]
New upstream kernel versions, as those in linux-hwe package, require a newer makedumpfile to be supported. Otherwise, all copies fallback to copying the entire memory.

[Test case]
kdump-tools has been installed, system rebooted, then crash trigerred and verified that a small dump file was present on /var/crash/. Tested on amd64 and ppc64le.

[Regression potential]
Many other bug fixes have been included in the latest version of the package. The changes are supposed to fix these bugs, and have been tested as well. However, as the total of changes is not trivial, there is impact of regression that has been minimized by the tests done. Regression potential of not supporting older kernels has been tested with the kernels shipped on xenial and artful as well.

====================================================================

== Comment: #0 - Hari Krishna Bathini <email address hidden> - 2018-01-30 10:46:53 ==
---Problem Description---
update makedumpfile to latest version v1.6.3 that officially supports
up to kernel version 4.14.8. Since makedumpfile is inherently backward compatible,
this would not break existing functionality..

Contact Information = <email address hidden>

---uname output---
na

Machine Type = na

---Debugger---
A debugger is not configured

---Steps to Reproduce---
 makedumpfile reports ""The kernel version is not supported" while generating vmcore
Also, there is a possibility of bogus address translations in makedumpfile tool with
missing upstream patches. Can't be so sure without an exhaustive testing. Instead,
it would be a good idea to go with the version which officially supports the kernel
version in question.

Userspace tool common name: makedumpfile

The userspace tool has the following bit modes: 64-bit

Userspace rpm: makedumpfile

Userspace tool obtained from project website: na

*Additional Instructions for <email address hidden>:
-Attach ltrace and strace of userspace application.

== Comment: #1 - Hari Krishna Bathini <email address hidden> - 2018-01-30 10:49:13 ==
With kernel version updated to 4.13.0, please update makedumpfile tool
version to 1.6.3 which officially supports up to kernel version 4.14.8 [1].

Thanks
Hari

[1] http://lists.infradead.org/pipermail/kexec/2018-January/019853.html

This needs to be tagged for both 16.04.4 & 18.04 releases

bugproxy (bugproxy) on 2018-01-30
tags: added: architecture-ppc64le bugnameltc-164118 severity-high targetmilestone-inin16044
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → makedumpfile (Ubuntu)

------- Comment From <email address hidden> 2018-02-06 07:43 EDT-------
Please suggest if the makedumpfile tool have been updated to version 1.6.3?

I am working on it. I will let you know when it's available in -proposed.

Changed in makedumpfile (Ubuntu):
assignee: Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage) → Thadeu Lima de Souza Cascardo (cascardo)
status: New → In Progress
importance: Undecided → High
Changed in ubuntu-power-systems:
importance: Undecided → High
status: New → In Progress
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package makedumpfile - 1:1.6.3-1

---------------
makedumpfile (1:1.6.3-1) unstable; urgency=medium

  * New upstream release. Main new feature:
    o Support new kernels
     - The supported kernel is updated to 4.14.8 in this version. (LP: #1746299)
       4.14.9 and later can't be filtered correctly due to inappropriate VMCOREINFO,
       it will be resolved in kernel 4.15.

  * Changelog:
    o New feature
        - [PATCH v2] x86_64: Take care of init_level4_pgt rename in kernel (by Pratyush Anand) 64bd5db
        - [PATCH v2] Fix SECTION_MAP_MASK for kernel >= v.13 (by Pratyush Anand) 4bf4f2b
        - [PATCH v2] book3s/ppc64: Lower the max real address to 53 bits for kernels >= v4.11
          (by Bhupesh Sharma) 6c83e74
        - [PATCH v3 1/4] Support symbol __cpu_online_mask (by Takao Indoh) 3b11c00
        - [PATCH] ppc64: update hash page table geometry (by Hari Bathini) 3c39f13
        - [PATCH] handle renamed init_level4_pgt -> init_top_pgt (by Jeff Mahoney) 5e54d53

    o Bugfix
        - [PATCH v2] arm64: Fix page table walk of 1GB section (by Bradley Bolen) 27508f1
        - [PATCH v2 1/2] ppc64: set page_offset in get_versiondep_info_ppc64() (by Pingfan Liu) 52319d2
        - [PATCH v2 2/2] ppc64: get the info of mem reserved for crashkernel (by Pingfan Liu) c7fcbbc
        - [PATCH v3 3/4] sadump: Fix a KASLR problem of sadump (by Takao Indoh) b4f7d95
        - [PATCH v3 4/4] sadump: Fix a KASLR problem of sadump while kdump is working (by Takao Indoh) 13d3059
        - [PATCH 2/2] Fix 'kernel_version' variable being uninitialized & introduce minor reorganization
          (by Bhupesh Sharma) d1ffe82
        - [PATCH 1/2] Fix off-by-one errors in exclude_segment() (by Petr Tesarik) 590f35e
        - [PATCH 2/2] Fix physical-to-virtual conversion in exclude_segment() (by Petr Tesarik) 6c1bf2a

    o Cleanup
        - [PATCH] Fix formatting problems in header file (by Eric DeVolder) cefea9e
        - [PATCH v3 2/4] Introduce vtop4_x86_64_pagetable (by Takao Indoh) 6de5d37
        - [PATCH 1/2] Fix compilation warnings on ppc64/ppc64le platforms (by Bhupesh Sharma) 0df157a
        - [PATCH] Make good use of is_cyclic_region() (by Atsushi Kumagai) 6bfd7a3
        - [PATCH] Fix the regression about getting kernel version (by Atsushi Kumagai) 254c116
        - [PATCH] Update maintainers (by Atsushi Kumagai) 9d3147e

  * Use multi-user.target. (LP: #1708409)
  * kdump-tools Recommends initramfs-tools-core.
  * Add myself as uploader.
  * Move Vcs control fields to salsa.

 -- Thadeu Lima de Souza Cascardo <email address hidden> Tue, 06 Feb 2018 12:53:14 -0200

Changed in makedumpfile (Ubuntu):
status: In Progress → Fix Released
Changed in makedumpfile (Ubuntu):
milestone: none → ubuntu-16.04.4
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-02-13 02:12 EDT-------
(In reply to comment #8)
> This bug was fixed in the package makedumpfile - 1:1.6.3-1
>
> ---------------
> makedumpfile (1:1.6.3-1) unstable; urgency=medium
>
> * New upstream release. Main new feature:
> o Support new kernels
> - The supported kernel is updated to 4.14.8 in this version. (LP: #1746299)
> 4.14.9 and later can't be filtered correctly due to inappropriate VMCOREINFO,
> it will be resolved in kernel 4.15.
>
> * Changelog:
> o New feature
> - [PATCH v2] x86_64: Take care of init_level4_pgt rename in kernel (by
> Pratyush Anand) 64bd5db
> - [PATCH v2] Fix SECTION_MAP_MASK for kernel >= v.13 (by Pratyush Anand)
> 4bf4f2b
> - [PATCH v2] book3s/ppc64: Lower the max real address to 53 bits for kernels
> >= v4.11
> (by Bhupesh Sharma) 6c83e74
> - [PATCH v3 1/4] Support symbol __cpu_online_mask (by Takao Indoh) 3b11c00
> - [PATCH] ppc64: update hash page table geometry (by Hari Bathini) 3c39f13
> - [PATCH] handle renamed init_level4_pgt -> init_top_pgt (by Jeff Mahoney)
> 5e54d53
>
> o Bugfix
> - [PATCH v2] arm64: Fix page table walk of 1GB section (by Bradley Bolen)
> 27508f1
> - [PATCH v2 1/2] ppc64: set page_offset in get_versiondep_info_ppc64() (by
> Pingfan Liu) 52319d2
> - [PATCH v2 2/2] ppc64: get the info of mem reserved for crashkernel (by
> Pingfan Liu) c7fcbbc
> - [PATCH v3 3/4] sadump: Fix a KASLR problem of sadump (by Takao Indoh)
> b4f7d95
> - [PATCH v3 4/4] sadump: Fix a KASLR problem of sadump while kdump is
> working (by Takao Indoh) 13d3059
> - [PATCH 2/2] Fix 'kernel_version' variable being uninitialized & introduce
> minor reorganization
> (by Bhupesh Sharma) d1ffe82
> - [PATCH 1/2] Fix off-by-one errors in exclude_segment() (by Petr Tesarik)
> 590f35e
> - [PATCH 2/2] Fix physical-to-virtual conversion in exclude_segment() (by
> Petr Tesarik) 6c1bf2a
>
> o Cleanup
> - [PATCH] Fix formatting problems in header file (by Eric DeVolder) cefea9e
> - [PATCH v3 2/4] Introduce vtop4_x86_64_pagetable (by Takao Indoh) 6de5d37
> - [PATCH 1/2] Fix compilation warnings on ppc64/ppc64le platforms (by
> Bhupesh Sharma) 0df157a
> - [PATCH] Make good use of is_cyclic_region() (by Atsushi Kumagai) 6bfd7a3
> - [PATCH] Fix the regression about getting kernel version (by Atsushi
> Kumagai) 254c116
> - [PATCH] Update maintainers (by Atsushi Kumagai) 9d3147e
>
> * Use multi-user.target. (LP: #1708409)
> * kdump-tools Recommends initramfs-tools-core.
> * Add myself as uploader.
> * Move Vcs control fields to salsa.
>
> -- Thadeu Lima de Souza Cascardo <email address hidden> Tue, 06 Feb 2018
> 12:53:14 -0200

Hello Cascardo, we don't see the fix package in -proposed yet.
When could we expect it there..?

Thanks
Hari

Hi, Hari.

It's already in bionic. However, due to some of the changes on kpti patches, it might fail to properly work, and there is no upstream makedumpfile fix in the works yet, so I am debugging and working on it, so we will get something that will also work for those latest kernels we have released.

Thanks.
Cascardo.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-02-15 05:50 EDT-------
(In reply to comment #10)
> Hi, Hari.
>
> It's already in bionic. However, due to some of the changes on kpti patches,
> it might fail to properly work, and there is no upstream makedumpfile fix in
> the works yet, so I am debugging and working on it, so we will get something
> that will also work for those latest kernels we have released.
>
> Thanks.
> Cascardo.

Thannk you cascardo for the update,
Yes though v1.6.3 is present in 18.04 makedumpfile still fails during dump..
===console log===
kernel used on Bionic is 4.13.0-32-generic
||/ Name Version Architecture Description
+++-====================-===============-===============-=============================================
ii makedumpfile 1:1.6.3-1 ppc64el VMcore extraction tool

Starting Kernel crash dump capture service...
[ 22.094036] kdump-tools[1360]: Starting kdump-tools: * running makedumpfile -c -d 31 /proc/vmcore /var/crash/201802150350/dump-incomplete
Checking for memory holes : [100.0 %] | readpage_elf: Attempt to read non-existent page at 0x4d39b30000.
[ 22.378312] kdump-tools[1360]: readmem: type_addr: 0, addr:c000004d39b37140, size:16384
[ 22.378411] kdump-tools[1360]: __exclude_unnecessary_pages: Can't read the buffer of struct page.
[ 22.378538] kdump-tools[1360]: create_2nd_bitmap: Can't exclude unnecessary pages.
Checking for memory holes : [100.0 %] - readpage_elf: Attempt to read non-existent page at 0x4d39b30000.
[ 22.378708] kdump-tools[1360]: readmem: type_addr: 0, addr:c000004d39b37140, size:16384
[ 22.378779] kdump-tools[1360]: __exclude_unnecessary_pages: Can't read the buffer of struct page.
[ 22.378853] kdump-tools[1360]: create_2nd_bitmap: Can't exclude unnecessary pages.
[ 22.378924] kdump-tools[1360]: makedumpfile Failed.
[ 22.379014] kdump-tools[1360]: * kdump-tools: makedumpfile failed, falling back to 'cp'

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-02-15 06:21 EDT-------
(In reply to comment #11)
> (In reply to comment #10)
> > Hi, Hari.
> >
> > It's already in bionic. However, due to some of the changes on kpti patches,
> > it might fail to properly work, and there is no upstream makedumpfile fix in
> > the works yet, so I am debugging and working on it, so we will get something
> > that will also work for those latest kernels we have released.
> >
> > Thanks.
> > Cascardo.
>
> Thannk you cascardo for the update,
> Yes though v1.6.3 is present in 18.04 makedumpfile still fails during dump..
> ===console log===
> kernel used on Bionic is 4.13.0-32-generic
> ||/ Name Version Architecture Description
> +++-====================-===============-===============-
> =============================================
> ii makedumpfile 1:1.6.3-1 ppc64el VMcore extraction
> tool
>
> Starting Kernel crash dump capture service...
> [ 22.094036] kdump-tools[1360]: Starting kdump-tools: * running
> makedumpfile -c -d 31 /proc/vmcore /var/crash/201802150350/dump-incomplete
> Checking for memory holes : [100.0 %] |
> readpage_elf: Attempt to read non-existent page at 0x4d39b30000.
> [ 22.378312] kdump-tools[1360]: readmem: type_addr: 0,
> addr:c000004d39b37140, size:16384
> [ 22.378411] kdump-tools[1360]: __exclude_unnecessary_pages: Can't read
> the buffer of struct page.
> [ 22.378538] kdump-tools[1360]: create_2nd_bitmap: Can't exclude
> unnecessary pages.
> Checking for memory holes : [100.0 %] -
> readpage_elf: Attempt to read non-existent page at 0x4d39b30000.
> [ 22.378708] kdump-tools[1360]: readmem: type_addr: 0,
> addr:c000004d39b37140, size:16384
> [ 22.378779] kdump-tools[1360]: __exclude_unnecessary_pages: Can't read
> the buffer of struct page.
> [ 22.378853] kdump-tools[1360]: create_2nd_bitmap: Can't exclude
> unnecessary pages.
> [ 22.378924] kdump-tools[1360]: makedumpfile Failed.
> [ 22.379014] kdump-tools[1360]: * kdump-tools: makedumpfile failed,
> falling back to 'cp'

Naveed, what was the size of the vmcore saved through 'cp'? What is the total
RAM size on the system? please share the proc/device-tree info (sys.dts) on
the system it failed

$ dtc -I fs /proc/device-tree -O dts -o sys.dts

Thanks
Hari

Breno Leitão (breno-leitao) wrote :

Hi Cascardo,

How are you planning to fix it on 16.04 since package version upgrade is not allowed? Are you going to cherry pick the patches?

Hi, Breno.

I will try to push makedumpfile, kexec-tools and crash on the basis that those new versions are required to support new kernels as the ones that come from linux-hwe. New version upgrades are allowed. Even though the following link [1] mentions microreleases, and we would upgrade from 1.5.9 to 1.6.3, I believe the exception still applies.

However, that means that we will need to test it much more. So, I would like your help with testing that combination on as many environments as possible. If I give you a personal PPA with those packages, will you be able to test it on different scenarios (NUMA systems, like ones with no node 0), systems with large amounts of memory (512GiB and up), etc?

Thanks.
Cascardo.

[1] https://wiki.ubuntu.com/StableReleaseUpdates#New_upstream_microreleases

I opened bug LP#1750021 [1]. It contains a debdiff with what I intent to push to bionic. If you are running one of the latest kernels, that have kpti fixes, it contains an arch-independent patch that breaks kdump. Read the bug for more details.

[1] https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1750021

Now building on my ppa:

sudo add-apt-repository ppa:cascardo/ppa
sudo apt-get update

Any updates on this? Does the makedumpfile version on my ppa for bionic work?

Cascardo.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-02-23 05:57 EDT-------
We have below makedumpfile in bionic-proposed and dump capture works fine.

:~# makedumpfile -v
makedumpfile: version 1.6.3 (released on 29 Jun 2018)
lzo enabled
snappy disabled

Sorry, but that version number is not sufficient. It cannot distinguish between package versions, which might contain patches? When you give a makedumpfile version, can you use dpkg -s makedumpfile?

Also, I need to know which kernel version you dumped with that. And if crash could successfully load it. It might be that makedumpfile dumps (though incorrectly) a newer kernel, but, then, crash won't be able to analyze it. Can you test that? And, please, test the makedumpfile from the ppa.

Thanks.
Cascardo.

bugproxy (bugproxy) wrote :
Download full text (4.7 KiB)

------- Comment From <email address hidden> 2018-02-26 00:13 EDT-------
(In reply to comment #19)
> Sorry, but that version number is not sufficient. It cannot distinguish
> between package versions, which might contain patches? When you give a
> makedumpfile version, can you use dpkg -s makedumpfile?
>
> Also, I need to know which kernel version you dumped with that. And if crash
> could successfully load it. It might be that makedumpfile dumps (though
> incorrectly) a newer kernel, but, then, crash won't be able to analyze it.
> Can you test that? And, please, test the makedumpfile from the ppa.
>
> Thanks.
> Cascardo.

Please find crash tool output below.

-generic dump.201802210519 02210519# crash /usr/lib/debug/boot/vmlinux-4.15.0-10-

crash 7.2.1
Copyright (C) 2002-2017 Red Hat, Inc.
Copyright (C) 2004, 2005, 2006, 2010 IBM Corporation
Copyright (C) 1999-2006 Hewlett-Packard Co
Copyright (C) 2005, 2006, 2011, 2012 Fujitsu Limited
Copyright (C) 2006, 2007 VA Linux Systems Japan K.K.
Copyright (C) 2005, 2011 NEC Corporation
Copyright (C) 1999, 2002, 2007 Silicon Graphics, Inc.
Copyright (C) 1999, 2000, 2001, 2002 Mission Critical Linux, Inc.
This program is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions. Enter "help copying" to see the conditions.
This program has absolutely no warranty. Enter "help warranty" for details.
GNU gdb (GDB) 7.6
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "powerpc64le-unknown-linux-gnu"...

KERNEL: /usr/lib/debug/boot/vmlinux-4.15.0-10-generic
DUMPFILE: dump.201802210519 [PARTIAL DUMP]
CPUS: 1
DATE: Wed Feb 21 05:18:51 2018
UPTIME: 00:04:50
LOAD AVERAGE: 0.01, 0.08, 0.04
TASKS: 105
NODENAME: ubuntu
RELEASE: 4.15.0-10-generic
VERSION: #11-Ubuntu SMP Tue Feb 13 18:21:52 UTC 2018
MACHINE: ppc64le (2250 Mhz)
MEMORY: 2 GB
PANIC: "sysrq: SysRq : Trigger a crash"
PID: 1737
COMMAND: "bash"
TASK: c00000007c44cf00 [THREAD_INFO: c00000007c47c000]
CPU: 0
STATE: TASK_RUNNING (SYSRQ)

crash> bt
PID: 1737 TASK: c00000007c44cf00 CPU: 0 COMMAND: "bash"
#0 [c00000007c47f850] crash_kexec at c0000000001e0930
#1 [c00000007c47f890] oops_end at c0000000000258e8
#2 [c00000007c47f910] bad_page_fault at c00000000006a1e0
#3 [c00000007c47f980] handle_page_fault at c00000000000a560
Data Access [300] exception frame:
R0: c0000000007eb1a8 R1: c00000007c47fc70 R2: c0000000016ea600
R3: 0000000000000063 R4: c00000007fd4ce18 R5: c00000007fd64368
R6: 6967676572206120 R7: 63726173680d0a72 R8: 0000000000000007
R9: 0000000000000001 R10: 0000000000000000 R11: 0000000000000000
R12: c0000000007ea240 R13: c000000007a80000 R14: 000001f7efb34348
R15: 0000000000000000 R16: 000001f7ef96e9f0 R17: 000001f7efa01998
R18: 000001f7efa019d0 R19: 000001f7efa38204 R20: 0000000000000000
R21: 0000000000000001 R22: 000000...

Read more...

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-02-26 02:31 EDT-------
Tested 1:1.5.9-5ubuntu0.6 on 4.13.0-36-generic 16.04.4 .
Makedumpfile fails while kdump and kdump falls back to cp.

# dpkg -s makedumpfile
Package: makedumpfile
Status: install ok installed
Priority: optional
Section: devel
Installed-Size: 425
Maintainer: Ubuntu Developers <email address hidden>
Architecture: ppc64el
Version: 1:1.5.9-5ubuntu0.6
Replaces: kdump-tools (<< 1.3.4-1~)
Depends: libc6 (>= 2.17), libdw1 (>= 0.143), libelf1 (>= 0.142), liblzo2-2, zlib1g (>= 1:1.2.0), perl
Recommends: crash, kexec-tools
Description: VMcore extraction tool
This program is used to extract a subset of the memory available either
via /dev/mem or /proc/vmcore (for crashdumps). It is used to get memory
images without extra unneeded information (zero pages, userspace programs,
etc).
Original-Maintainer: Louis Bouchard <email address hidden>

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-02-26 06:02 EDT-------
(In reply to comment #21)
> Tested 1:1.5.9-5ubuntu0.6 on 4.13.0-36-generic 16.04.4 .
> Makedumpfile fails s/while/during/ kdump and kdump falls back to cp.
>
> # dpkg -s makedumpfile
> Package: makedumpfile
> Status: install ok installed
> Priority: optional
> Section: devel
> Installed-Size: 425
> Maintainer: Ubuntu Developers <email address hidden>
> Architecture: ppc64el
> Version: 1:1.5.9-5ubuntu0.6
> Replaces: kdump-tools (<< 1.3.4-1~)
> Depends: libc6 (>= 2.17), libdw1 (>= 0.143), libelf1 (>= 0.142), liblzo2-2,
> zlib1g (>= 1:1.2.0), perl
> Recommends: crash, kexec-tools
> Description: VMcore extraction tool
> This program is used to extract a subset of the memory available either
> via /dev/mem or /proc/vmcore (for crashdumps). It is used to get memory
> images without extra unneeded information (zero pages, userspace programs,
> etc).
> Original-Maintainer: Louis Bouchard <email address hidden>

===console log===
27.528264] kdump-tools[2637]: Starting kdump-tools: * running makedumpfile -c -d 31 /proc/vmcore /var/crash/201802260113/dump-incomplete
Checking for memory holes : [100.0 %] |/usr/sbin/kdump-config: line 595: 2714 Segmentation fault makedumpfile $MAKEDUMP_ARGS $vmcore_file $KDUMP_CORETEMP
[ 27.648216] kdump-tools[2637]: * kdump-tools: makedumpfile failed, falling back to 'cp'
[ 94.724887] kdump-tools[2637]: * kdump-tools: saved vmcore in /var/crash/201802260113
[ 95.548243] kdump-tools[2637]: * running makedumpfile --dump-dmesg /proc/vmcore /var/crash/201802260113/dmesg.201802260113
[ 95.662597] kdump-tools[2637]: The kernel version is not supported.
[ 95.663151] kdump-tools[2637]: The makedumpfile operation may be incomplete.
[ 95.663574] kdump-tools[2637]: The dmesg log is saved to /var/crash/201802260113/dmesg.201802260113.
[ 95.663992] kdump-tools[2637]: makedumpfile Completed.
[ 95.664296] kdump-tools[2637]: * kdump-tools: saved dmesg content in /var/crash/201802260113
[ 95.749509] kdump-tools[2637]: Mon, 26 Feb 2018 01:14:41 -0600
[ 95.812644] kdump-tools[2637]: Rebooting.
====
# ls -lhrt /var/crash/201802260113/
total 4.9G
-r-------- 1 root root 253G Feb 26 01:14 vmcore.201802260113
-rw------- 1 root root 103K Feb 26 01:14 dmesg.201802260113
====
vmcore size is of RAM size, makedumpfile was failure on 16.04.4

Hi.

As of now, the package is only ready for bionic, so this would need to be tested on bionic. Also, there is a problem on some of the KPTI kernels that includes 4.13 and 4.4 (but not the current 4.15 on bionic). This problem requires a package that is now on my ppa, no you will need to install makedumpfile from that.

As this patch would be required for any xenial backport, I am requesting that you test it on bionic right now, with 4.13 kernel. Otherwise, I can't push something that is not tested on real ppc64el hardware to xenial. Can you do that?

Thank you very much.
Cascardo.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-02-26 08:18 EDT-------
(In reply to comment #24)
> Hi.
>
> As of now, the package is only ready for bionic, so this would need to be
> tested on bionic. Also, there is a problem on some of the KPTI kernels that
> includes 4.13 and 4.4 (but not the current 4.15 on bionic). This problem
> requires a package that is now on my ppa, no you will need to install
> makedumpfile from that.
>
> As this patch would be required for any xenial backport, I am requesting
> that you test it on bionic right now, with 4.13 kernel. Otherwise, I can't
> push something that is not tested on real ppc64el hardware to xenial. Can
> you do that?
>
> Thank you very much.
> Cascardo.

Thank you Cascardo for the reply,

We tested in couple of systems with 512GB RAM and we are able to use your makedumpfile to dump the vmcore on 4.13.0-32-generic kernel on Bionic.

==console log===

# dpkg -s makedumpfile
Package: makedumpfile
Status: install ok installed
Priority: optional
Section: devel
Installed-Size: 493
Maintainer: Louis Bouchard <email address hidden>
Architecture: ppc64el
Version: 1:1.6.3-1ubuntu1
Replaces: kdump-tools (<< 1.3.4-1~)
Depends: libc6 (>= 2.17), libdw1 (>= 0.143), libelf1 (>= 0.142), liblzo2-2, zlib1g (>= 1:1.2.0), perl:any
Recommends: crash, kexec-tools
Description: VMcore extraction tool
This program is used to extract a subset of the memory available either
via /dev/mem or /proc/vmcore (for crashdumps). It is used to get memory
images without extra unneeded information (zero pages, userspace programs,
etc).

Starting Kernel crash dump capture service...
[ 26.303566] kdump-tools[1369]: Starting kdump-tools: * running makedumpfile -c -d 31 /proc/vmcore /var/crash/201802260805/dump-incomplete
Copying data : [100.0 %] | eta: 0s
[ 57.183844] kdump-tools[1369]: The dumpfile is saved to /var/crash/201802260805/dump-incomplete.
[ 57.183934] kdump-tools[1369]: makedumpfile Completed.
[ 57.194154] kdump-tools[1369]: * kdump-tools: saved vmcore in /var/crash/201802260805
[ 60.095854] kdump-tools[1369]: * running makedumpfile --dump-dmesg /proc/vmcore /var/crash/201802260805/dmesg.201802260805
[ 60.135142] kdump-tools[1369]: The dmesg log is saved to /var/crash/201802260805/dmesg.201802260805.
[ 60.135301] kdump-tools[1369]: makedumpfile Completed.
[ 60.135439] kdump-tools[1369]: * kdump-tools: saved dmesg content in /var/crash/201802260805
[ 60.446625] kdump-tools[1369]: Mon, 26 Feb 2018 08:06:14 -0500
[ 60.736484] kdump-tools[1369]: Rebooting.
===========

Can you point this makedumpfile over web link which we can wget to install it on 16.04.4 (reason we are asking this is, we will be doing hardware certifications and kdump test will fail on 16.04.4)

We request for your comment on inclusion of this version makedumpfile on 16.04.4 after we test it.

Manoj Iyer (manjo) on 2018-03-05
Changed in ubuntu-power-systems:
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Changed in makedumpfile (Ubuntu Xenial):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Changed in makedumpfile (Ubuntu Artful):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Changed in makedumpfile (Ubuntu Xenial):
importance: Undecided → High
Changed in makedumpfile (Ubuntu Artful):
importance: Undecided → High
tags: added: triage-g

Hello bugproxy, or anyone else affected,

Accepted makedumpfile into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/makedumpfile/1:1.6.3-2~17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in makedumpfile (Ubuntu Artful):
status: New → Fix Committed
tags: added: verification-needed verification-needed-artful
Łukasz Zemczak (sil2100) wrote :

Hello bugproxy, or anyone else affected,

Accepted makedumpfile into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/makedumpfile/1:1.6.3-2~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in makedumpfile (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial

------- Comment From <email address hidden> 2018-06-05 06:56 EDT-------
Dump captured successfully on Xenial with makedumpfile verion 1:1.6.3-2~16.04.1.
Tested successfully with kernel versions linux-image-4.13.0-43-generic &
linux-image-4.15.0-23-generic

But analyzing the dump failed with the crash tool version 7.1.4-1ubuntu4.2, shipped
with 16.04.4. Failed with similar errors as reported in launchpad bug 1746088.

Using the crash tool version 7.2.1-1 shipped with bionic, was able to analyze the
dumps successfully.

Thanks
Hari

tags: added: verification-done-xenial
removed: verification-needed-xenial
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-06-05 08:55 EDT-------
(In reply to comment #30)
> Dump captured successfully on Xenial with makedumpfile verion
> 1:1.6.3-2~16.04.1.
> Tested successfully with kernel versions linux-image-4.13.0-43-generic &
> linux-image-4.15.0-23-generic
>
> But analyzing the dump failed with the crash tool version 7.1.4-1ubuntu4.2,
> shipped
> with 16.04.4. Failed with similar errors as reported in launchpad bug
> 1746088.
>
> Using the crash tool version 7.2.1-1 shipped with bionic, was able to
> analyze the
> dumps successfully.
>

Similar story on artful. Captured dump successfully on artful - kernel version
linux-image-4.13.0-43-generic, using makedumpfile verion 1:1.6.3-2~17.10.1

But vmalloc address translation failed while analyzing the dump with the
crash tool version 7.1.9-1 shipped with 17.10.1.

Though, was able to analyze the dump successfully using the crash tool
version 7.2.1-1 shipped with bionic.

Thanks
Hari

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful

The verification of the Stable Release Update for makedumpfile has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package makedumpfile - 1:1.6.3-2~17.10.1

---------------
makedumpfile (1:1.6.3-2~17.10.1) artful; urgency=medium

  * Backport latest makedumpfile to artful. (LP: #1746299)

 -- Thadeu Lima de Souza Cascardo <email address hidden> Mon, 21 May 2018 10:56:29 -0300

Changed in makedumpfile (Ubuntu Artful):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package makedumpfile - 1:1.6.3-2~16.04.1

---------------
makedumpfile (1:1.6.3-2~16.04.1) xenial; urgency=medium

  * Backport latest makedumpfile to xenial. (LP: #1746299)
  * Revert to build-depending on dh-systemd, as xenial does not have
    debhelper >= 9.20160709.

 -- Thadeu Lima de Souza Cascardo <email address hidden> Mon, 21 May 2018 11:02:15 -0300

Changed in makedumpfile (Ubuntu Xenial):
status: Fix Committed → Fix Released
Manoj Iyer (manjo) on 2018-06-11
Changed in ubuntu-power-systems:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers