kdump-tools install script uses deprecated syntax

Bug #1599491 reported by Jason Yundt on 2016-07-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
makedumpfile (Ubuntu)
Low
Louis Bouchard
Xenial
Low
Louis Bouchard

Bug Description

[SRU justification]
Error message polluting the installation

[Impact]
Wrongfully implies a problem with the installation

[Fix]
Remove unneeded dh_installinit override

[Test Case]
Install kdump-tools on Xenial. Without the fix, the installation will complain with :

update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults

This message does not appear with the fix

[Regression]
None expected. update-rc.d default is used as a fallback.

[Original description of the problem]

When installing kdump-tools, the apt-get outputs:

Setting up kdump-tools (1:1.5.9-5) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults

Full log:

jayman@jayman-kubuntu:~$ sudo apt-get install kdump-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  crash kexec-tools libdw1 makedumpfile
The following NEW packages will be installed:
  crash kdump-tools kexec-tools libdw1 makedumpfile
0 upgraded, 5 newly installed, 0 to remove and 10 not upgraded.
Need to get 0 B/2,962 kB of archives.
After this operation, 9,379 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Preconfiguring packages ...
Selecting previously unselected package crash.
(Reading database ... 235512 files and directories currently installed.)
Preparing to unpack .../crash_7.1.4-1ubuntu4_amd64.deb ...
Unpacking crash (7.1.4-1ubuntu4) ...
Selecting previously unselected package libdw1:amd64.
Preparing to unpack .../libdw1_0.165-3ubuntu1_amd64.deb ...
Unpacking libdw1:amd64 (0.165-3ubuntu1) ...
Selecting previously unselected package makedumpfile.
Preparing to unpack .../makedumpfile_1%3a1.5.9-5_amd64.deb ...
Unpacking makedumpfile (1:1.5.9-5) ...
Selecting previously unselected package kexec-tools.
Preparing to unpack .../kexec-tools_1%3a2.0.10-1ubuntu2_amd64.deb ...
Unpacking kexec-tools (1:2.0.10-1ubuntu2) ...
Selecting previously unselected package kdump-tools.
Preparing to unpack .../kdump-tools_1%3a1.5.9-5_all.deb ...
Unpacking kdump-tools (1:1.5.9-5) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.23-0ubuntu3) ...
Processing triggers for systemd (229-4ubuntu6) ...
Processing triggers for ureadahead (0.100.0-19) ...
Setting up crash (7.1.4-1ubuntu4) ...
Setting up libdw1:amd64 (0.165-3ubuntu1) ...
Setting up makedumpfile (1:1.5.9-5) ...
Setting up kexec-tools (1:2.0.10-1ubuntu2) ...
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.4.0-28-generic
Found initrd image: /boot/initrd.img-4.4.0-28-generic
Found linux image: /boot/vmlinuz-4.4.0-24-generic
Found initrd image: /boot/initrd.img-4.4.0-24-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your device.map.
Found Windows 7 (loader) on /dev/sda1
done
Setting up kdump-tools (1:1.5.9-5) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Processing triggers for libc-bin (2.23-0ubuntu3) ...
jayman@jayman-kubuntu:~$

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: kdump-tools 1:1.5.9-5
ProcVersionSignature: Ubuntu 4.4.0-28.47-generic 4.4.13
Uname: Linux 4.4.0-28-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: KDE
Date: Wed Jul 6 08:02:53 2016
InstallationDate: Installed on 2016-06-16 (19 days ago)
InstallationMedia: Kubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
SourcePackage: makedumpfile
UpgradeStatus: No upgrade log present (probably fresh install)

Jason Yundt (swagfortress) wrote :
Louis Bouchard (louis) on 2016-07-15
Changed in makedumpfile (Ubuntu):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Louis Bouchard (louis-bouchard)
Louis Bouchard (louis) on 2016-07-15
Changed in makedumpfile (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Louis Bouchard (louis-bouchard)
Louis Bouchard (louis) on 2016-07-15
Changed in makedumpfile (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package makedumpfile - 1:1.6.0-2

---------------
makedumpfile (1:1.6.0-2) sid; urgency=medium

  * define_stampdir() : Loop on hostname -I for 5 sec to get IP address
    if HOSTTAG=ip. The network stack may not be ready when kdump-config runs.
    Give it some time before reverting HOSTTAG to hostname if an IP address
    cannot be found. (LP: #1599561)

  * debian/rules : drop the dh_installinit override
    Uses a syntax which is no longer supported and generate an error on
    install. (LP: #1599491)

 -- Louis Bouchard <email address hidden> Fri, 15 Jul 2016 17:25:33 +0200

Changed in makedumpfile (Ubuntu):
status: In Progress → Fix Released

Hello Jason, or anyone else affected,

Accepted makedumpfile into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/makedumpfile/1:1.5.9-5ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in makedumpfile (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed
Louis Bouchard (louis) on 2016-07-22
description: updated
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package makedumpfile - 1:1.5.9-5ubuntu0.1

---------------
makedumpfile (1:1.5.9-5ubuntu0.1) xenial; urgency=medium

  [ Hari Bathini <email address hidden> ]
  * Fix networked kdump failure to reach remote server.
    Avoids "Network is unreachable" message when trying to do remote dumps on
    either SSH or NFS. (LP: #1571590)

  * Replace maxcpus by nr_cpus
    nr_cpus is a hard limit that has an impact on the (kdump) kernel
    memory consumption, while it is not the case with maxcpus=1, as we can
    theoretically hotplug cpus with maxcpus=1 (LP: #1568952)

  * define_stampdir() : Loop on hostname -I for 5 sec to get IP address
    if HOSTTAG=ip. The network stack may not be ready when kdump-config runs.
    Give it some time before reverting HOSTTAG to hostname if an IP address
    cannot be found. (LP: #1599561)

  * Add cio_ignore result to /etc/default/kdump-tools on s390x
    In order to have crashkernel=128M to work correctly on the s390
    architecture the result of cio_ignore -u -k needs to be appended to the
    KDUMP_CMDLINE_APPEND variable in /etc/default/kdump-tools. This patch
    adds the required logic to do the proper modification. (LP: #1570775)

  * debian/rules : drop the dh_installinit override
    Uses a syntax which is no longer supported and generate an error on
    install. (LP: #1599491)

 -- Louis Bouchard <email address hidden> Fri, 22 Jul 2016 10:15:20 +0200

Changed in makedumpfile (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for makedumpfile has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers