makedumpfile generates kernel version error

Bug #1557751 reported by bugproxy on 2016-03-15
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
High
Unassigned
makedumpfile (Ubuntu)
Medium
Taco Screen team
Trusty
Medium
Louis Bouchard
Xenial
Medium
Unassigned
Yakkety
Medium
Louis Bouchard

Bug Description

== Comment: #7 - Vaishnavi Bhat - 2016-03-15 06:16:53 ==
The following warning is generated by makedumpfile
* running makedumpfile --dump-dmesg /proc/vmcore /mnt/201602030129/dmesg.201602030129
The kernel version is not supported.
The created dumpfile may be incomplete.

The makedumpfile version on your machine is
# makedumpfile -v
makedumpfile: version 1.5.5 (released on 18 Dec 2013)

I did a #sudo apt-get source makedumpfile and checked for the sources.
In the makedumpfile.h , the LATEST_VERSION is set to
#define OLDEST_VERSION KERNEL_VERSION(2, 6, 15)/* linux-2.6.15 */
#define LATEST_VERSION KERNEL_VERSION(4, 1, 0)/* linux-4.1.0 */
where as kernel version on the machine is
# uname -r
4.2.0-27-generic

Hence we see this mismatch and message as "The kernel version is not supported."

We need canonical to change the value of LATEST_VERSION so that we do not see this message.

Default Comment by Bridge

tags: added: architecture-ppc64le bugnameltc-136481 severity-high targetmilestone-inin14044

Default Comment by Bridge

Changed in ubuntu:
assignee: nobody → Taco Screen team (taco-screen-team)
Kevin W. Rudd (kevinr) on 2016-03-15
affects: ubuntu → makedumpfile (Ubuntu)
Louis Bouchard (louis) wrote :

Hello,

The reason for this verification is that version 1.5.5 of makedumpfile was tested on kernels up to 4.1 and not later. Fixing that is not just to trivially change the entry in the file. It requires verification that makedumpfile will indeed work for newer kernels.

Since the upcoming release of Xenial will introduce a 4.4 kernel in trusty, it will also become apparent for 4.4 kernels.

I am going to verify if this version limit can be bumped up to 4.4 which will resolve your problem.

Louis Bouchard (louis) on 2016-03-16
Changed in makedumpfile (Ubuntu):
status: New → Confirmed
Changed in makedumpfile (Ubuntu Trusty):
status: New → Confirmed
Changed in makedumpfile (Ubuntu):
importance: Undecided → Medium
Changed in makedumpfile (Ubuntu Trusty):
importance: Undecided → Medium
assignee: nobody → Louis Bouchard (louis-bouchard)
Louis Bouchard (louis) wrote :

Hi,

First of all, I was wrong in my previous statement : 1.5.5 currently supports kernels up to 3.19. The source code that you cite is for 1.5.9 that is only available in Xenial.

Secondly, there is no upstream version that supports kernel up to 4.2 since 1.5.9 is the last released upstream version. The current plans for the next upstream version is to support kernels up to 4.2 so the problem will remain with the lts-xenial kernel.

After reviewing the differences between 1.5.5 and 1.5.9, I only see one kernel specific commit of interest, and it only enhances the current behavior by using newly exported kernel information not available beforehand. This will not impair the current functionality.

So I am not in a position to overrule upstream's decision to warn about the fact that kernels above 4.1 are not supported.

I could backport the current situation but it will do you no good as it will only bring the limit to 4.1. I prefer to wait for the newer release that will provide a wider span of version support.

I will get in touch with upstream to see if there is any plan to bring support for earlier kernels and up to what version they plan to confirm support.

Kind regards

------- Comment From <email address hidden> 2016-05-18 06:43 EDT-------
I see the issue on Xenial also, but the current kernel is 4.4.0-18. Getting upstream to support only upto kernel version 4.2 would not solve it for Xenial.

Thanks!

Louis Bouchard (louis) wrote :

After talking with upstream, the new version should come sometimes in may with support for newer kernels. At the moment, this message can be disregarded as a warning since there is no kernel specific issue up to k4.5

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2016-06-16 07:53 EDT-------
(In reply to comment #15)
> After talking with upstream, the new version should come sometimes in may
> with support for newer kernels. At the moment, this message can be
> disregarded as a warning since there is no kernel specific issue up to k4.5

Hi Louis,

Now that we have makedumpfile v1.6.0 that supports kernel till v4.5.3,
can we expect that to be pushed into trusty & xenial as well?

Thanks
Hari

Luciano Chavez (lnx1138) wrote :

Hello,

Since we see this in xenial as well, will there be a track opened for delivery of a fix there as well? Thanks.

Louis Bouchard (louis) on 2017-01-11
Changed in makedumpfile (Ubuntu Xenial):
status: New → Confirmed
Changed in makedumpfile (Ubuntu Yakkety):
status: New → Confirmed
Changed in makedumpfile (Ubuntu Xenial):
importance: Undecided → Medium
Changed in makedumpfile (Ubuntu Yakkety):
importance: Undecided → Medium
Changed in makedumpfile (Ubuntu Xenial):
assignee: nobody → Louis Bouchard (louis-bouchard)
Changed in makedumpfile (Ubuntu Yakkety):
assignee: nobody → Louis Bouchard (louis-bouchard)
Louis Bouchard (louis) on 2017-01-11
Changed in makedumpfile (Ubuntu):
status: Confirmed → Fix Released

Hello bugproxy, or anyone else affected,

Accepted makedumpfile into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/makedumpfile/1:1.5.9-5ubuntu0.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in makedumpfile (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed
Louis Bouchard (louis) on 2017-02-23
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package makedumpfile - 1:1.5.9-5ubuntu0.4

---------------
makedumpfile (1:1.5.9-5ubuntu0.4) xenial; urgency=medium

  * d/p/0006-PATCH-Support-newer-kernels.patch :
    Support kernel versions up to 4.8 (LP: #1557751)
  * Turn hardcoded timeo and retrans NFS options into parameters that
    can be modified in /etc/default/kdump-tools. Also use the NFS defaults
    (timeo=600, retrans=3) for these parameters. Make those values visible
    in the 'show' command if NFS is configured (LP: #1641235)
  * Complete support for kernel versions 4.8 and later :
    d/p/0007-PATCH-Looking-for-page.compound_order-compound_dtor-.patch,
    d/p/0008-PATCH-Skip-examining-compound-tail-pages.patch (LP: #1655625)

 -- Louis Bouchard <email address hidden> Wed, 11 Jan 2017 11:33:42 +0100

Changed in makedumpfile (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for makedumpfile has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Louis Bouchard (louis) on 2017-03-06
Changed in makedumpfile (Ubuntu Yakkety):
assignee: Louis Bouchard (louis-bouchard) → nobody
assignee: nobody → Louis Bouchard (louis-bouchard)
Changed in makedumpfile (Ubuntu Xenial):
assignee: Louis Bouchard (louis-bouchard) → nobody

Default Comment by Bridge

Changed in ubuntu-power-systems:
status: New → In Progress
Manoj Iyer (manjo) on 2017-07-19
Changed in ubuntu-power-systems:
importance: Undecided → High
Manoj Iyer (manjo) on 2017-07-20
Changed in ubuntu-power-systems:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers