Logrotate is noisy with: Re-opening all log files

Bug #244233 reported by pearcec on 2008-06-30
54
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GNU Mailman
Undecided
Unassigned
mailman (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: mailman

When logrotate runs for mailman you get this:

/etc/cron.daily/logrotate:
Re-opening all log files
Re-opening all log files

It calls mailmanctl reopen. If it called it with a -q it would be quiet.

IMPACT: when rotating the mailman logfiles, 'mailmanctl reopen' is called
from /etc/logrotate.d/mailman, to get mailman to reopen the new logfiles.
For every call, mailman prints message "Re-opening all log files", which
gets sent to the user in a (useless) email.

This was fixed upstream in mailman 2.1.9-10 and Karmic has 2.1.12-2.

TEST CASE:

- install mailman (apt-get install mailman)
- create the default mailman list with the following command:
    newlist mailman
- start mailman (/etc/init.d/mailman start), there should be a couple of
  files in /var/log/mailman
- force a logrotate of these files by running:
    logrotate -f /etc/logrotate.d/mailman
- you should see the following output:

root@utest-hhs32:/var/log/mailman# logrotate -f /etc/logrotate.d/mailman
Re-opening all log files
Re-opening all log files

This is called from crontab so there will be an email sent to users every
time.

- install the patched version, and run the above command again, it should
be quiet, without any messages.

REGRESSION POTENTIAL: low. According to the mailmanctl help page:

    -q/--quiet
      Don't print status messages. Error messages are still printed to
      standard error.

By applying this patch, users will not get the informational messages
but they will still get any error message.

Thijs Kinkhorst (kink) wrote :

This has been fixed since 1:2.1.9-10

Changed in mailman:
status: New → Fix Released

Hm... 8.04 LTS Server (Hardy) doesn't seem to have that fix yet.

Stas Sușcov (sushkov) wrote :

Fix released... Not in hardy!

$apt-cache policy mailman
mailman:
  Installed: 1:2.1.9-9ubuntu1
  Candidate: 1:2.1.9-9ubuntu1
...

Serge van Ginderachter (svg) wrote :

This bug is not resolved as the fixe was not released to LTS.

Petri Koistinen (pkoistin) wrote :

What does this "Declined for Hardy by Thierry Carrez" means, what is the reasoning behind declining this update to hardy (8.04 LTS) release?

Petri Koistinen (pkoistin) wrote :
Changed in mailman (Ubuntu):
assignee: nobody → Thierry Carrez (ttx)
status: Fix Released → Incomplete
Thierry Carrez (ttx) wrote :

Bug is fix released in the current development version.
Bug was rejected for hardy SRU since stable release updates are here to address "high-impact" bugs, and during review this was not considered to be high-impact.
See https://wiki.ubuntu.com/StableReleaseUpdates#When

Changed in mailman (Ubuntu):
assignee: Thierry Carrez (ttx) → nobody
status: Incomplete → Fix Released
Petri Koistinen (pkoistin) wrote :

I think this fits just fine to this definition:

* Bugs which do not fit under above categories, but (1) have an obviously safe patch and (2) affect an application rather than critical infrastructure packages (like X.org or the kernel).

Changed in mailman (Ubuntu):
status: Fix Released → Incomplete
assignee: nobody → Thierry Carrez (ttx)
Thierry Carrez (ttx) wrote :

Approved, please follow https://wiki.ubuntu.com/StableReleaseUpdates#Procedure to submit SRU for consideration.

Changed in mailman (Ubuntu):
status: Incomplete → Triaged
assignee: Thierry Carrez (ttx) → nobody
Petri Koistinen (pkoistin) wrote :

It seems that I can't use "Nominate for release" as this has been previously declined for Hardy.

Changed in mailman (Ubuntu):
status: Triaged → Fix Released
Thierry Carrez (ttx) wrote :

@Petri: I thought I had nominated/approved it. Done now, sorry for the noise.

Imre Gergely (cemc) wrote :

I've updated the bug description with some details for a SRU and I've tested the patch provided by pearcec and it's working as expected.

description: updated
description: updated
description: updated
Imre Gergely (cemc) wrote :

Attached debdiff.

description: updated
Scott Moser (smoser) wrote :

Imre,
  Thanks for the debdiff.

I'm not able to sponsor this, but looked at the patch, and it is an exact backport of the commit to debian/mailman.logrotate at
at [1]. I can +1 the patch.

--
[1] http://bazaar.launchpad.net/%7Eubuntu-branches/ubuntu/natty/mailman/natty/revision/17/debian/mailman.logrotate#debian/mailman.logrotate

Accepted mailman into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in mailman (Ubuntu Hardy):
status: New → Fix Committed
tags: added: verification-needed
Imre Gergely (cemc) wrote :

Did the test case and everythings seems ok.

root@utest-hhs32:~# apt-cache policy mailman
mailman:
  Installed: 1:2.1.9-9ubuntu1.2
  Candidate: 1:2.1.9-9ubuntu1.2
  Version table:
 *** 1:2.1.9-9ubuntu1.2 0
        500 http://archive.ubuntu.com hardy-proposed/main Packages
        100 /var/lib/dpkg/status
     1:2.1.9-9ubuntu1.1 0
        500 http://ro.archive.ubuntu.com hardy-updates/main Packages
     1:2.1.9-9ubuntu1 0
        500 http://ro.archive.ubuntu.com hardy/main Packages

root@utest-hhs32:~# ls -la /var/log/mailman/
total 12
drwxrws--- 2 root list 4096 2010-12-15 16:36 .
drwxr-xr-x 11 root root 4096 2010-12-15 16:33 ..
-rw-rw-r-- 1 list list 0 2010-12-15 16:34 error
-rw-rw-r-- 1 list list 729 2010-12-15 16:34 qrunner

root@utest-hhs32:~# logrotate -f /etc/logrotate.d/mailman <--- (notice how there is no message displayed)
root@utest-hhs32:~# ls -la /var/log/mailman/
total 16
drwxrws--- 2 root list 4096 2010-12-15 16:36 .
drwxr-xr-x 11 root root 4096 2010-12-15 16:33 ..
-rw-rw-r-- 1 list list 0 2010-12-15 16:36 error
-rw-rw-r-- 1 list list 0 2010-12-15 16:34 error.1
-rw-rw-r-- 1 list list 729 2010-12-15 16:36 qrunner
-rw-rw-r-- 1 list list 1458 2010-12-15 16:36 qrunner.1

Martin Pitt (pitti) on 2010-12-15
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mailman - 1:2.1.9-9ubuntu1.2

---------------
mailman (1:2.1.9-9ubuntu1.2) hardy-proposed; urgency=low

  * debian/mailman.logrotate: quiet down logrotate for mailman log
    files (LP: #244233)
 -- Imre Gergely <email address hidden> Tue, 07 Dec 2010 23:44:02 +0200

Changed in mailman (Ubuntu Hardy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.