mu4e post-install script breaks on emacs24

Bug #1150593 reported by Titus von der Malsburg on 2013-03-06
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
maildir-utils (Debian)
Fix Released
Unknown
maildir-utils (Ubuntu)
Undecided
Unassigned

Bug Description

The error message was:

In toplevel form:
org-mu4e.el:31:30:Error: Can't find library org
ERROR: install script from mu4e package failed
dpkg: error processing mu4e (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 mu4e
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 12.10
Package: mu4e 0.9.8.5-1
ProcVersionSignature: Ubuntu 3.5.0-25.39-generic 3.5.7.4
Uname: Linux 3.5.0-25-generic x86_64
ApportVersion: 2.6.1-0ubuntu10
AptOrdering:
 maildir-utils: Install
 mu4e: Install
 maildir-utils: Configure
 mu4e: Configure
Architecture: amd64
Date: Wed Mar 6 23:28:24 2013
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2012-11-15 (111 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: maildir-utils
Title: package mu4e 0.9.8.5-1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

tags: removed: need-duplicate-check

org-mode was installed via elpa repositories. After I installed org-mode from Ubuntu repositories, installing the package worked.

era (era) on 2013-07-10
summary: - package mu4e 0.9.8.5-1 failed to install/upgrade: subprocess installed
- post-installation script returned error exit status 1
+ Third-party org-mode install breaks mu4e post-install script
summary: - Third-party org-mode install breaks mu4e post-install script
+ Elpa org-mode package breaks mu4e post-install script

Possible upstream bug http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=686113 suggests installing emacs24-el package would fix this symptom. Not linking at this point because it's not entirely obvious that it's the same problem.

era (era) wrote :

Based on the observations in LP bug #1199553 and the upstream workaround, I'm assuming that the ELPA hint is a red herring, and that this is genuinely the same bug as Debian #686113. Updating accordingly.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in maildir-utils (Ubuntu):
status: New → Confirmed
era (era) wrote :

In duplicate LP bug #1199553, the OP reports a workaround: uninstalling mu4e allows emacs24 to configure correctly, after which point mu4e can be installed as well.

summary: - Elpa org-mode package breaks mu4e post-install script
+ mu4e post-install script breaks on emacs24
Changed in maildir-utils (Debian):
status: Unknown → New
Changed in maildir-utils (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.