Crashes on start (Couldn't open font /usr/share/fonts/truetype/ttf-isabella/Isabella.ttf)

Bug #1360075 reported by Sergey Basalaev
This bug affects 2 people
Affects Status Importance Assigned to Milestone
magicmaze (Debian)
Fix Released
magicmaze (Ubuntu)
Fix Released

Bug Description

When started, crashes with the following stacktrace

$ magicmaze
Starting Magic Maze...
Setting up graphics...
/usr/lib/ruby/vendor_ruby/magicmaze/graphics.rb:170:in `open': Couldn't open font /usr/share/fonts/truetype/ttf-isabella/Isabella.ttf: Couldn't open /usr/share/fonts/truetype/ttf-isabella/Isabella.ttf (SDL::Error)
        from /usr/lib/ruby/vendor_ruby/magicmaze/graphics.rb:170:in `font_init'
        from /usr/lib/ruby/vendor_ruby/magicmaze/graphics.rb:86:in `initialize'
        from /usr/lib/ruby/vendor_ruby/magicmaze/graphics.rb:73:in `new'
        from /usr/lib/ruby/vendor_ruby/magicmaze/graphics.rb:73:in `get_graphics'
        from /usr/lib/ruby/vendor_ruby/magicmaze/game.rb:47:in `init_graphics'
        from /usr/lib/ruby/vendor_ruby/magicmaze/game.rb:32:in `initialize'
        from /usr/games/magicmaze:110:in `new'
        from /usr/games/magicmaze:110:in `<main>'

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: magicmaze
ProcVersionSignature: Ubuntu 3.13.0-34.60-generic
Uname: Linux 3.13.0-34-generic i686
ApportVersion: 2.14.1-0ubuntu3.3
Architecture: i386
CurrentDesktop: KDE
Date: Fri Aug 22 12:34:48 2014
InstallationDate: Installed on 2012-07-06 (776 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
PackageArchitecture: all
SourcePackage: magicmaze
UpgradeStatus: Upgraded to trusty on 2013-03-04 (535 days ago)

Revision history for this message
Sergey Basalaev (sbasalaev) wrote :
Changed in magicmaze (Debian):
status: Unknown → New
summary: - crashes on start
+ Crashes on start (Couldn't open font /usr/share/fonts/truetype/ttf-
+ isabella/Isabella.ttf)
tags: added: utopic vivid
Revision history for this message
Hans Joachim Desserud (hjd) wrote :

I get the same error message when attempting to start magicmaze on Ubuntu 15.04.

The bug report in Debian mentions a workaround which creates a symbolic link so that magicmaze is able to find the font in the place it expects.

# ( cd /usr/share/fonts/truetype/ && ln -s isabella ttf-isabella )

Briefly tried this (with sudo in front of ln) and it seems to make the game able to run at least...

Changed in magicmaze (Ubuntu):
status: New → Confirmed
Revision history for this message
David Daynard (nardholio) wrote :

The game files are written in Ruby, you can also edit them to change the location it looks since it's a plain text file.

Changed in magicmaze (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Hans Joachim Desserud (hjd) wrote :

David: Yes, I didn't think about that. Thanks for the tip. :)

I prepared a small patch which I submitted to the Debian bug report. Hopefully the maintainer will take a look at it soon.

Revision history for this message
David Daynard (nardholio) wrote :

If there is a fix for this why is this package still buggy 3 years later in Ubuntu 18.10. This is code rot. If the package isn't being maintained it needs to be dropped.

Changed in magicmaze (Debian):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package magicmaze -

magicmaze ( unstable; urgency=medium

  [ Andreas Beckmann ]
  * QA upload.
  * Set Maintainer to Debian QA Group. (See: #869294)

  [ Hans Joachim Desserud ]
  * Depend on fonts-isabella now that ttf-isabella is a virtual package.
  * Update isabella path in patch to new location,
    closes: #747046, LP: #1360075.

 -- Andreas Beckmann <email address hidden> Sat, 06 Oct 2018 16:18:35 +0200

Changed in magicmaze (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.