Upgrade madwifi tarball to 0.9.4

Bug #208754 reported by Cristian Aravena Romero on 2008-03-29
4
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.24 (Ubuntu)
Undecided
Unassigned
madwifi-tools (Ubuntu)
Undecided
Unassigned

Bug Description

description: updated
Timo Aaltonen (tjaalton) on 2008-04-02
Changed in linux-restricted-modules-2.6.24:
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-restricted-modules-2.6.24 - 2.6.24.12-14.32

---------------
linux-restricted-modules-2.6.24 (2.6.24.12-14.32) hardy; urgency=low

  * ABI bump to 14.
  * Madwifi 0.9.4 (LP: #208754):
    - fixes compilation for recently released kernel 2.6.24
    - introduces Minstrel rate control algorithm
    - introduces switch to turn ANI (Ambience Noise Immunity) off, which
      can help to improve performance (see also #705)
    - several bug fixes to improve stability
    - now defaults to radiotap headers in monitor mode
    - adds support for variable number of VAPs, tunable via module
      parameter
  * control: Drop the nvidia-kernel-ABIVER dependencies from nvidia-glx*, since
    fglrx is doing just fine without them, and they only create problems
    during upgrades when apt selects the first package to provide the
    virtual package. (LP: #188287)
  * ltmodem/serial.c: Modify to compile with 2.6.24. Enable ltmodem again.
    (LP: #210652)
  * Add openvz flavour.

 -- Timo Aaltonen <email address hidden> Thu, 03 Apr 2008 01:45:22 +0300

Changed in linux-restricted-modules-2.6.24:
status: In Progress → Fix Released
Martin Jackson (mhjacks) wrote :

I am getting I/O errors on my Hardy system when trying to use the 2.6.24-15 kernel with the current (0.9.3-based) madwifi-tools:

root@glamdring:~# wlanconfig ath0 create wlandev wifi0 wlanmode ap
wlanconfig: ioctl: Input/output error

root@glamdring:~# dpkg -l | grep madwifi
ii madwifi-tools 1:0.9.3+dfsg-3 tools for the Multiband Atheros Driver for W
root@glamdring:~# uname -a
Linux glamdring 2.6.24-15-generic #1 SMP Fri Apr 4 03:48:31 UTC 2008 i686 GNU/Linux

I'm not entirely sure this is the cause, but it's certainly plausible. :) If you need more info, I can provide it.

Release for linux-restricted-modules, not for package madwifi-tools

Changed in madwifi-tools:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers