running just the command "maas" causes an error

Bug #974046 reported by Rick Spencer on 2012-04-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
maas (Ubuntu)
High
Andres Rodriguez
Quantal
High
Andres Rodriguez

Bug Description

I installed Ubuntu Server and Maas in a Virtual Machine. I ran "maas" expecting to get command line help, but instead received a crash.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: maas 0.1+bzr415+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Thu Apr 5 10:19:24 2012
InstallationMedia: Ubuntu-Server 12.04 LTS "Precise Pangolin" - Beta amd64 (20120327)
MAASLog:

PackageArchitecture: all
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions:
 python-django-maas 0.1+bzr415+dfsg-0ubuntu1
 apparmor 2.7.102-0ubuntu1
SourcePackage: maas
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.maas.maas.local.settings.py: [modified]
modified.conffile..etc.maas.pserv.yaml: [modified]
modified.conffile..etc.maas.txlongpoll.yaml: [modified]
mtime.conffile..etc.maas.maas.local.settings.py: 2012-04-05T10:08:02.280281
mtime.conffile..etc.maas.pserv.yaml: 2012-04-05T10:07:51.322806
mtime.conffile..etc.maas.txlongpoll.yaml: 2012-04-05T10:07:55.412849

Andres Rodriguez (andreserl) wrote :

Traceback (most recent call last):
  File "/usr/bin/django-admin", line 5, in <module>
    management.execute_from_command_line()
  File "/usr/lib/python2.7/dist-packages/django/core/management/__init__.py", line 429, in execute_from_command_line
    utility.execute()
  File "/usr/lib/python2.7/dist-packages/django/core/management/__init__.py", line 368, in execute
    sys.stderr.write(self.main_help_text() + '\n')
  File "/usr/lib/python2.7/dist-packages/django/core/management/__init__.py", line 239, in main_help_text
    commands = get_commands().keys()
  File "/usr/lib/python2.7/dist-packages/django/core/management/__init__.py", line 101, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/lib/python2.7/dist-packages/django/utils/functional.py", line 276, in __getattr__
    self._setup()
  File "/usr/lib/python2.7/dist-packages/django/conf/__init__.py", line 42, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/lib/python2.7/dist-packages/django/conf/__init__.py", line 139, in __init__
    logging_config_func(self.LOGGING)
  File "/usr/lib/python2.7/logging/config.py", line 777, in dictConfig
    dictConfigClass(config).configure()
  File "/usr/lib/python2.7/logging/config.py", line 575, in configure
    '%r: %s' % (name, e))
ValueError: Unable to configure handler 'log': [Errno 13] Permission denied: '/var/log/maas/maas.log'

Changed in maas (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in maas (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
status: Confirmed → In Progress
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/974046

tags: added: iso-testing
Kate Stewart (kate.stewart) wrote :

Since this is associated with a manditory test, and is key functionality not working for A3, upping the importance on this bug.

Changed in maas (Ubuntu):
importance: Medium → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 0.1+bzr777+dfsg-0ubuntu1

---------------
maas (0.1+bzr777+dfsg-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release
  * Only run 'maas' command as root. (LP: #974046)
    - debian/extras/maas: Check id.
    - debian/maas.install: Install in 'sbin'.
  * debian/maas.postinst:
    - restart apache2 after everything gets processed.
    - Update version to handle upgrades.
  * debian/extras/maas-provision: Add wrapper to access 'maasprovisiong'
    command line.
  * debian/patches/99_temporary_fix_path.patch: Dropped. No longer needed.
 -- Andres Rodriguez <email address hidden> Tue, 17 Jul 2012 08:28:36 -0400

Changed in maas (Ubuntu Quantal):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers