[FFe] FFe for 20.04 snap transition

Bug #1861096 reported by Adam Collard on 2020-01-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
maas (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu Focal currently has MAAS 2.6.0.

This is a Feature Freeze Exception request for MAAS to allow the package to move to a snap transition. Learning from, and copying code from the LXD snap transition, along with support in `do-release-upgrade` the MAAS team plans to release future MAAS versions as a snap.

Existing users will have their < 20.04 .deb upgraded to a snap installation, using the correct track and architecture for the expected release.

The binary packages from this package will be consolidated down to a single one which will contain the deb to snap transition logic.

Data migration
==============

Existing data will be untouched, and the snap configured to use whatever db is currently in use.

Testing
=======

Tests will be performed in several scenarios that cover the risks, notably:

- snapd package not installed
- airgapped environments which e.g. cannot reach the Snap Store
- i386 architecture transition

For more information on the QA process MAAS follows, please see https://wiki.ubuntu.com/MAASUpdates .

Related branches

description: updated
Alberto Donato (ack) wrote :

WRT i386, as focal won't support the arch anymore, no maas update will be available for i386 users.

Changed in maas (Ubuntu):
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers