[SRU] MAAS 2.4.2

Bug #1788641 reported by Andres Rodriguez on 2018-08-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
maas (Ubuntu)
High
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]
This is a new upstream release that addresses various issues present in 2.4.2.

MAAS 2.4.2 fixes various issues that were present on MAAS 2.4.2.

https://launchpad.net/maas/+milestone/2.4.1
https://launchpad.net/maas/+milestone/2.4.2

This point release includes fixes/enhancements for hardware enablement and to address customer related issues that are worth noting:

Enhancements
------------

LP: #1779712 [enhancement] maas-proxy port should be configurable
Adds the ability to change the proxy port for the proxy that MAAS uses. If users upgrade, the configuration rendered will continue to use the default port. This will only take effect for users who change the port.

Regression potential: None. MAAS will continue to behave the same way it did before in new installs and upgrades, by using the default port. This change only takes effect by a user driven action.

LP: #1778710 [2.3] Allow telling MAAS image import to not use proxy.
Allow's users to tell MAAS to import images without using the configured proxy, in cases that MAAS is directly connected to the internet but machines are not.

Regression potential: None. MAAS will continue to behave the same way it did before in new installs and upgrades, this would only take effect by a user driven action.

Resource Pools UI - MAAS 2.4.1 adds API & UI for resource pools. Al

Regression potential: Minimal. This is minimal because it doesn't affect the current operation provided that everything already released in 2.4.0 already included the resource pools feature. This only adds the missing API endpoints and UI that's already been released in 2.5.

Remote authentication - Adds improvements to remote authentication support.

Regression potential: Minimal, given that this is never enabled. This fixes the support for remote authentication against idm.

[Test Case]

MAAS Testing
------------
MAAS testing has been done in various cases, partially documented https://wiki.ubuntu.com/MAASUpdates. This include:

1. Manual Fresh installation of MAAS
2. Manual upgrade from the previous Ubuntu Release.
3. Automated (CI) testing of MAAS install and operation as per the MAAS' CI.
4. Automated (CI) testing of MAAS install and operation against other Canonical's product (juju, Canonical OpenStack & Kubernetes) provided by the Canonical Solutions QA Team.
5. Manual split region/rack test are performed. This is to ensure that if we upgrade a MAAS Region to a newer version, the MAAS rack of the older version remains connected and operational.

All of this includes verifying normal operation, issues fixed, and ensuring that Canonical Cloud solutions can inter-operate.

Solutions QA
------------
MAAS releases are also now vetted by the Solutions QA team. The test they run ensure there are no regression for their use cases. This release has been accepted / vetted by them.

[Regression Potential]

Minimal (For MAAS itself).
MAAS is fully backwards compatible and handles upgrades from previous releases which result in the continuous operation of MAAS. Users will continue to use this new version of MAAS as they used it before.

Since this is a point release, this has been tested thoroughly to confirm that no regressions have been introduced.

description: updated
description: updated
summary: - [SRU] MAAS 2.4.1
+ [SRU] MAAS 2.4.3
summary: - [SRU] MAAS 2.4.3
+ [SRU] MAAS 2.4.2
Changed in maas (Ubuntu):
status: New → In Progress
importance: Undecided → High
description: updated
description: updated

Hello Andres, or anyone else affected,

Accepted maas into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/2.4.2-7034-g2f5deb8b8-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in maas (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Andres Rodriguez (andreserl) wrote :
Download full text (114.9 KiB)

I;ve tested this both manually and CI and confirm that is good to go. Partial logs from CI testing:

Reading package lists...
Building dependency tree...
Reading state information...
Correcting dependencies...Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
 Done
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following additional packages will be installed:
  archdetect-deb authbind autoconf automake autopoint autotools-dev
  avahi-daemon avahi-utils bind9 bind9utils build-essential chrony cpp cpp-7
  curtin-common dbconfig-common dbconfig-pgsql debhelper devscripts
  dh-autoreconf dh-strip-nondeterminism distro-info docutils-common fakeroot
  formencode-i18n freeipmi-common freeipmi-tools g++ g++-7 gcc gcc-7 gettext
  ieee-data intltool-debian isc-dhcp-server libarchive-zip-perl libasan4
  libatomic1 libavahi-client3 libavahi-common-data libavahi-common3
  libavahi-core7 libc-dev-bin libc6-dev libcc1-0 libcilkrts5 libcroco3
  libdaemon0 libdbi-perl libdebian-installer4 libecap3 libfakeroot
  libfile-homedir-perl libfile-stripnondeterminism-perl libfile-which-perl
  libfreeipmi16 libgcc-7-dev libgomp1 libipmiconsole2 libipmidetect0
  libirs-export160 libisccfg-export160 libisl19 libitm1 libjs-angularjs
  libjs-jquery libjs-sphinxdoc libjs-underscore liblsan0 libltdl7 libmpc3
  libmpx2 libnspr4 libnss3 libpq5 libprotobuf10 libpython-stdlib
  libpython2.7-minimal libpython2.7-stdlib libquadmath0 libsodium23
  libstdc++-7-dev libtimedate-perl libtool libtsan0 libubsan0 libuv1
  libvirt-clients libvirt0 libyajl2 linux-libc-dev m4 maas maas-cli
  maas-common maas-dhcp maas-dns maas-proxy maas-rack-controller
  maas-region-api maas-region-controller pep8 po-debconf postgresql
  postgresql-10 postgresql-client postgresql-client-10
  postgresql-client-common postgresql-common pxelinux pycodestyle pyflakes
  python python-babel-localedata python-django-common python-minimal
  python-pkg-resources python-pyflakes python2.7 python2.7-minimal
  python3-alabaster python3-attr python3-automat python3-babel python3-bson
  python3-constantly python3-convoy python3-crochet python3-curtin
  python3-django python3-django-maas python3-django-piston3
  python3-djorm-ext-pgarray python3-dnspython python3-docutils python3-extras
  python3-fixtures python3-formencode python3-hyperlink python3-imagesize
  python3-incremental python3-iso8601 python3-linecache2 python3-lxml
  python3-maas-client python3-maas-provisioningserver python3-macaroonbakery
  python3-mimeparse python3-mock python3-nacl python3-netaddr
  python3-netifaces python3-nose python3-oauth python3-openssl
  python3-paramiko python3-pbr python3-petname python3-pexpect python3-ply
  python3-prettytable python3-protobuf python3-psycopg2 python3-ptyprocess
  python3-pyasn1 python3-pyasn1-modules python3-pycodestyle python3-pygments
  python3-pymacaroons python3-pyparsing python3-pyvmomi python3-rfc3339
  python3-roman python3-seamicroclient python3-service-identity
  python3-setuptools python3-simplejson python3-simplestreams python3-sphinx
  python3-tempita python3-testtools python3-traceb...

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for maas has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 2.4.2-7034-g2f5deb8b8-0ubuntu1

---------------
maas (2.4.2-7034-g2f5deb8b8-0ubuntu1) bionic-proposed; urgency=medium

  * Stable Release Update. New upstream release, MAAS 2.4.2 (LP: #1788641)

 -- Andres Rodriguez <email address hidden> Thu, 23 Aug 2018 11:29:47 -0400

Changed in maas (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in maas (Ubuntu):
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers