[SRU] MAAS 2.2.2

Bug #1708651 reported by Andres Rodriguez on 2017-08-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
maas (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned

Bug Description

[Impact]
This is a new upstream release that addresses various upstream bugs. MAAS 2.2.2 does NOT introduce any new features.

Please see CHANGELOG for further details.

[Test Case]
MAAS testing has been done in various cases, partially documented https://wiki.ubuntu.com/MAASUpdates. This include:

All MAAS Upstream releases follow the following testing:

1. Manual Fresh installation of MAAS
2. Manual upgrade from the previous Ubuntu Release.
3. Automated (CI) testing of MAAS install and operation as per the MAAS' CI.
4. Automated (CI) testing of MAAS install and operation against other Canonical's product (juju, Canonical OpenStack & Kubernetes) provided by the Canonical Solutions QA Team.
5. Manual split region/rack test are performed. This is to ensure that if we upgrade a MAAS Region to a newer version, the MAAS rack of the older version remains connected and operational.

Packages from proposed have the following testing to guard against misbuilds:

1. Manual Fresh installation, configuration and deployment of machines.
2. Manual upgrade from the previous Ubuntu Release (and ensure continued operation)
3. Includes split region/rack tests.

All of this includes verifying normal operation, issues fixed, and ensuring that Canonical Cloud solutions can inter-operate. MAAS releases are also now vetted by the Solutions QA team.

[Regression Potential]
Minimal (For MAAS itself). MAAS 2.2.2 is just a point release that addresses bugs and does not change any behavior. It has minimum risk for backward compatibility issues. It does NOT include any database migrations as such, upgrade risks are very minimal as well.

Changed in maas (Ubuntu):
status: New → Won't Fix
Steve Langasek (vorlon) wrote :

This package introduces a conflicts against package 'python3-googleapi', which is not present in the Ubuntu archive. However, if a system does have this package installed, this will have implications for installing the new maas with unattended-upgrades / update-manager / apt upgrade. Please explain the reason for this packaging change.

Changed in maas (Ubuntu Zesty):
status: New → Incomplete
Changed in maas (Ubuntu Xenial):
status: New → Incomplete
Steve Langasek (vorlon) wrote :

Please also clarify in the bug description what testing is done on the binary packages in -proposed (as distinct from the pre-upload testing) as a guard against misbuilds.

description: updated
description: updated
Andres Rodriguez (andreserl) wrote :

Hi Steve,

python3-googleapi is present in the Archive. https://packages.ubuntu.com/xenial-updates/python/python3-googleapi

The reason why we need a conflicts is because both MAAS and python3-googleapi installs in /usr/lib/python3/dist-packages/apiclient, which obviously we need a conflicts.

Changed in maas (Ubuntu Xenial):
status: Incomplete → New
Changed in maas (Ubuntu Zesty):
status: Incomplete → New

Hello Andres, or anyone else affected,

Accepted maas into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/2.2.2-6099-g8751f91-0ubuntu1~17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in maas (Ubuntu Zesty):
status: New → Fix Committed
tags: added: verification-needed verification-needed-zesty
Changed in maas (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Steve Langasek (vorlon) wrote :

Hello Andres, or anyone else affected,

Accepted maas into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/2.2.2-6099-g8751f91-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Andres Rodriguez (andreserl) wrote :

I've tested this both in Xenial and Zesty as per the bug report testing from proposed section, and can verify that everything works as expected!

tags: added: verification-done verification-done-xenial verification-done-zesty
removed: verification-needed verification-needed-xenial verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 2.2.2-6099-g8751f91-0ubuntu1~17.04.1

---------------
maas (2.2.2-6099-g8751f91-0ubuntu1~17.04.1) zesty-proposed; urgency=medium

  * Stable Release Update. New MAAS upstream release 2.2.2 (LP: #1708651)
    - MAAS 2.2.2 is a new upstream bugfix release that fixes several bugs
      present on MAAS 2.2.0. This is solely a bug fix release. To see what
      issues have been fixes, please refer to the CHANGELOG.
  * debian/control: Conflicts with python3-googleapi.
  * debian/rules: Drop get-orig-source as MAAS & packaging are now in GIT.

 -- Andres Rodriguez <email address hidden> Fri, 04 Aug 2017 08:37:54 -0400

Changed in maas (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for maas has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 2.2.2-6099-g8751f91-0ubuntu1~16.04.1

---------------
maas (2.2.2-6099-g8751f91-0ubuntu1~16.04.1) xenial-proposed; urgency=medium

  * Stable Release Update. New MAAS upstream release 2.2.2 (LP: #1708651)
    - MAAS 2.2.2 is a new upstream bugfix release that fixes several bugs
      present on MAAS 2.2.0. This is solely a bug fix release. To see what
      issues have been fixes, please refer to the CHANGELOG.
  * debian/control: Conflicts with python3-googleapi.
  * debian/rules: Drop get-orig-source as MAAS & packaging are now in GIT.

 -- Andres Rodriguez <email address hidden> Fri, 04 Aug 2017 08:37:54 -0400

Changed in maas (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers