Switch to netplan renderer in Artful

Bug #1698181 reported by Robert C Jennings on 2017-06-15
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cloud-images
Undecided
Unassigned
openvswitch
New
Undecided
Unassigned
cloud-init (Ubuntu)
Undecided
Unassigned
ifupdown (Ubuntu)
Undecided
Unassigned
lxc (Ubuntu)
Undecided
Unassigned
lxd (Ubuntu)
Undecided
Unassigned
maas (Ubuntu)
Critical
Unassigned
resolvconf (Ubuntu)
Undecided
Dimitri John Ledkov
ubuntu-meta (Ubuntu)
Undecided
Mathieu Trudel-Lapierre

Bug Description

Ubuntu server ISOs are moving to netplan and cloud images must follow suit. We are requesting that the default renderer in 17.10 be switched to netplan to be consistent across all cloud images and ISO installs.

Related bugs:
 * bug 1713803: replacement of resolvconf with systemd needs integration

Robert C Jennings (rcj) wrote :

Marking lxd and maas as affected here as well to be aware of downstream effects.

summary: - Switch to netplan renderer in Artful in preparation for next LTS
+ Switch to netplan renderer in Artful
Stéphane Graber (stgraber) wrote :

Closing the LXD task but subscribing the ubuntu-lxc team.

LXD itself doesn't generate any eni information. The only network configuration that we allow our users to send through is cloud-init's network-config.

Changed in lxd (Ubuntu):
status: New → Invalid
Robert C Jennings (rcj) wrote :

I just learned that this doesn't need changes in cloud-init, or shouldn't. I was target this to ubuntu-meta for ifupdate to be removed from the seed in 17.10. From that we should just switch to netplan like magic. ;) I'll let the owners of the other affected packages close their own bits of this bug once they've evaluated the impact.

Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)

This is now in place:

ubuntu-meta (1.388) artful; urgency=medium

  * Refreshed dependencies
  * Removed ifupdown from minimal
  * Removed nplan from standard
  * Added nplan to minimal

One remaining issue is that ifupdown still gets installed, since it's priority: important (gets pulled in to the livefs via debootstap).

Changed in ubuntu-meta (Ubuntu):
status: New → Fix Released
Scott Moser (smoser) wrote :

marking cloud-init fix-released under bug 1705639.

Changed in cloud-init (Ubuntu):
status: New → Fix Released
Scott Moser (smoser) wrote :

I think that resolvconf should be listed here, as it Depends on ifupdown.
also resolvconf is rdepend'd on by ubuntu-minimal, so I think that ubuntu-meta probably needs another bump.

Scott Moser (smoser) wrote :

apt-get upgraded lxc container just now, shows:

root@a2:~# apt-get remove ifupdown
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  ifenslave ifupdown resolvconf ubuntu-minimal
0 upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
After this operation, 543 kB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.
root@a2:~# cat /etc/cloud/build.info
build_name: server
serial: 20170725

Also note
# apt-cache rdepends ifenslave
ifenslave
Reverse Depends:
  ifenslave-2.6
  ubuntu-server

So thats another change we probably need for ubuntu-meta/seeds.

Steve Langasek (vorlon) wrote :

On Wed, Jul 26, 2017 at 04:48:22PM -0000, Scott Moser wrote:
> I think that resolvconf should be listed here, as it Depends on ifupdown.
> also resolvconf is rdepend'd on by ubuntu-minimal, so I think that
> ubuntu-meta probably needs another bump.

The intent is to drop resolvconf from minimal. I believe Dimitri is in the process of landing the necessary systemd changes to let us remove resolvconf integration.

Changed in resolvconf (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
status: New → In Progress
Scott Moser (smoser) on 2017-09-05
description: updated
Dimitri John Ledkov (xnox) wrote :

resolvconf/resolved have updated integration which each other. Such that things work better, with default tipped to resolved. And for example removing resolvconf switches to using resolved.

Dimitri John Ledkov (xnox) wrote :

ifupdown/isc-dhcp is fixed to supplied dns servers to resolved instead of resolvconf

Changed in resolvconf (Ubuntu):
status: In Progress → Fix Released
Dimitri John Ledkov (xnox) wrote :

All cloud images do not have ifupdown installed and thus default to netplan.

Changed in cloud-images:
status: New → Fix Released
Changed in ifupdown (Ubuntu):
status: New → Fix Released
Dimitri John Ledkov (xnox) wrote :

lxc templates got fixed to use netplan in artful.

Changed in lxc (Ubuntu):
status: New → Fix Released
Changed in maas (Ubuntu):
importance: Undecided → Critical
Dimitri John Ledkov (xnox) wrote :

What is outstanding for MAAS?

madbiologist (me-again) on 2017-10-24
tags: added: artful
James Gibbins (jfgibbins) wrote :

For 17.10 forward, due to netplan being incomplete and lacking too many features, it is unsuitable for production use. What packages need to be added/removed to drop netplan and restore full network functionality as it existed in 16.04?

David Britton (davidpbritton) wrote :

re: comment #14 (for future readers), please keep the discussion over on:

https://bugs.launchpad.net/netplan/+bug/1729022

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in maas (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers