Activity log for bug #1615210

Date Who What changed Old value New value Message
2016-08-20 10:06:40 Andres Rodriguez bug added bug
2016-08-20 10:07:41 Andres Rodriguez description Following the SRU of MAAS 2.0rc2 in Xenial, we would like to request the SRU of MAAS 2.0 Final. [Impact] This is a new version of MAAS that provides bugfixes only. It addresses various upstream bugs, that were fixed after RC2 was released (and before it landed in Xenial). [Regression Potential] Minimal. MAAS has been thoroughly tested stand alone as well as via upgrades. It has been QA'd in a CI lab as well as other production deployments: Tests done: 1. Upgraded a production lab. 2. MAAS CI Lab: - Tests Installation (from pkgs), configuration / customization of MAAS, enlistment, commissioning. It also tests deployments with Juju. - Tests various API's - Tests are performed against Xenial 3. Other manual testing include: - Installation (both fresh and upgrades) - Configuration - Taking nodes through the lifecycle for regression testing. - Custom configuration to ensure proper operation. - Tests API's for regressions, and keeping backwards compatibility. 2.0.0 (rc4) =========== Issues fixed in this release ---------------------------- LP: #1592666 Mirror URL contains double slash (/) after hostname, impacting proxy cachaility. LP: #1604461 [2.0rc2] Static IP address are allowed to be created in a dynamic range. LP: #1610397 When juju adds containers to MAAS, ensure they inherit the parent machine domain name, if none is passed by Juju. LP: #1611342 UI error while generating a MAAS key (token). LP: #1610414 apiclient.maas_client.MAASClient.post() always sets an op in the query string 2.0.0 (rc3) =========== Issues fixed in this release ---------------------------- LP: #1557434 For the MAAS CLI, mimic the error behaviour provided by argparse 1.1 on PyPI when insufficient arguments are given. LP: #1594991 MAAS displays every power query on the summarized view of node event log. LP: #1603147 Commissioning dropdown is grey and checkmarks are missing. LP: #1576116 [2.0rc1] MAAS does not respect default subnet's DNS server when choosing default DNS LP: #1600720 [2.0rc1] MAAS doesn't honor DNS settings for a subnet for DHCP LP: #1598028 [2.0] Loading latest machine events can make web browser unresponsive LP: #1604128 [2.0rc2] Unable to add a public SSH Key due to lp1604147 LP: #1604169 [2.0] maas login yields "ImportError: No module named 'maasserver'" LP: #1604962 Fixes to correctly log cloud-init/curtin FAIL events in the node event log. LP: #1604987 Fixes to correctly log "mark_failed" events. LP: #1602721 [2.0rc2] Can't get node-results via cli/api LP: #1604465 [2.0] RackController.get_image_sync_status causes huge load on regiond process LP: #1598149 [2.0rc2] MAAS is not automatically monitoring timeouts for commissioning. LP: #1605252 [2.0] Error messaging about monitor expiry has been dropped Following the SRU of MAAS 2.0rc2 (LP #1599523) in Xenial, we would like to request the SRU of MAAS 2.0 Final. [Impact] This is a new version of MAAS that provides bugfixes only. It addresses various upstream bugs, that were fixed after RC2 was released (and before it landed in Xenial). [Regression Potential] Minimal. MAAS has been thoroughly tested stand alone as well as via upgrades. It has been QA'd in a CI lab as well as other production deployments: Tests done: 1. Upgraded a production lab. 2. MAAS CI Lab:  - Tests Installation (from pkgs), configuration / customization of MAAS, enlistment, commissioning. It also tests deployments with Juju.  - Tests various API's  - Tests are performed against Xenial 3. Other manual testing include:  - Installation (both fresh and upgrades)  - Configuration  - Taking nodes through the lifecycle for regression testing.  - Custom configuration to ensure proper operation.  - Tests API's for regressions, and keeping backwards compatibility. 2.0.0 (rc4) =========== Issues fixed in this release ---------------------------- LP: #1592666 Mirror URL contains double slash (/) after hostname, impacting proxy cachaility. LP: #1604461 [2.0rc2] Static IP address are allowed to be created in a dynamic range. LP: #1610397 When juju adds containers to MAAS, ensure they inherit the parent machine domain name, if none is passed by Juju. LP: #1611342 UI error while generating a MAAS key (token). LP: #1610414 apiclient.maas_client.MAASClient.post() always sets an op in the query string 2.0.0 (rc3) =========== Issues fixed in this release ---------------------------- LP: #1557434 For the MAAS CLI, mimic the error behaviour provided by argparse 1.1 on PyPI when insufficient arguments are given. LP: #1594991 MAAS displays every power query on the summarized view of node event log. LP: #1603147 Commissioning dropdown is grey and checkmarks are missing. LP: #1576116 [2.0rc1] MAAS does not respect default subnet's DNS server when choosing default DNS LP: #1600720 [2.0rc1] MAAS doesn't honor DNS settings for a subnet for DHCP LP: #1598028 [2.0] Loading latest machine events can make web browser unresponsive LP: #1604128 [2.0rc2] Unable to add a public SSH Key due to lp1604147 LP: #1604169 [2.0] maas login yields "ImportError: No module named 'maasserver'" LP: #1604962 Fixes to correctly log cloud-init/curtin FAIL events in the node event log. LP: #1604987 Fixes to correctly log "mark_failed" events. LP: #1602721 [2.0rc2] Can't get node-results via cli/api LP: #1604465 [2.0] RackController.get_image_sync_status causes huge load on regiond process LP: #1598149 [2.0rc2] MAAS is not automatically monitoring timeouts for commissioning. LP: #1605252 [2.0] Error messaging about monitor expiry has been dropped
2016-08-22 16:26:05 Andres Rodriguez maas (Ubuntu): importance Undecided Critical
2016-08-22 17:11:28 Andres Rodriguez bug added subscriber Ubuntu Stable Release Updates Team
2016-08-22 17:11:51 Andres Rodriguez nominated for series Ubuntu Xenial
2016-08-22 17:11:51 Andres Rodriguez bug task added maas (Ubuntu Xenial)
2016-08-22 17:11:55 Andres Rodriguez maas (Ubuntu Xenial): importance Undecided Critical
2016-08-22 17:12:02 Andres Rodriguez maas (Ubuntu): status New Fix Released
2016-08-25 18:10:46 Brian Murray maas (Ubuntu Xenial): status New Fix Committed
2016-08-25 18:10:49 Brian Murray bug added subscriber SRU Verification
2016-08-25 18:10:52 Brian Murray tags verification-needed
2016-09-07 14:43:21 Andres Rodriguez tags verification-needed verification-done
2016-09-08 15:52:10 Launchpad Janitor maas (Ubuntu Xenial): status Fix Committed Fix Released
2016-09-08 15:52:19 Brian Murray removed subscriber Ubuntu Stable Release Updates Team