[SRU] MAAS 1.7.6

Bug #1460737 reported by Andres Rodriguez on 2015-06-01
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
maas (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

We would like to request an Standing Feature Freeze exception for MAAS 1.7. This follow the approval by the Ubuntu Technical Board for backporting new MAAS upstream releases. This release includes:

MAAS 1.7 brings the following features:
=========
Changelog
=========

1.7.5
=====

Bug Fix Update
--------------

#1456969 MAAS cli/API: missing option set use-fast-installer /
            use-debian-installer

1.7.4
=====

Bug Fix Update
--------------

#1456892 500 error: UnboundLocalError: local variable 'key_required'
            referenced before assignment
#1387859 When MAAS has too many leases, and lease parsing fails, MAAS fails
            to auto-map NIC with network
#1329267 Alert a command-line user of `maas` when their local API
            description is out-of-date.

1.7.3
=====

Bug Fix Update
--------------

#1441933 Internal Server Error when saving a cluster without Router IP
#1441133 MAAS version not exposed over the API
#1437094 Sorting by mac address on webui causes internal server error
#1439359 Automatically set correct boot resources selection and start import
            after upgrade from MAAS 1.5; Ensures MAAS is usable after upgrade.
#1439366 Backwards compatibility with MAAS 1.5 preseeds and custom preseeds.
            Ensures that users dont have to manually change preseeds names.

1.7.2
=====

Bug Fix Update
--------------

For full details see https://launchpad.net/maas/+milestone/1.7.2

#1331214 Support AMT Version > 8
#1397567 Fix call to amttool when restarting a node to not fail disk erasing.
#1415538 Do not generate the 'option routers' stanza if router IP is None.
#1403909 Do not deallocate StaticIPAddress before node has powered off.
#1405998 Remove all OOPS reporting.
#1423931 Update the nodes host maps when a sticky ip address is claimed over the API.
#1433697 Look for bootloaders in /usr/lib/EXTLINUX

1.7.1
=====

Minor feature improvements
--------------------------

New CentOS Release support.
  Further to the work done in the 1.7.0 MAAS Release, MAAS now supports
  uploading various versions of CentOS. Previously MAAS would only
  officially support 6.5.

Power Monitoring for Seamicro 15000, Cisco UCS and HP Moonshot Chassis
  Further the work done in the 1.7.0 MAAS release, it now supports power
  query and monitoring for the Seamicro 15000 Chassis, the Cisco UCS
  Chassis Manager and the HP Moonshot Chassis Manager.

Node Listing Page and Node Event Log live refresh
  The Node Listing page and the Node Event Log now have live refresh
  every 10 seconds. This allows MAAS to display the latest node status
  and events without forcing a browser refresh.

IP Address Reservation
  The static IP address reservation API now has an optional "mac"
  parameter. Specifying a MAC address here will link the new static IP
  to that MAC address. A DHCP host map will be created for the MAC
  address. No other IPs may be reserved for that MAC address until the
  current one is released.

Bug fix update
--------------

For full details see https://launchpad.net/maas/+milestone/1.7.1

#1330765 If start_nodes() fails, it doesn't clean up after itself.
#1373261 pserv.yaml rewrite breaks when previous generator URL uses IPv6 address
#1386432 After update to the latest curtin that changes the log to install.log MAAS show's two installation logs
#1386488 If rndc fails, you get an Internal Server Error page
#1386502 No "failed" transition from "new"
#1386914 twisted Unhandled Error when region can't reach upstream boot resource
#1391139 Tagged VLAN on aliased NIC breaks migration 0099
#1391161 Failure: twisted.internet.error.ConnectionDone: Connection was closed cleanly.
#1391411 metadata API signal() is releasing host maps at the end of installation
#1391897 Network names with dots cause internal server error when on node pages
#1394382 maas does not know about VM "paused" state
#1396308 Removing managed interface causes maas to delete nodes
#1397356 Disk Wiping fails if installation is not Ubuntu
#1398405 MAAS UI reports storage size in Gibibytes (base 2) but is labeled GB - Gigabytes (base 10).
#1399331 MAAS leaking sensitive information in ps ax output
#1400849 Check Power State disappears after upgrade to 1.7 bzr 3312
#1401241 custom dd-tgz format images looked for in wrong path, so they don't work
#1401983 Exception: deadlock detected
#1403609 can not enlist chassis with maas admin node-group probe-and-enlist-mscm
#1283106 MAAS allows the same subnet to be defined on two managed interfaces of the same cluster
#1303925 commissioning fails silently if a node can't reach the region controller
#1357073 power state changes are not reflected quickly enough in the UI
#1360280 boot-source-selections api allows adding bogus and duplicated values
#1368400 Can't power off nodes that are in Ready state but on
#1370897 The node power monitoring service does not check nodes in parallel
#1376024 gpg --batch [...]` error caused by race in BootSourceCacheService
#1376716 AMT NUC stuck at boot prompt instead of powering down (no ACPI support in syslinux poweroff)
#1378835 Config does not have a unique index on name
#1379370 Consider removing transaction in claim_static_ip_addresses().
#1379556 Panicky log warning that is irrelevant
#1381444 Misleading error message in log "Unknown power_type 'sm15k'"
#1382166 Message disclosing image import necessary visible while not logged in
#1382237 UnicodeEncodeError when unable to create host maps
#1383231 Error message when trying to reserve the same static IP twice is unhelpful
#1383237 Error message trying to reserve an IP address when no static range is defined is misleading
#1384424 Seamicro Machines do not have Power Status Tracking
#1384428 HP Moonshot Chassis Manager lacks power status monitoring
#1384924 need to provide a better upgrade message for images on the cluster but not on the region
#1386517 DHCP leases are not released at the end of commissioning and possibly enlistment
#1387239 MAAS does not provide an API for reserving a static IP for a given MAC address
#1387414 Race when registering new event type
#1388033 Trying to reserve a static IP when no more IPs are available results in 503 Service Unavailable with no error text
#1389602 Inconsistent behavior in the checks to delete a node
#1389733 node listing does not update the status and power of nodes
#1390144 Node 'releasing' should have a timeout
#1391193 API error documentation
#1391421 Names of custom boot-resources not visible in the web UI
#1391891 Spurious test failure: TestDNSForwardZoneConfig_GetGenerateDirectives.test_returns_single_entry_for_tiny_network
#1393423 PowerKVM / VIrsh import should allow you to specify a prefix to filter VM's to import
#1393953 dd-format images fail to deploy
#1400909 Networks are being autocreated like eth0-eth0 instead of maas-eth0
#1401349 Memory size changes to incorrect size when page is refreshed
#1402237 Node event log queries are slow (over 1 second)
#1402243 Nodes in 'Broken' state are being power queried constantly
#1402736 clicking on zone link from node page - requested URL was not found on this server
#1403043 Wrong top-level tab is selected when viewing a node
#1381609 Misleading log message when a node has a MAC address not attached to a cluster interface
#1386909 Misleading Error: Unable to identify boot image for (ubuntu/amd64/generic/trusty/local): cluster 'maas' does not have matching boot image.
#1388373 Fresh image import of 3 archs displaying multiple rows for armhf and amd64
#1398159 TFTP into MAAS server to get pxelinux.0 causes unhandled error
#1383651 Node.start() and Node.stop() raise MulltipleFailures unnecessarily
#1383668 null" when releasing an IP address is confusing
#1389416 Power querying for UCSM not working
#1399676 UX bug: mac address on the nodes page should be the MAC address it pxe booted from
#1399736 MAAS should display memory sizes in properly labeld base 2 units - MiB, GiB, etc.
#1401643 Documentation has wrong pattern for user provided preseeds
#1401707 Slow web performance (5+ minute response time) on MAAS with many nodes
#1403609 Fix MSCM chassis enlistment.
#1409952 Correctly parse MAC Address for Power8 VM enlistment.
#1409852 Do not fail when trying to perform an IP Address Reservation.
#1413030 OS and Release no longer populate on Add Node page
#1414036 Trying to add an empty network crashes (AddrFormatError)

1.7.0
=====

Important announcements
-----------------------
 * If you are modifying ``/etc/network/interfaces`` in the preseed, it must be
   moved so it is processed last in ``late_commands`` since MAAS now writes
   to this file itself as part of IPv6 setup. For example::

    late_commands:
      bonding_02: ["curtin", "in-target", "--", "wget", "-O", "/etc/network/interfaces", "http://[...snip...]"]

   must now look like this::

    late_commands:
      zz_write_ifaces: ["curtin", "in-target", "--", "wget", "-O", "/etc/network/interfaces", "http://[...snip...]"]

   The leading ``zz`` ensures the command sorts to the end of the
   ``late_commands`` list.

Major new features
------------------

**Improved image downloading and reporting.**
**Increased robustness.**
**RPC security.**
**RPC connections.**
**Node event log.**
**IPv6.**
**Removal of Celery and RabbitMQ.**
**Support for other OSes.**
**Custom Images.**
**maas-proxy.**
**Better handling of networks.**
**Improved logging.**
**Static IP selection.**
**Pronounceable random hostnames.**

Changed in maas (Ubuntu):
status: New → Fix Released
description: updated

Hello Andres, or anyone else affected,

Accepted maas into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/1.7.5+bzr3369-0ubuntu1~15.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in maas (Ubuntu Vivid):
status: New → Fix Committed
tags: added: verification-needed
Dave Chiluk (chiluk) on 2015-06-03
tags: added: cts sts
Adam Conrad (adconrad) wrote :

Hello Andres, or anyone else affected,

Accepted maas into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/1.7.5+bzr3369-0ubuntu1~14.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in maas (Ubuntu Utopic):
status: New → Fix Committed
Changed in maas (Ubuntu Trusty):
status: New → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Andres, or anyone else affected,

Accepted maas into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/1.7.5+bzr3369-0ubuntu1~14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

10:36 <infinity> Alright, accepting (slowly) the trusty and utopic uploads now.
10:36 <infinity> Consider this a test drive for a broader acceptance of the backporting exception.
10:37 <infinity> So, please do track any bugs that come from this, respond promptly to issues, etc.
10:37 <infinity> We don't expect it to be perfect, but we also won't be happy with bugs being ignored or closed with "well, it's a new version, suck it up if the upgrade broke".
10:39 <infinity> And document your testing strategies, etc on the master SRU bug, don't just set it "verification-done" without a solid explanation of how you arrived at that conclusion.

tags: added: verification-needed-trusty verification-needed-utopic verification-needed-vivid
removed: verification-needed
Andres Rodriguez (andreserl) wrote :

This has been tested extensively and we are marking it verification-done

tags: added: verification-done-trusty verification-done-utopic verification-done-vivid
removed: verification-needed-trusty verification-needed-utopic verification-needed-vivid
summary: - [SRU] MAAS 1.7.5
+ [SRU] MAAS 1.7.6
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.7.6+bzr3376-0ubuntu2~14.04.1

---------------
maas (1.7.6+bzr3376-0ubuntu2~14.04.1) trusty; urgency=medium

  * debian/control: Make maas-dns a Dependy of maas-region-controller.
  * debian/maas-region-controller.postinst: Ensure DNS config migration is
    always run. (LP: #1413388)

 -- Andres Rodriguez <email address hidden> Fri, 10 Jul 2015 13:47:40 -0400

Changed in maas (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.7.6+bzr3376-0ubuntu2~15.04.1

---------------
maas (1.7.6+bzr3376-0ubuntu2~15.04.1) vivid; urgency=medium

  * debian/control: Make maas-dns a Dependy of maas-region-controller.
  * debian/maas-region-controller.postinst: Ensure DNS config migration is
    always run. (LP: #1413388)

 -- Andres Rodriguez <email address hidden> Fri, 10 Jul 2015 13:47:40 -0400

Changed in maas (Ubuntu Vivid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers