[0-day SRU] maas needs to use python-django16 instead of 1.7

Bug #1447573 reported by Andres Rodriguez on 2015-04-23
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
maas (Ubuntu)
Undecided
Unassigned

Bug Description

MAAS does not have support for django 1.7. Hence it needs to use python-django16.

[Impact]
Without using django16, MAAS won't be a ble to work as it does not support the mgiration system in django 1.7

[Test Case]
1. Install MAAS
2. Access maas in http://localhost/MAAS

[Regression Potential]
Minimal. This has been tested in production environments.

Hello Andres, or anyone else affected,

Accepted maas into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/1.7.3+bzr3363-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in maas (Ubuntu):
status: New → Confirmed
Andres Rodriguez (andreserl) wrote :

I have tested this and works as expected!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.7.3+bzr3363-0ubuntu2

---------------
maas (1.7.3+bzr3363-0ubuntu2) vivid; urgency=medium

  * Use python-django16 instead of python-django ( 1.7). MAAS does not
    support django 1.7 due to having a new migration system. (LP: #1447573)
  * Adding systemd units and packaging support. (LP: #1423613)
  * debian/control: Add missing dependency on python-apt. (LP: #1446878)
 -- Andres Rodriguez <email address hidden> Wed, 22 Apr 2015 12:10:50 -0400

Changed in maas (Ubuntu):
status: Confirmed → Fix Released

The verification of the Stable Release Update for maas has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers