Activity log for bug #1334401

Date Who What changed Old value New value Message
2014-06-25 18:50:57 Diogo Matsubara bug added bug
2014-06-25 18:51:07 Diogo Matsubara maas (Ubuntu): status New Triaged
2014-06-25 18:51:09 Diogo Matsubara maas (Ubuntu): importance Undecided Critical
2014-06-25 19:10:36 Launchpad Janitor branch linked lp:~matsubara/maas/bug-1334401-paramiko
2014-06-25 19:11:03 Diogo Matsubara tags ci
2014-07-24 18:48:22 Launchpad Janitor branch linked lp:~matsubara/maas/bug-1334401-paramiko-trusty
2014-07-29 15:20:14 Diogo Matsubara maas (Ubuntu): assignee Diogo Matsubara (matsubara)
2014-07-29 15:20:16 Diogo Matsubara maas (Ubuntu): status Triaged Fix Committed
2014-08-21 14:40:21 Launchpad Janitor maas (Ubuntu): status Fix Committed Fix Released
2014-08-22 01:05:13 Launchpad Janitor branch linked lp:ubuntu/maas
2014-08-29 19:53:25 Launchpad Janitor branch linked lp:ubuntu/trusty-proposed/maas
2014-09-02 04:08:55 Greg Lutostanski summary Missing dependency on python-paramiko [SRU] Missing dependency on python-paramiko
2014-09-02 04:11:54 Greg Lutostanski description As seen here: http://d-jenkins.ubuntu-ci:8080/view/MAAS/job/utopic-adt-maas/131/console, maas package can't be installed on utopic due to a missing dependency on python-paramiko Setting up maas-dns (1.6+bzr2367+2475+283-0ubuntu1) ... Traceback (most recent call last): File "/usr/bin/django-admin", line 5, in <module> management.execute_from_command_line() File "/usr/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line utility.execute() File "/usr/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute self.fetch_command(subcommand).run_from_argv(self.argv) File "/usr/lib/python2.7/dist-packages/django/core/management/base.py", line 242, in run_from_argv self.execute(*args, **options.__dict__) File "/usr/lib/python2.7/dist-packages/django/core/management/base.py", line 284, in execute self.validate() File "/usr/lib/python2.7/dist-packages/django/core/management/base.py", line 310, in validate num_errors = get_validation_errors(s, app) File "/usr/lib/python2.7/dist-packages/django/core/management/validation.py", line 34, in get_validation_errors for (app_name, error) in get_app_errors().items(): File "/usr/lib/python2.7/dist-packages/django/db/models/loading.py", line 196, in get_app_errors self._populate() File "/usr/lib/python2.7/dist-packages/django/db/models/loading.py", line 78, in _populate self.load_app(app_name) File "/usr/lib/python2.7/dist-packages/django/db/models/loading.py", line 99, in load_app models = import_module('%s.models' % app_name) File "/usr/lib/python2.7/dist-packages/django/utils/importlib.py", line 40, in import_module __import__(name) File "/usr/lib/python2.7/dist-packages/maasserver/models/__init__.py", line 47, in <module> from maasserver.models.bootimage import BootImage File "/usr/lib/python2.7/dist-packages/maasserver/models/bootimage.py", line 27, in <module> from maasserver.models.nodegroup import NodeGroup File "/usr/lib/python2.7/dist-packages/maasserver/models/nodegroup.py", line 37, in <module> from maasserver.refresh_worker import refresh_worker File "/usr/lib/python2.7/dist-packages/maasserver/refresh_worker.py", line 21, in <module> from provisioningserver.tasks import refresh_secrets File "/usr/lib/python2.7/dist-packages/provisioningserver/tasks.py", line 56, in <module> from provisioningserver.drivers.hardware.mscm import probe_and_enlist_mscm File "/usr/lib/python2.7/dist-packages/provisioningserver/drivers/hardware/mscm.py", line 26, in <module> from paramiko import ( ImportError: No module named paramiko Setting up maas-region-controller (1.6+bzr2367+2475+283-0ubuntu1) ... [Impact] * Add missing dependency for install [Testcase] * install maas-dns (will fail if >1.6.0) * or using provisioning on mscm hardware (will fail if >=1.5.4) -- when fix not included [Regression Potential] * Minimal, included in main for all supported releases. As seen here: http://d-jenkins.ubuntu-ci:8080/view/MAAS/job/utopic-adt-maas/131/console, maas package can't be installed on utopic due to a missing dependency on python-paramiko Setting up maas-dns (1.6+bzr2367+2475+283-0ubuntu1) ... Traceback (most recent call last):   File "/usr/bin/django-admin", line 5, in <module>     management.execute_from_command_line()   File "/usr/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line     utility.execute()   File "/usr/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute     self.fetch_command(subcommand).run_from_argv(self.argv)   File "/usr/lib/python2.7/dist-packages/django/core/management/base.py", line 242, in run_from_argv     self.execute(*args, **options.__dict__)   File "/usr/lib/python2.7/dist-packages/django/core/management/base.py", line 284, in execute     self.validate()   File "/usr/lib/python2.7/dist-packages/django/core/management/base.py", line 310, in validate     num_errors = get_validation_errors(s, app)   File "/usr/lib/python2.7/dist-packages/django/core/management/validation.py", line 34, in get_validation_errors     for (app_name, error) in get_app_errors().items():   File "/usr/lib/python2.7/dist-packages/django/db/models/loading.py", line 196, in get_app_errors     self._populate()   File "/usr/lib/python2.7/dist-packages/django/db/models/loading.py", line 78, in _populate     self.load_app(app_name)   File "/usr/lib/python2.7/dist-packages/django/db/models/loading.py", line 99, in load_app     models = import_module('%s.models' % app_name)   File "/usr/lib/python2.7/dist-packages/django/utils/importlib.py", line 40, in import_module     __import__(name)   File "/usr/lib/python2.7/dist-packages/maasserver/models/__init__.py", line 47, in <module>     from maasserver.models.bootimage import BootImage   File "/usr/lib/python2.7/dist-packages/maasserver/models/bootimage.py", line 27, in <module>     from maasserver.models.nodegroup import NodeGroup   File "/usr/lib/python2.7/dist-packages/maasserver/models/nodegroup.py", line 37, in <module>     from maasserver.refresh_worker import refresh_worker   File "/usr/lib/python2.7/dist-packages/maasserver/refresh_worker.py", line 21, in <module>     from provisioningserver.tasks import refresh_secrets   File "/usr/lib/python2.7/dist-packages/provisioningserver/tasks.py", line 56, in <module>     from provisioningserver.drivers.hardware.mscm import probe_and_enlist_mscm   File "/usr/lib/python2.7/dist-packages/provisioningserver/drivers/hardware/mscm.py", line 26, in <module>     from paramiko import ( ImportError: No module named paramiko Setting up maas-region-controller (1.6+bzr2367+2475+283-0ubuntu1) ...
2014-09-02 14:11:46 Chris J Arges nominated for series Ubuntu Trusty
2014-09-02 14:11:46 Chris J Arges bug task added maas (Ubuntu Trusty)
2014-09-02 14:26:05 Greg Lutostanski maas (Ubuntu Trusty): status New Fix Committed
2014-09-02 14:26:08 Greg Lutostanski maas (Ubuntu Trusty): importance Undecided Critical
2014-09-02 14:26:12 Greg Lutostanski maas (Ubuntu Trusty): assignee Greg Lutostanski (lutostag)
2014-09-02 14:26:15 Greg Lutostanski maas (Ubuntu Trusty): milestone trusty-updates
2014-09-03 14:35:48 Chris J Arges bug added subscriber Ubuntu Stable Release Updates Team
2014-09-03 14:35:50 Chris J Arges bug added subscriber SRU Verification
2014-09-03 14:35:52 Chris J Arges tags ci ci verification-needed
2014-09-30 18:20:38 Andres Rodriguez tags ci verification-needed ci verification-done
2014-09-30 20:18:03 Launchpad Janitor maas (Ubuntu Trusty): status Fix Committed Fix Released