maas/installation-note could (should?) be echoed to the CLI, not a debconf note

Bug #1284652 reported by Tycho Andersen on 2014-02-25
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
maas (Ubuntu)
High
Andres Rodriguez
Trusty
High
Andres Rodriguez

Bug Description

Can this be echoed on the command line, instead of listed as an installation note? We'd like to not have any pop-ups when you apt-get install cloud.

Daniel Westervelt (danwest) wrote :

The inability to automatically suppress this pop-up is blocking the cloud-installer bootstrap automation. We either need to figure out a workaround or remove the d-i/ncurses style pop-up and replace it with a cmdline message.

Changed in maas (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-14.04-beta-2
tags: added: cloud-installer
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in maas (Ubuntu):
status: New → Confirmed
Robie Basak (racb) wrote :

@Tycho

Does DEBIAN_FRONTEND=noninteractive not work? Or are you unable to do this in your case?

Hi Robie,

On Wed, Mar 19, 2014 at 02:02:23PM -0000, Robie Basak wrote:
> @Tycho
>
> Does DEBIAN_FRONTEND=noninteractive not work? Or are you unable to do
> this in your case?

We were listing maas as a dependency for the cloud installer, so we'd
have to ask the user to run with a non-interactive frontend when they
installed the cloud installer to avoid the message, which didn't seem
like a great thing.

However, now we've changed the process and so this bug isn't actually
so relevant for us any more; we can probably close it if you want.

\t

Robie Basak (racb) wrote :

OK, thanks. That makes sense. I'm not sure what the original rationale was to add that message in the first place, since in the general case we avoid such things on Ubuntu. So I'll leave the bug open for that, but I think we can drop the milestone if it's not blocking you.

Changed in maas (Ubuntu):
milestone: ubuntu-14.04-beta-2 → none
Tycho Andersen (tycho-s) wrote :

On Wed, Mar 19, 2014 at 03:14:35PM -0000, Robie Basak wrote:
> OK, thanks. That makes sense. I'm not sure what the original rationale
> was to add that message in the first place, since in the general case we
> avoid such things on Ubuntu. So I'll leave the bug open for that, but I
> think we can drop the milestone if it's not blocking you.

Yep, sounds good to me.

Dustin Kirkland  (kirkland) wrote :

OMG, +100

Changed in maas (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
Changed in maas (Ubuntu Trusty):
milestone: none → ubuntu-14.04
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.5+bzr2252-0ubuntu1

---------------
maas (1.5+bzr2252-0ubuntu1) trusty; urgency=medium

  * New upstream release
    - Add support to install Third Party Drivers. In order for this to be
      used the user will have to go to the Settings page to enable the
      installation of these drivers. (LP: #1305839)
    - Use release images instead of daily. (LP: #1306701)
    - Quote interface name in dhcpd.template, otherwise DHCP server fails
      to start. (LP: #1306335)
    - Fix IntegrityError, when multiple processes are trying to register
      the same component. (LP: #1307415)
    - Add missing armhf commissioning template (LP: #1307780)
  * debian/maas-region-controller-min.install: Install drivers.yaml.
  * debian/maas-region-controller.postinst: No longer show the
    installation note by default. (LP: #1284652)
 -- Andres Rodriguez <email address hidden> Wed, 09 Apr 2014 19:02:00 -0400

Changed in maas (Ubuntu Trusty):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers