[FFe] FFe for 14.04 features

Bug #1281881 reported by Julian Edwards on 2014-02-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
maas (Ubuntu)
Critical
Unassigned

Bug Description

[Rationale]
MAAS requires the following features to land after the Feature Freeze:
 * support for third party hardware drivers
 * support for tracking which NICs on each node are associated with a particular network
 * support for UEFI
 * support for Other Hardware Devices.

For this reason, we are requesting an *Standing* Feature Freeze Exception for MAAS' features described above. Uploads will only contain the features described above as well as any bugfixes that might come out of other features.

Third party hardware drivers
============================
[Description]
This is related to bug 1281765 and forms the infrastructure to enable hardware enablement teams to write drivers for hardware not already supported in MAAS.

This is essential work to prevent these teams from blocking on the core MAAS development team, and to make writing new drivers an order of magnitude quicker and easier.

[Proposed Changes]
The feature is already half implemented; bi-directional comms between clusters and the region controller is now established but further work is required to add an API layer between these comms and the driver code.

The API layer will translate the various requirements that a driver should provide into calls to the region, and vice versa. Additionally, all current code that is part of hardware enablement, such as architecture types and power parameter choices, will be moved into new driver code that will become part of each cluster controller.

NIC tracking
============
[Description]
A feature is already landed to support network tracking on Nodes that MAAS manages. This needs to be extended to track on which NIC the network is available.

This is essential otherwise the existing work is of no use to API clients if they cannot know on which NIC the network is to be used.

[Proposed changes]
The database will gain a link table between MACAddress and Network, and the UI will change so that it lets the user link networks against MACs on the node rather than the node as a whole. API calls will also change accordingly.

Changed in maas:
status: New → Triaged
importance: Undecided → Critical

I just edited this to a single FFE for many things, as advised by infinity. We'll do a single upload when all the features are done.

summary: - FFE: maas support for third party hardware drivers
+ FFE: 14.04 features
description: updated
summary: - FFE: 14.04 features
+ [FFe] Standing FFe for 14.04 features
description: updated
description: updated
no longer affects: maas
Changed in maas (Ubuntu):
importance: Undecided → Critical
description: updated
Changed in maas (Ubuntu):
milestone: none → ubuntu-14.04-beta-2
Anders (eddiedog988) on 2014-03-13
Changed in maas (Ubuntu):
status: New → Confirmed

Please can you provide more detail on:
 - The progress of these features so far
 - Expected landing dates of these features (will land prior to Final Beta, 27/03/14?)
 - Testing plan, and regression potential
 - Fallback plan if this doesn't land as expected?

In addition, can you comment on ppc64el & UEFI testing methods?
Is there a upstream bug tracking, NIC ident & tracking?

Thanks

Dave Walker (davewalker) wrote :

Please can the previous questions be answered?

Thanks

Changed in maas (Ubuntu):
status: Confirmed → Incomplete
Julian Edwards (julian-edwards) wrote :

Hey Dave, I think Andres can answer some of these better than I but I'll have a stab:

 - The progress of these features so far

90% done, there's some remaining work to land for hardware enablements which is in progress now and we hope to finish it Monday.

 - Expected landing dates of these features (will land prior to Final Beta, 27/03/14?)

Everything will land prior to final beta, hopefully Monday but possibly up to 2 days later.

 - Testing plan, and regression potential

Maas uses the maas-test project on a CI loop in the QA lab. There is minimal regression potential.

 - Fallback plan if this doesn't land as expected?

Release without the features, or incomplete features.

>In addition, can you comment on ppc64el & UEFI testing methods?

Andres will have to comment on those.

>Is there a upstream bug tracking, NIC ident & tracking?

No, it's a blueprint:
https://blueprints.launchpad.net/maas/+spec/t-cloud-maas-advanced-networking

Andres Rodriguez (andreserl) wrote :

ppc64el is not longer included in this FFe.
UEFI testing is done via manual testing, not automated.

summary: - [FFe] Standing FFe for 14.04 features
+ [FFe] FFe for 14.04 features
description: updated
Changed in maas (Ubuntu):
status: Incomplete → New
Dave Walker (davewalker) wrote :

ppc64el is no longer targeted for 14.04?

The upload in rejected queue, you believe has all of the features outlined in this bug? Nothing new to come, and confidence is high in having a low regression potential?

Julian Edwards (julian-edwards) wrote :

> ppc64el is no longer targeted for 14.04?

Correct.

> The upload in rejected queue, you believe has all of the features
> outlined in this bug? Nothing new to come, and confidence is high in
> having a low regression potential?

Confidence is high, we have green lights in the QA lab.

Cheers.

Julian Edwards (julian-edwards) wrote :

> Nothing new to come

There are no more features but there will almost certainly be bug fixes! :)

Steve Langasek (vorlon) wrote :

It sounds like the MAAS team have answered all of Daviey's questions here, and the clock is ticking. It looks like the upload has been ready since before beta2, we're now after beta2 and only blocking on release team approval. So FFe granted, please upload ASAP.

Changed in maas (Ubuntu):
status: New → Confirmed

Agreed, apologies for not confirming.

Steve, can you recover the upload from rejected?

Thanks
 On 2 Apr 2014 20:31, "Steve Langasek" <email address hidden> wrote:

> It sounds like the MAAS team have answered all of Daviey's questions
> here, and the clock is ticking. It looks like the upload has been ready
> since before beta2, we're now after beta2 and only blocking on release
> team approval. So FFe granted, please upload ASAP.
>
> ** Changed in: maas (Ubuntu)
> Status: New => Confirmed
>
> --
> You received this bug notification because you are a member of Ubuntu
> Release Team, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/1281881
>
> Title:
> [FFe] FFe for 14.04 features
>
> Status in “maas” package in Ubuntu:
> Confirmed
>
> Bug description:
> [Rationale]
> MAAS requires the following features to land after the Feature Freeze:
> * support for third party hardware drivers
> * support for tracking which NICs on each node are associated with a
> particular network
> * support for UEFI
> * support for Other Hardware Devices.
>
> For this reason, we are requesting an *Standing* Feature Freeze
> Exception for MAAS' features described above. Uploads will only
> contain the features described above as well as any bugfixes that
> might come out of other features.
>
> Third party hardware drivers
> ============================
> [Description]
> This is related to bug 1281765 and forms the infrastructure to enable
> hardware enablement teams to write drivers for hardware not already
> supported in MAAS.
>
> This is essential work to prevent these teams from blocking on the
> core MAAS development team, and to make writing new drivers an order
> of magnitude quicker and easier.
>
> [Proposed Changes]
> The feature is already half implemented; bi-directional comms between
> clusters and the region controller is now established but further work is
> required to add an API layer between these comms and the driver code.
>
> The API layer will translate the various requirements that a driver
> should provide into calls to the region, and vice versa.
> Additionally, all current code that is part of hardware enablement,
> such as architecture types and power parameter choices, will be moved
> into new driver code that will become part of each cluster controller.
>
> NIC tracking
> ============
> [Description]
> A feature is already landed to support network tracking on Nodes that
> MAAS manages. This needs to be extended to track on which NIC the network
> is available.
>
> This is essential otherwise the existing work is of no use to API
> clients if they cannot know on which NIC the network is to be used.
>
> [Proposed changes]
> The database will gain a link table between MACAddress and Network, and
> the UI will change so that it lets the user link networks against MACs on
> the node rather than the node as a whole. API calls will also change
> accordingly.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/maas/+bug/1281881/+subscriptions
>
>

Steve Langasek (vorlon) wrote :

On Wed, Apr 02, 2014 at 08:35:11PM +0100, Dave Walker wrote:
> Agreed, apologies for not confirming.
>
> Steve, can you recover the upload from rejected?
Done.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.5+bzr2204-0ubuntu1

---------------
maas (1.5+bzr2204-0ubuntu1) trusty; urgency=low

  * New upstream release (LP: #1281881)

  [ Andres Rodriguez ]
  * debian/maas-region-controller-min.templates: Set installation note to false
    by default.
  * Check rabbitmqctl is present before running commands:
    - debian/maas-region-controller-min.maas-region-celery.upstart.
    - debian/maas-region-controller-min.maas-txlongpoll.upstart.
  * make sure maas_longpoll rabbitmq user is created/with correct password on
    a package reconfigure.
  * debian/maas-dns.postinst: Fix upgrade setup of named.conf.options.
  * debian/maas-cluster-controller.install: Install UEFI templates (LP: #1299143)

  [ Julian Edwards ]
  * debian/extas/maas: Echo warning to stderr so json stdout is not polluted
  * debian/maas-cluster-controller.postinst: Run upgrade-cluster on each
    upgrade
  * debian/maas-dns.postinst: Call edit_named_options to add a line in
    /etc/bind/named.conf.options that includes the
    /etc/named/maas/named.conf.options.inside.maas file.
  * debian/control:
    - maas-dns depends on python-iscpy
    - maas-cluster-controller depends on python-seamicroclient
  * debian/maas-cluster-controller.install: Install bootresources.yaml

  [ Dustin Kirkland ]
  * debian/control: LP: #1297097
    - clean up package descriptions, modernize, and more clearly/simply
      explain what each package does
    - drop "Ubuntu" in front of MAAS, clean up command line/API description
 -- Andres Rodriguez <email address hidden> Fri, 28 Mar 2014 10:43:53 -0400

Changed in maas (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers