[SRU] maas dhcp.conf template not adding ignore-client-uids unless using raring or later

Bug #1240972 reported by Matt Rae on 2013-10-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Low
Unassigned
Ubuntu Cloud Archive
High
Unassigned
maas (Ubuntu)
High
Unassigned
Saucy
High
Unassigned

Bug Description

1. Description of the problem:

The maas dhcpd.conf.template only adds ignore-client-uids if using raring or later. Packages in the cloud-tools archive should work on precise and require this option for dhcpd. I have verified that dhcpd starts after adding ignore-client-uids

root@maas1000:~# cat /etc/maas/templates/dhcp/dhcpd.conf.template
...
subnet {{subnet}} netmask {{subnet_mask}} {
       filename "{{bootloader}}";
       {{if platform_codename >= 'raring'}}
       ignore-client-uids true;
       {{endif}}
       option subnet-mask {{subnet_mask}};

2. Ubuntu release, software version, Release Number and Architecture of the selected components.

root@maas1000:/etc/maas/templates/dhcp# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.3 LTS
Release: 12.04
Codename: precise

root@maas1000:~# apt-cache policy maas-cluster-controller
maas-cluster-controller:
  Installed: 1.4+bzr1693+dfsg-0ubuntu2~ctools0
  Candidate: 1.4+bzr1693+dfsg-0ubuntu2~ctools0
  Version table:
 *** 1.4+bzr1693+dfsg-0ubuntu2~ctools0 0
        500 http://10.0.0.1/ubuntu-cloud/ubuntu/ precise-updates/cloud-tools/main amd64 Packages
        100 /var/lib/dpkg/status
     1.2+bzr1373+dfsg-0ubuntu1~12.04.2 0
        500 http://10.0.0.1/ubuntu/ precise-updates/main amd64 Packages

root@maas1000:~# apt-cache policy isc-dhcp-server
isc-dhcp-server:
  Installed: 4.2.4-7ubuntu8~ctools0
  Candidate: 4.2.4-7ubuntu8~ctools0
  Version table:
 *** 4.2.4-7ubuntu8~ctools0 0
        500 http://10.0.0.1/ubuntu-cloud/ubuntu/ precise-updates/cloud-tools/main amd64 Packages
        100 /var/lib/dpkg/status
     4.1.ESV-R4-0ubuntu5.9 0
        500 http://10.0.0.1/ubuntu/ precise-updates/main amd64 Packages
     4.1.ESV-R4-0ubuntu5.5 0
        500 http://10.0.0.1/ubuntu/ precise-security/main amd64 Packages
     4.1.ESV-R4-0ubuntu5 0
        500 http://10.0.0.1/ubuntu/ precise/main amd64 Packages
root@maas1000:~#

[Impact]
No having the option enabled by default causes DNS/DHCP to misbehave when managed by MAAS. This option needs to be added when installing from CA/ cloud-pocket tools, however, in order for it to hit the CA needs to be SRu'd.

[Test Case]
1. Install maas
2. check that /etc/maas/templates/dhcp/dhcpd.conf.template has the option enabled.

[Regression Potential]
Minimal. This won't affect saucy at all, but it is required for the cloud-archive (which uses the latest from saucy).

Related branches

Andres Rodriguez (andreserl) wrote :

Hi Matt,

The version of MAAS in the precise ubuntu archives does *not* support ignore-client-uids because the version of isc-dhcp in the precise archives does not support it either.

However, the maas version in the cloud-tools pocket does include the option by default, as we also ship a new version of isc-dhcp (which supports ignore-client-uids).

For this reason, I'm marking this bug invalid. If you feel this issue persists, please re-open the bug.

Cheers.

Changed in maas (Ubuntu):
status: New → Incomplete
status: Incomplete → Won't Fix
status: Won't Fix → Invalid
Andres Rodriguez (andreserl) wrote :

Oh nevermind my comment, I see what you mean!

Changed in maas (Ubuntu):
status: Invalid → Confirmed
importance: Undecided → High
assignee: nobody → Andres Rodriguez (andreserl)
Changed in cloud-archive:
status: New → Confirmed
importance: Undecided → High
Changed in maas:
importance: Undecided → Low
status: New → Confirmed
summary: - maas dhcp.conf template not adding ignore-client-uids unless using
+ [SRU] maas dhcp.conf template not adding ignore-client-uids unless using
raring or later
description: updated
Changed in maas (Ubuntu):
assignee: Andres Rodriguez (andreserl) → nobody

Hello Matt, or anyone else affected,

Accepted maas into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/maas/1.4+bzr1693+dfsg-0ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Changed in maas (Ubuntu Saucy):
status: New → Fix Committed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.4+bzr1693+dfsg-0ubuntu2.2

---------------
maas (1.4+bzr1693+dfsg-0ubuntu2.2) saucy-proposed; urgency=low

  * debian/patches:
    - 99_fix_dhcp_template_lp1240972.patch: Do not prevent the MAAS DHCP
      template from adding ignore-client-uids on precise, which causes
      issues with DNS for MAAS in the Cloud Archive. (LP: #1240972)
    - 99_arm_generic_kernel_lp1166994.patch: Re-enable armhf generic as it
      is supported starting from raring. (LP: #1166994)

maas (1.4+bzr1693+dfsg-0ubuntu2.1) saucy-proposed; urgency=low

  * debian/patches/99_fix_juju_multienv_lp1239488: Allows juju to distinguish
    between different environments, actually fixing the MAAS side of multiple
    juju environment support. (LP: #1239488)
 -- Andres Rodriguez <email address hidden> Thu, 24 Oct 2013 13:35:00 -0700

Changed in maas (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in maas:
status: Confirmed → Fix Released
James Page (james-page) on 2015-03-24
Changed in cloud-archive:
status: Confirmed → Fix Released
Changed in maas (Ubuntu Saucy):
importance: Undecided → High
Changed in maas (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers