Cluster controller fails to start because MAAS_URL is not set.

Bug #1063857 reported by Raphaël Badin on 2012-10-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
maas (Ubuntu)
Critical
Andres Rodriguez

Bug Description

Testing the package in the daily ppa (0.1+bzr1170+dfsg-0+1215+119~ppa0~quantal1), the cluster controller is unable to start:

$ sudo tail -f /var/log/upstart/maas-cluster-celery.log
usage: __main__.py start-cluster-controller [-h] [--user USER] [--group GROUP]
                                            URL
__main__.py start-cluster-controller: error: too few arguments

The cluster controller is started by:
exec /usr/sbin/maas-provision start-cluster-controller $MAAS_URL -u maas -g maas
(see /etc/init/maas-cluster-celery.conf)

I think this is because /etc/maas/maas_cluster.conf contains:
# [...]
MAAS_URL=

If I put MAAS_URL=http://localhost/MAAS in that file, the cluster controller starts ok and fires the cluster worker fine.

Related branches

Raphaël Badin (rvb) wrote :

At Andres' request, here is the output of sudo dpkg-reconfigure -phigh maas-cluster-controller :
$ sudo dpkg-reconfigure -phigh maas-cluster-controller
maas-cluster-celery stop/waiting
/var/lib/dpkg/info/maas-cluster-controller.config: 26: /var/lib/dpkg/info/maas-cluster-controller.config: db_input: not found
/var/lib/dpkg/info/maas-cluster-controller.config: 27: /var/lib/dpkg/info/maas-cluster-controller.config: db_go: not found

affects: maas → maas (Ubuntu)
description: updated
Changed in maas (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
Raphaël Badin (rvb) wrote :

I've tested the most recent package (0.1+bzr1223+dfsg-0ubuntu1~ppa1) and the problem is fixed.

Changed in maas (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers