The DHCP config file does not get written.

Bug #1046397 reported by Raphaël Badin on 2012-09-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
maas (Ubuntu)
Critical
Andres Rodriguez

Bug Description

When masternodegroup.set_up_dhcp() is called, the script /usr/sbin/maas-provision is used to write the DHCP configuration. That script is run using sudo in order to be able to write the config into /etc/dhcp/dhcpd.conf.

The sudo rule to allow that sudo command to be run is missing from debian/extras/99-maas-sudoers: The complete command is: "sudo maas-provision atomic-write --filename /etc/dhcp/dhcpd.conf --mode 744" so I suggest adding something like: "maas ALL= NOPASSWD: /usr/sbin/maas-provision" in debian/extras/99-maas-sudoers. (note that I've tested that fix manually and it solves the problem)

Changed in maas (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
assignee: nobody → Andres Rodriguez (andreserl)
Changed in maas (Ubuntu):
importance: Wishlist → Critical
Raphaël Badin (rvb) wrote :

Julian suggested putting the sudoers file which is currently in the packaging branch into the upstream branch (in contrib). The main advantage would be that it would be more easy for someone running maas directly from the tree to copy the required sudo rules from contrib/sudoers.

Hi Raphael!

I'm not opposed. Please update setup.py accordingly though.
On Sep 6, 2012 10:10 AM, "Raphaël Badin" <email address hidden> wrote:

> Julian suggested putting the sudoers file which is currently in the
> packaging branch into the upstream branch (in contrib). The main
> advantage would be that it would be more easy for someone running maas
> directly from the tree to copy the required sudo rules from
> contrib/sudoers.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1046397
>
> Title:
> The DHCP config file does not get written.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/maas/+bug/1046397/+subscriptions
>

Andres Rodriguez (andreserl) wrote :

Oh and please keep the naming convention as i would like to avoid having to
rename the file in packaging or use (maas-sudoers) please
On Sep 6, 2012 10:42 AM, "Andres Rodriguez" <email address hidden> wrote:

> Hi Raphael!
>
> I'm not opposed. Please update setup.py accordingly though.
> On Sep 6, 2012 10:10 AM, "Raphaël Badin" <email address hidden>
> wrote:
>
>> Julian suggested putting the sudoers file which is currently in the
>> packaging branch into the upstream branch (in contrib). The main
>> advantage would be that it would be more easy for someone running maas
>> directly from the tree to copy the required sudo rules from
>> contrib/sudoers.
>>
>> --
>> You received this bug notification because you are a bug assignee.
>> https://bugs.launchpad.net/bugs/1046397
>>
>> Title:
>> The DHCP config file does not get written.
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/ubuntu/+source/maas/+bug/1046397/+subscriptions
>>
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 0.1+bzr971+dfsg-0ubuntu2

---------------
maas (0.1+bzr971+dfsg-0ubuntu2) quantal; urgency=low

  * debian/extras/99-maas-sudoers: Add missing rule for
    maas-provision. (LP: #1046397)
 -- Andres Rodriguez <email address hidden> Wed, 05 Sep 2012 12:36:58 -0400

Changed in maas (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers