[SRU] After Commission Action 2 no longer exists

Bug #1024010 reported by Andres Rodriguez on 2012-07-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
maas-enlist (Ubuntu)
High
Andres Rodriguez
Precise
Critical
Unassigned
Quantal
High
Andres Rodriguez

Bug Description

In MAAS, there used to be various after_commissioning_actions. These ranged from 0 to 3. Nowadays, the only one left is 0. This needs to be changed in maas-enlist.

If this is not fixed, precise/quantal machines will not be able to enlist against a MAAS server in Quantal, and/or in Precise when it gets backported.

[IMPACT]

Currently, maas-enlist enlists a node with after_commissioning_action=2. The default is 0. However, in newer MAAS releases the actions 1,2,3 no longer exist. The default is still 0. Enlisting with 2 has really no consequences and is no different to enlisting with 0.

Not enlisting with after_commissioning_action=0 means that precise nodes won't be able to enlist into MAAS running on quantal.

[TEST CASE]

== Reproduce Failure ==
1. Install a MAAS server in Quantal and maas-enlist:
    sudo apt-get install maas maas-enlist
2. Try to enlist own node:
    maas-enlist --serverurl=localhost
3. A failure will be shown:
    ubuntu@server-13542:~$ maas-enlist --serverurl localhost
    {"after_commissioning_action": ["Select a valid choice. 2 is not one of the available choices."]}

== Fixed Version ==
1. Install MAAS and the fixed version of maas-enlist
2. Enlist as above (maas-enlist --serverurl=localhost)
3. Success:

ubuntu@server-13542:~$ maas-enlist --serverurl localhost
{
    "status": 0,
    "macaddress_set": [
        {
            "mac_address": "fa:16:3e:0b:f8:be"
        }
    ],
    "power_parameters": "",
    "netboot": true,
    "hostname": "node-fa163e0bf8be.local",
    "power_type": "",
    "system_id": "node-0b48e4aa-cc54-11e1-9dc6-fa163e0bf8be",
    "architecture": "amd64"

[REGRESSION POTENTIAL]
Minimal to None. Current MAAS in precise supports after_commissioning_action=0 as is the default when adding a node.

Changed in maas-enlist (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
importance: Undecided → High
status: New → In Progress
Changed in maas-enlist (Ubuntu Precise):
assignee: nobody → Andres Rodriguez (andreserl)
importance: Undecided → High
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas-enlist - 0.4+bzr27-0ubuntu1

---------------
maas-enlist (0.4+bzr27-0ubuntu1) quantal; urgency=low

  * Fix after_commissioning_action (LP: #1024010)
 -- Andres Rodriguez <email address hidden> Fri, 13 Apr 2012 10:08:30 -0400

Changed in maas-enlist (Ubuntu Quantal):
status: In Progress → Fix Released
description: updated
description: updated
Changed in maas-enlist (Ubuntu Precise):
assignee: Andres Rodriguez (andreserl) → nobody
status: Confirmed → New
importance: High → Critical
summary: - After Commission Action 2 no longer exists
+ [SRU] After Commission Action 2 no longer exists
Changed in maas-enlist (Ubuntu Precise):
milestone: none → ubuntu-12.04.1

Hello Andres, or anyone else affected,

Accepted maas-enlist into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/maas-enlist/0.4-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in maas-enlist (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Andres Rodriguez (andreserl) wrote :

I have tested this and it works as expected. Marking verification-done!

Cheers and thanks for taking care of it.

tags: added: verification-done
removed: verification-needed
Trond Thingstad (trond-t) wrote :

Hi guys, sorry for asking this noob question here..
I just tried to enlist nodes with a Quantal MAAS server, and got the error you are describing here.
I followed the guide EnableProposed and tried to install (as root) with the command:
aptitude install maas-enlist/precise-proposed and /quantal-proposed
but I only get the error message "Unable to find an archive "precise-proposed" for the package "maas-enlist" "
What am I doing wrong?

Keep up the good work

Trond

Andres Rodriguez (andreserl) wrote :

Hi Trond,

Thank you for your concerns.

The proposed version of the package above is only for Precise, not for quantal. You only need to enable the proposed in Precise. This really means that this fix was already released in Quantal and waiting to be confirmed to be released on precise.

Now, the enlistment into a Quantal MAAS server might be failing for some other reason in your case. If you are running the latest release in MAAS, then a dependency needs to be fixed. This fix has already been uploaded into Quantal and is waiting to be released (the package in question is python-txtftp).

In order to confirm the enlistment is not related to that, could you please provide us with 2 thins:

1. Output of maas-enlist command (i.e. maas-enlist --serverurl <1.1.1.1>)
2. Output of:

ps faux | grep maas-pserv

Thank you again for your concerns. I look forward to hearing from you.

Best regards.

Trond Thingstad (trond-t) wrote :

I installed this image to server
http://cdimage.ubuntu.com/ubuntu-server/daily/current/quantal-server-amd64.iso
and ran apt-get install maas after OS installed sucsessfully.
I am running this setup with a separate DHCP-server if that is of importance

Output of maas-enlist -s <url> :
curl: (7) couldn't connect to host

Output of ps faux |grep maas-pserv:
root 2558 0.0 0.0 9384 936 pts/2 S+ 20:05 0:00 \_ grep --color=auto maas-pserv

Output from /var/log/syslog from the past 10 minutes, including when trying to enlist a node.
http://pastebin.com/QUcvW1Pi

A lot of TCP-denied entries in squid-deb-proxy access.log
1342528039.533 0 <node-ip> TCP_DENIED/403 3605 GET http://archive.ubuntu.com/ubuntu/dists/precise/Release - NONE/- text/html

And theres the "select a valid choice" ofc
http://pastebin.com/V1bNFRCW

Perhaps I should try 12.04 for now? :)

Andres Rodriguez (andreserl) wrote :

Hi Trond,

This totally sounds like the issue I was referring to, which is not related to this report. Could you please upgrade the python-txtftp package and restart pserv (and celery)?

sudo apt-get update
sudo apt-get install python-txtftp
sudo service maas-pserv restart
sudo service maas-celery restart

Then you should have maas-pserv running again, and you should not see the above error when trying to enlist.

Hope this resolve your issue.

Best regards

Trond Thingstad (trond-t) wrote :

Thank you for you quick answers!

Sadly it still does not work. Same output from maas-enlist command.
ps faux now outputs:
root 3643 0.0 0.0 9384 932 pts/6 S+ 11:18 0:00 \_ grep --color=auto maas-pserv

The TCP Denied entries in squid-deb-proxy/access.log are gone though.
celery.log : http://pastebin.com/Uek9Kwg1

Any other advices? Should I ask in askubuntu forum instead of spamming this bug-report?

Trond

Andres Rodriguez (andreserl) wrote :

Please, ask a question there and let me know the link so I can follow up there.

Otherwise, you can find me on IRC (freenode) with nickname: roaksoax.

Cheers.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas-enlist - 0.4-0ubuntu1.1

---------------
maas-enlist (0.4-0ubuntu1.1) precise-proposed; urgency=low

  * SRU: Enlist with after_commissioning_action=0 as 2 doesn no longer exist
    in MAAS. (LP: #1024010)
 -- Andres Rodriguez <email address hidden> Thu, 12 Jul 2012 14:44:57 -0400

Changed in maas-enlist (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers