m2crypto fails to build from source in maverick

Bug #600549 reported by Matthias Klose
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
m2crypto (Ubuntu)
High
Marc Deslauriers
Maverick
High
Marc Deslauriers

Bug Description

Binary package hint: m2crypto

seen in a test rebuild and in current maverick (amd64):
https://launchpad.net/ubuntu/+archive/test-rebuild-20100628/+build/1831808

======================================================================
ERROR: test_signEncryptDecryptVerify (tests.test_smime.SMIMETestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/build/buildd/m2crypto-0.20.1/tests/test_smime.py", line 199, in test_signEncryptDecryptVerify
    p7, data = SMIME.smime_load_pkcs7_bio(p7_bio)
  File "/build/buildd/m2crypto-0.20.1/M2Crypto/SMIME.py", line 104, in smime_load_pkcs7_bio
    p7_ptr, bio_ptr = m2.smime_read_pkcs7(p7_bio._ptr())
SMIME_Error: no multipart body failure

======================================================================
ERROR: test_verify (tests.test_smime.SMIMETestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/build/buildd/m2crypto-0.20.1/tests/test_smime.py", line 74, in test_verify
    p7, data = SMIME.smime_load_pkcs7_bio(self.signed)
  File "/build/buildd/m2crypto-0.20.1/M2Crypto/SMIME.py", line 104, in smime_load_pkcs7_bio
    p7_ptr, bio_ptr = m2.smime_read_pkcs7(p7_bio._ptr())
SMIME_Error: no content type

======================================================================
ERROR: test_verifyBad (tests.test_smime.SMIMETestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/build/buildd/m2crypto-0.20.1/tests/test_smime.py", line 97, in test_verifyBad
    p7, data = SMIME.smime_load_pkcs7_bio(self.signed)
  File "/build/buildd/m2crypto-0.20.1/M2Crypto/SMIME.py", line 104, in smime_load_pkcs7_bio
    p7_ptr, bio_ptr = m2.smime_read_pkcs7(p7_bio._ptr())
SMIME_Error: no content type

----------------------------------------------------------------------
Ran 236 tests in 47.092s

FAILED (errors=3)
make: *** [build-stamp] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Matthias Klose (doko)
Changed in m2crypto (Ubuntu):
importance: Undecided → High
milestone: none → maverick-alpha-3
status: New → Confirmed
Changed in m2crypto (Ubuntu Maverick):
assignee: nobody → Marc Deslauriers (mdeslaur)
status: Confirmed → In Progress
Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

Build this with -O0 makes the test suite work again.

Changed in m2crypto (Ubuntu Maverick):
status: In Progress → Triaged
status: Triaged → In Progress
Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

Disregard my previous comment, -O0 doesn't change anything.

Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

Looks like this is failing with openssl 0.9.8o

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package m2crypto - 0.20.1-1ubuntu3

---------------
m2crypto (0.20.1-1ubuntu3) maverick; urgency=low

  * tests/test_smime.py: fix testsuite with newer openssl. (LP: #600549)
    - Backported from http://svn.osafoundation.org/viewvc/m2crypto/trunk/tests/test_smime.py?r1=698&r2=721
 -- Marc Deslauriers <email address hidden> Fri, 09 Jul 2010 11:17:57 -0400

Changed in m2crypto (Ubuntu Maverick):
status: In Progress → Fix Released
Revision history for this message
Matthias Klose (doko) wrote :

confirmed in a rebuild and a local build
http://people.ubuntuwire.org/~lucas/ubuntu-nbs/32/m2crypto_0.20.1-1ubuntu3_lubuntu32.buildlog
reopening, the tests fail with
======================================================================
ERROR: test_sslv23_weak_crypto (tests.test_ssl.MiscSSLClientTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/scratch/packages/tmp/m2crypto-0.20.1/tests/test_ssl.py", line 408, in test_sslv23_weak_crypto
    s.connect(self.srv_addr)
  File "/scratch/packages/tmp/m2crypto-0.20.1/M2Crypto/SSL/Connection.py", line 179, in connect
    ret = self.connect_ssl()
  File "/scratch/packages/tmp/m2crypto-0.20.1/M2Crypto/SSL/Connection.py", line 172, in connect_ssl
    return m2.ssl_connect(self.ssl)
SSLError: unexpected eof

----------------------------------------------------------------------
Ran 237 tests in 162.729s

FAILED (errors=1)
make: *** [build-stamp] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Changed in m2crypto (Ubuntu Maverick):
milestone: maverick-alpha-3 → ubuntu-10.10
status: Fix Released → Confirmed
Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

This new failing test is related to SSLv2 being disabled in openssl 0.9.8o-1ubuntu3, and has nothing to do with the original issue.

The only way to resolve this is to disable that particular test, as it is expected to fail.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package m2crypto - 0.20.1-1ubuntu4

---------------
m2crypto (0.20.1-1ubuntu4) maverick; urgency=low

  * tests/test_ssl.py: disable sslv23_weak_crypto test as it is expected to
    fail with SSLv2 having been disabled in openssl 0.9.8o-1ubuntu3.
    (LP: #600549)
 -- Marc Deslauriers <email address hidden> Fri, 01 Oct 2010 11:58:15 -0400

Changed in m2crypto (Ubuntu Maverick):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers