Konica Minolta Magicolor 2400W uses incorrect driver by default

Bug #250583 reported by Peter De Maeyer on 2008-07-21
6
Affects Status Importance Assigned to Milestone
m2300w (Ubuntu)
Low
Unassigned
system-config-printer (Ubuntu)
Low
Unassigned
ubuntu-meta (Ubuntu)
Low
Unassigned

Bug Description

When I attach my "KONICA MINOLTA magicolor 2400W" printer, it is detected but it uses the wrong driver by default. The default driver is "Minolta magicolor 2300 DL Foomatic/foo2zjs (recommended)" which does not work. In order to install the correct driver, I have to manually install the package "m2300w", and then select "Minolta"->"magicolor 2400W". It would be nicer if ubuntu would auto-detect this correctly.

I am using ubuntu 8.04.1.

The m2300w needs to become a distribution independent driver package on openprinting.org so we can implement this specification: https://blueprints.launchpad.net/ubuntu/+spec/printerdriverautodownload.

Yfrwlf (yfrwlf) wrote :

Yes please. I'd love it if my Konica Minolta 2400W printer Just Worked (tm), but instead it incorrectly thinks it's a 2480MF printer. Even after I install the 2300W driver package from the repository, it still doesn't print (even after a reboot, just to rule that out), and when it does the "searching for drivers" it still doesn't show up as an option, nor does 2300W show up even.

Yfrwlf (yfrwlf) wrote :

Update: The 2300w package puts some ppd files in an archive file, and after using those, it works. So for some reason:

a) it's not automatically and correctly detected
b) installing the 2300w driver package isn't actually installing the driver (correctly)

Weird. ^^

Carl Anderson (nexusrpg) wrote :

I decided to hook up my 2400W to my 8.10 Dell Ubuntu Linux box today, and I did have the problem of it assigning the 2480MF driver, but when I went into administration->printing->right-click->properties, I was able to just select the make and model as a Minolta (Konica Minolta is a different selection and does not have the correct driver for this model) and then click forward and Magicolor 2400W was one of the options. I didn't have to install any packages for this to work. I printed a test page and it worked perfectly, and then I printed a one page PDF and it also worked perfectly. So this appears to still be a minor issue for 8.10, but I'm posting this to help anyone else who runs into an issue with this printer. I have no idea why there are different drivers under Konica Minolta and Minolta, but if one area doesn't list the correct driver, the other probably might.

Yfrwlf (yfrwlf) wrote :

In 9.04, this is no longer true. The driver is no present in the "select printer from database" section. The "search for a printer driver to download" section is also a bit confusing to me, as it finds the right printer model, then on the next page it says "For the printer you have selected there are drivers available for download.", when there aren't. It'd be nice if it wouldn't say that when there are no drivers available. I still don't understand why this now slightly old printer has been completely overlooked as far as the automatic installation system goes even though there is the driver package available in the repository still.

Looks like it's back to installing it via the PPD file using the m2300w package in Synaptic.

Till Kamppeter (till-kamppeter) wrote :

One problem is that the database contains only a Minolta Magicolor 2400W and not a Konica Minolta Magicolor 2400W, therefore there is no match even if the driver is installed. The other problem is that the driver (which is already in main) is not in the seeds for getting installed by default in the Ubuntu installation. The package is rather small, so it should be no problem to add it. A third problem is in system-config-printer, The "search for a printer driver to download" section should not find models for which OpenPrinting cannot deliver a PPD file.

OAP (seagem7) wrote :

Hello. Would some kind soul out there tell me how I make a KONICA MINOLTA MAGICOLOR 2400W 'wireless' as I am assuming it is so old that it is not the later. This is the first time I have ever done a public notice online and hope it will be quicker via you to get an answer - than to plow through a user manual.

I have a laptop HP PAVILION ze 4130 with Windows XP which I have made wireless by installing a NETGEAR WG111 WIRELESS USB ADAPTER - and it has been working fine - so I naively am thinking that I can do the same for the color printer which is attached to a PC in another room which is VISTA.

The broadband is via a BT provided via an ethernet router which is THOMSON ST585 v6.

I am being recommended by a friend to buy AIRPORT EXTREME by Apple and they say the latter router will work without the computers being Apple themselves and that all I need is XP or Vista and Ethernet which I have. I am also being told by Konica Minolta that "Magicolor 2400w is not theirs and I have no contact detail for the latter in order to ask the question "how do I make it wireless?"

Is it so that the Netgear USB Adapter on my laptop is NOT compatible with ???? Thank you in advance.

Changed in m2300w (Ubuntu):
status: Confirmed → Triaged
Changed in system-config-printer (Ubuntu):
status: New → Triaged
Changed in ubuntu-meta (Ubuntu):
status: New → Triaged
Changed in m2300w (Ubuntu):
importance: Undecided → Low
Changed in system-config-printer (Ubuntu):
importance: Undecided → Low
Changed in ubuntu-meta (Ubuntu):
importance: Undecided → Low

> In 9.04, this is no longer true. The driver is no present in the "select printer from database" section.
> The "search for a printer driver to download" section is also a bit confusing to me, as it finds the
> right printer model, then on the next page it says "For the printer you have selected there are
> drivers available for download.", when there aren't. It'd be nice if it wouldn't say that when there
> are no drivers available.

Peter De Maeyer, Yfrwlf,
Still the same in Ubuntu 10.04 or higher?

Changed in system-config-printer (Ubuntu):
status: Triaged → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package m2300w - 0.51-0ubuntu15

---------------
m2300w (0.51-0ubuntu15) oneiric; urgency=low

  * debian/rules: Added PPD files for the KONICA MINOLTA versions of the
    magicolor 2300W/2400W (LP: #250583).
  * debian/rules, debian/control: Compress PPD files with pyppd.
  * debian/rules, debian/control, debian/m2300w.postinst,
    debian/m2300w.ppd-updater: Let automatic update of the PPDs of already
    existing print queues be done by CUPS.
 -- Till Kamppeter <email address hidden> Fri, 19 Aug 2011 20:37:23 +0200

Changed in m2300w (Ubuntu):
status: Triaged → Fix Released
Mathew Hodson (mhodson) on 2015-04-19
Changed in system-config-printer (Ubuntu):
status: Incomplete → Invalid
Changed in ubuntu-meta (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers