Please merge lzma 9.22-2 (main) from Debian testing

Bug #924044 reported by Leo Iannacone
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lzma (Ubuntu)
Wishlist
Unassigned

Bug Description

lzma (9.22-2) unstable; urgency=low

  * Upload to unstable.
  * Previous upload removed lzma-source. (Closes: #651796)
  * Prevent /dev/null removal while testing a file. (Closes: #550543)

 -- Mohammed Adnène Trojette <email address hidden> Sun, 08 Jan 2012 15:15:18 +0100

lzma (9.22-1) experimental; urgency=low

  [ Mohammed Adnène Trojette ]
  * New upstream release (Closes: #460501, #518365)
     + LZMA SDK is placed in the public domain since 4.62.
  * Update debian/patches/02_lzmp.diff.
  * Switch packaging under the terms of the BSD license.
  * Switch to dpkg-source 3.0 (quilt) format
     + debian/control: Build-Depends
        - drop quilt.
        - bump debhelper dependency to 8.0.0.
  * Bump Standards-Version to 3.9.2
  * Drop lzma-source package. It doesn't work with current kernels and
    SquashFS XZ is part of the standard kernel now. Patch courtesy of
    Jonathan Nieder. (Closes: #470893, #553707, #466582)
  * Update file list in lzma-dev. (Closes: #614417)
  * Fix and improve descriptions. (Closes: #535776, #540469)
  * Add deb-lzma script to convert a deb package to LZMA format. Script
    courtesy of Roger Millan. (Closes: #536275)
  * Add Jonathan Nieder as comaintainer.

  [ Jonathan Nieder ]
  * Bump debhelper compatibility to 7.
  * Manage lzma, unlzma, and lzcat through the alternatives system.
    Conflicts: xz-lzma (<< 5.1.1alpha+20110809-2). (Closes: #547802)

 -- Mohammed Adnène Trojette <email address hidden> Sat, 03 Sep 2011 23:27:39 +0200

Related branches

Revision history for this message
Leo Iannacone (l3on) wrote :
Revision history for this message
Leo Iannacone (l3on) wrote :

lzma (9.22-2ubuntu1) precise; urgency=low

  * Merge from debian unstable, remaining changes:
    - make lzma Priority: required and Section: base since
      dpkg Pre-Depends on it.

 -- Leo Iannacone <email address hidden> Tue, 31 Jan 2012 01:32:49 +0100

Changed in lzma (Ubuntu):
status: New → Confirmed
Revision history for this message
Alessio Treglia (quadrispro) wrote :

Leo, please review your patch:

diff -Nru lzma-9.22/debian/changelog lzma-9.22/debian/changelog
--- lzma-9.22/debian/changelog 2012-01-08 15:30:10.000000000 +0100
+++ lzma-9.22/debian/changelog 2012-01-31 01:32:56.000000000 +0100
@@ -1,3 +1,10 @@
+lzma (9.22-2ubuntu1) precise; urgency=low
+
+ * Merge from Debian testing. Remaining changes:
+ - SUMMARISE HERE
+
+ -- Leo Iannacone <email address hidden> Tue, 31 Jan 2012 01:32:49 +0100
+
 lzma (9.22-2) unstable; urgency=low

Unsubscribing sponsors team for now.

Changed in lzma (Ubuntu):
assignee: nobody → Alessio Treglia (quadrispro)
importance: Undecided → Wishlist
status: Confirmed → In Progress
status: In Progress → Incomplete
assignee: Alessio Treglia (quadrispro) → Leo Iannacone (l3on)
Revision history for this message
Alessio Treglia (quadrispro) wrote :

Re-subscribe sponsors when ready.

Revision history for this message
Leo Iannacone (l3on) wrote :

Ops, sorry. Here the following patches with the changelog updated.

Revision history for this message
Leo Iannacone (l3on) wrote :
Changed in lzma (Ubuntu):
status: Incomplete → In Progress
assignee: Leo Iannacone (l3on) → Alessio Treglia (quadrispro)
Revision history for this message
Alessio Treglia (quadrispro) wrote :

Uploaded, thanks!

Changed in lzma (Ubuntu):
status: In Progress → Fix Committed
assignee: Alessio Treglia (quadrispro) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lzma - 9.22-2ubuntu1

---------------
lzma (9.22-2ubuntu1) precise; urgency=low

  * Merge from debian unstable (LP: #924044). Remaining changes:
    - make lzma Priority: required and Section: base since
      dpkg Pre-Depends on it.

lzma (9.22-2) unstable; urgency=low

  * Upload to unstable.
  * Previous upload removed lzma-source. (Closes: #651796)
  * Prevent /dev/null removal while testing a file. (Closes: #550543)

lzma (9.22-1) experimental; urgency=low

  [ Mohammed Adnène Trojette ]
  * New upstream release (Closes: #460501, #518365)
     + LZMA SDK is placed in the public domain since 4.62.
  * Update debian/patches/02_lzmp.diff.
  * Switch packaging under the terms of the BSD license.
  * Switch to dpkg-source 3.0 (quilt) format
     + debian/control: Build-Depends
        - drop quilt.
        - bump debhelper dependency to 8.0.0.
  * Bump Standards-Version to 3.9.2
  * Drop lzma-source package. It doesn't work with current kernels and
    SquashFS XZ is part of the standard kernel now. Patch courtesy of
    Jonathan Nieder. (Closes: #470893, #553707, #466582)
  * Update file list in lzma-dev. (Closes: #614417)
  * Fix and improve descriptions. (Closes: #535776, #540469)
  * Add deb-lzma script to convert a deb package to LZMA format. Script
    courtesy of Roger Millan. (Closes: #536275)
  * Add Jonathan Nieder as comaintainer.

  [ Jonathan Nieder ]
  * Bump debhelper compatibility to 7.
  * Manage lzma, unlzma, and lzcat through the alternatives system.
    Conflicts: xz-lzma (<< 5.1.1alpha+20110809-2). (Closes: #547802)
 -- Leo Iannacone <email address hidden> Tue, 31 Jan 2012 01:32:49 +0100

Changed in lzma (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers