Ubuntu

[Sync request] Please sync lyx 2.0.0~rc1-1 from Debian Unstable

Reported by Dmitry "Divius" Tantsur on 2011-03-09
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lyx (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: lyx

I suggest syncing the first RC because now Natty ships with beta (which is just unusable as to me - it fails to work with my documents created in 1.6.9).

Debian changelog:

lyx (2.0.0~rc1-1) unstable; urgency=low

   [ Per Olofsson ]
   * Use dh_python2 instead of dh_pysupport.
   * Use debhelper sequence 'tex'.

   [ Rene Engelhard ]
   * Add a symlink so that LyX can access the mythes thesaurus files.
   * Build-depend on libmythes-dev.

   [ Sven Hoexter ]
   * New upstream release
   * Stop using defoma: Drop build-dep and dependency for ttf-lyx, remove
     dh_installdefoma from rules and subsequently no longer override_dh_install.
   * Add ttf-lyx.preinst to call dpkg-maintscript-helper rm_conffile
     to remove the old defoma hints file.
   * Build --without-included-mythes (Closes: #612327)
     Kudos to Rene Engelhard and Georg Baum for implementing it right away.
   * Refresh debian/patches/prefer-xdg-open.
 -- Sven Hoexter <email address hidden> Tue, 08 Mar 2011 17:06:27 +0100

This package doesn't have Ubuntu-specific changes.

Dave Walker (davewalker) wrote :
Changed in lyx (Ubuntu):
assignee: nobody → Dave Walker (davewalker)
importance: Undecided → Wishlist
status: New → In Progress
Dave Walker (davewalker) wrote :

Difference is *huge*, but that mainly seems to be refreshed po files. Upstream changelog is hard to find, but the site does indicate it's bug fixes only.

Moving from beta4 -> rc1 for release sounds like a good idea.

lyx 2.0.0~rc1-1 builds on amd64. Sync request ACK'd.

Changed in lyx (Ubuntu):
assignee: Dave Walker (davewalker) → nobody
status: In Progress → Confirmed
Didier Roche (didrocks) wrote :

Hey Dave, Dmitry. Before syncing it, as it still adds a lot of feature, I'd be in favor to ask for a FFe before syncing. Subscribing the release team.

Martin Pitt (pitti) wrote :

Agreed, we should aim to ship the final release in natty. Mostly bug fixes, approved.

Didier Roche (didrocks) wrote :

excellent, proceeding, thanks ffor beeing so reactive pitti! And thanks Dmitry for signaling it :)

Didier Roche (didrocks) wrote :

[Updating] lyx (2.0.0~beta4-1 [Ubuntu] < 2.0.0~rc1-1 [Debian])
 * Trying to add lyx...
2011-03-11 10:32:18 INFO - <lyx_2.0.0~rc1-1.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2011-03-11 10:32:18 INFO - <lyx_2.0.0~rc1-1.dsc: downloading from http://ftp.debian.org/debian/>
2011-03-11 10:32:18 INFO - <lyx_2.0.0~rc1.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
I: lyx [universe] -> lyx_2.0.0~beta4-1 [universe].
I: lyx [universe] -> lyx-common_2.0.0~beta4-1 [universe].
I: lyx [universe] -> ttf-lyx_2.0.0~beta4-1 [universe].

Changed in lyx (Ubuntu):
status: Confirmed → Fix Released

2.0.0-rc2 is available: http://www.lyx.org/News#item1

Created sync request, please pay attention: bug 756538

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers