Bugfix upstream release of Lyx (1.5.6)

Bug #253196 reported by Nicola Ferralis on 2008-07-30
10
Affects Status Importance Assigned to Milestone
lyx (Debian)
Fix Released
Unknown
lyx (Ubuntu)
Low
Luca Falavigna

Bug Description

Binary package hint: lyx

A bugfix upstream release of Lyx (1.5.6) is available, since July 28: http://www.lyx.org/announce/1_5_6.txt

Packages in Intrepid, (and hardy-backports) are currently still at version 1.5.5 and they should be upgraded to the new upstream release.

The LyX team has given the recommendation: "All users are encouraged to upgrade to this version."

Feature Freeze is now in effect. However, I believe this bug qualifies as an exception since this a bug-fix only (and updated translations) upstream release, especially considering that the LyX 1.5.x series has existed for about a year. In other words, this will fix more bugs (including some long-standing annoyances) and is not likely to cause new bugs.

LyX 1.5.6 is the last LyX release before LyX 1.6.0. LyX 1.5.7 will likely be released to coincide with LyX 1.6.0 and will include the ability to import LyX 1.6 documents: http://wiki.lyx.org/LyX/NewInBranch

Important bug fixes (from Debian bug):

- Implement properly word-movement code for both windows and mac
  conventions.

  This also fixes the data-eating 'word-delete' deletes following non-word
  items (including equations and floats) bug!

- Fix LaTeX export of combining characters in utf-8* encodings.

- Output paper size information to dvi or pdf documents when using
  landscape orientation, such that viewers can properly display them.

- Fix crash related to the outline pane with some documents.

- Fix crash when clicking with middle button on a collapsable inset.

Full upstream LyX changelog in second comment: https://bugs.launchpad.net/ubuntu/+source/lyx/+bug/253196/comments/2

Related branches

Changed in lyx:
status: Unknown → New
Dara Adib (daradib) on 2008-08-07
Changed in lyx:
status: New → Confirmed
Dara Adib (daradib) wrote :

The full LyX 1.5.6 release announcement is available here: http://www.lyx.org/announce/1_5_6.txt

The LyX team has given the recommendation: "All users are encouraged to upgrade to this version."

I believe this release may fix Bug 157443 and Bug 94706, though I am not absolutely certain.

Dara Adib (daradib) on 2008-08-22
Changed in lyx:
importance: Undecided → Wishlist
status: Confirmed → Triaged
Dara Adib (daradib) on 2008-08-27
Changed in lyx:
status: Triaged → Confirmed
Dara Adib (daradib) on 2008-08-27
Changed in lyx:
status: Confirmed → Triaged
Dara Adib (daradib) wrote :
Download full text (4.2 KiB)

Feature Freeze is now in effect. However, I believe this bug qualifies as an exception since this a bug-fix only (and updated translations) upstream release, especially considering that the LyX 1.5.x series has existed for about a year. In other words, this will fix more bugs (including some long-standing annoyances) and is not likely to cause new bugs.

LyX 1.5.6 is the last LyX release before LyX 1.6.0. LyX 1.5.7 will likely be released to coincide with LyX 1.6.0 and will include the ability to import LyX 1.6 documents: http://wiki.lyx.org/LyX/NewInBranch

Changelog:

** Updates:
***********

* DOCUMENTATION AND LOCALIZATION

- New (and complete!) Ukrainian localization of the user interface.

- Updated localization of the user interface for Czech, French, Galician,
  German, Italian, Polish, Portuguese and Japanese.

* DOCUMENT INPUT/OUTPUT

- New layout and template files for the Journal of Statistical Software
  (JSS).

- The importer for comma separated value (*.csv) files has been rewritten.
  Now the column separator character is automatically detected.
  Furthermore, the feature has been renamed to "Import->Table (CSV)".

- Paragraph line spacing settings are now imported when importing LaTeX
  files (bug 20).

- The paper orientation is now imported when importing LaTeX files.

- The paper layout and the number of text columns are now imported when
  importing LaTeX files (bug 4867).

- Add support for the xindy index processor (bug 4732).

- Add support for Graphviz Dot files (bug 4882).

- The A&A document class and template has been updated to conform to
  version 6.0 of the A&A specification (bug 4928).

- The 'Case' environment in the AMS classes has been rewritten to produce
  better output.

* USER INTERFACE

- Reenable quote display code, which was not working since 1.5.0.

- Implement properly word-movement code for both windows and mac
  conventions (bugs 2815 and 3580). This uses the new lyxrc variable
  \mac_like_word_movement, which is set to true by default on Mac OS X.
  It could be useful to emacs nostalgics too.

** Bug fixes:
*************

* DOCUMENT INPUT/OUTPUT

- Fix a LaTeX error with nested insets in CJK documents (bug 4913).

- Make sure that a GREEK SMALL LETTER SIGMA is not automatically turned
  into a GREEK SMALL LETTER FINAL SIGMA (and vice versa) on LaTeX output
  (bug 4966).

- Fix LaTeX export of combining characters in utf-8* encodings (bug 4946).

- Output paper size information to dvi or pdf documents when using
  landscape orientation, such that viewers can properly display them
  (bug 2721).

- Fix encoding errors when typewriter font is used (bug 4727).

- Correct the kerning between two subsequent '<' or '>' characters.

* USER INTERFACE

- Fix crash related to the outline pane with some documents (bug 4857).

- Fix crash when clicking with middle button on a collapsable inset
  (bug 4662).

- Fix crash when an outlining function was used for a section inside an
  inset (bug 5004). These functions are now disabled for section that
  are not in the main text area.

- Fix input of numeric values in non-english locales (bug 4951).

- Fix display of filters such as "LaTeX (plain)" in the fil...

Read more...

description: updated
Dara Adib (daradib) wrote :

Changing importance to Low because this is a bugfix release that fixes some important bugs.

description: updated
Changed in lyx:
importance: Wishlist → Low

I have created packages of lyx-1.5.6 for both Intrepid and Hardy on my PPA, at <http://launchpad.net/~andresjriofrio/+archive>. The hardy one is still building, so I haven't had the opportunity to test the program, but I don't expect any problems.

In any case, I hope this helps the MOTU upgrade the official release.

By the way, should the status be changed to "Fix commited" if the package proves appropriate?

Reporting about my packages at <http://launchpad.net/~andresjriofrio/+archive>. At least the hardy one (which would probably go into hardy-backports) works properly. Now all that is left is for someone to `dch -i` it and upload it to the main distribution. (I would do it, but I don't have the proper signature nor permission, not being part of the MOTU team.)

Again, should I change the status?

OK. So now I'm following the Sponsorship Process in the wiki. I am requesting sponsorship. (Couldn't find another way to say it. :P)

Here is the .diff.gz file attached; the source can be found at <ftp://ftp.lyx.org/pub/lyx/stable/lyx-1.5.6.tar.gz>.

The package is for intrepid; backporting shouldn't be a problem, as demonstrated by my PPA.

Dara Adib (daradib) wrote :

The package should NOT be marked as Fix committed. Fix committed refers to changes that are pending and to be uploaded soon or changes that have been uploaded to a -proposed repository. Fix committed is not to be used when patches are attached to a bug report.

As this package has been maintained by Debian with no Ubuntu changes, it is in the best interest to follow Debian policies and get your changes accepted into Debian sid. Later, the Debian package can be synced to Ubuntu.

See http://www.debian.org/doc/maint-guide/ch-update.en.html#s-newupstream-real for Debian policy. If the package you built meets those requirements, please add a comment on the upstream bug[1] and contact the Debian LyX Maintainers or LyX package uploaders (Per Olofsson and Sven Hoexter)[2].

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=492841
[2] http://packages.qa.debian.org/l/lyx.html

James Westby (james-w) wrote :

Hi,

I'm not sure that this qualifies for a freeze exception due to being
bugfix-only when the changlog contains entries starting with
"Add support for". I'm subscribing the release team so that they
can give their opinion.

Thanks,

James

Cesare Tirabassi (norsetto) wrote :

What is the impact on the rdepends:

  science-typesetting
  lyx-common
  gpsim-doc
  gbib
  education-desktop-other

and the rbdepends:

  debian-edu-doc
  lustre
  manderlbot
  sdcc
  sdcc-nf

?

Changed in lyx:
status: Triaged → Incomplete
Luca Falavigna (dktrkranz) wrote :

Changes provided should not affect negatively reverse-dependencies.
As a LyX user, ACK #1 from me.

Changed in lyx:
status: Incomplete → New
Scott Kitterman (kitterman) wrote :

Ack 2. Approved.

Changed in lyx:
status: New → Confirmed
Luca Falavigna (dktrkranz) wrote :

Andreas, mind attaching a clean .diff.gz to this bug report, this way we can review it and eventually upload it. Thanks!

Luca Falavigna (dktrkranz) wrote :

If no actions are taken, I'll review and eventually adjust Andres' package tomorrow.

Changed in lyx:
assignee: nobody → dktrkranz

I really can't work on this right now, as I have a religious retreat this weekend and lots of school work surrounding it. Feel free to take over for me, Luca. :-)

Luca Falavigna (dktrkranz) wrote :

Uploaded to Intrepid.

Changed in lyx:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lyx - 1.5.6-0ubuntu1

---------------
lyx (1.5.6-0ubuntu1) intrepid; urgency=low

  * New upstream release (LP: #253196).

 -- Andres Riofrio <email address hidden> Sat, 25 Oct 2008 15:29:17 +0200

Changed in lyx:
status: Fix Committed → Fix Released
Daniel Miles (themono) wrote :

I'd like to think I am normally reasonably softspoken, but due to it being so near to release, I have to be a little more explicit to be sure I get attention:

What in gods name were people thinking when this got approved?!?!?!?!? Why is it that to use Lyx in my KDE4 desktop, I now have to install:

evince{a} gnome-icon-theme{a} gnome-keyring{a} libglade2-0{a} libgnome-keyring0{a}
  libgp11-0{a} liblaunchpad-integration1{a} libnautilus-extension1{a} libpam-gnome-keyring{a}
  libpoppler-glib3{a} librsvg2-common{a}

Gnome Keyring????? Evince???? What in the name of all that is holy made you people think it was a good idea to have a QT4 based text editor DEPEND on the GNOME PDF READER? This is phenomenal stupidity. What functionality would I be missing in Lyx if I in fact did not have Evince installed? Or the glib bindings for poppler? Why do I need the Gnome Icon Theme???? This is absurdity. How this got approved is totally beyond me, because (a) there is absolutely no reason for these stupid dependencies, and (b) there are actually people out there who do not want to install every GNOME package under the sun just because a developer likes to make everything depend on GNOME for the hell of it.

I'm not a desktop Nazi, but I use an eeepc, so space is very much at a premium. And I'll be damned if I'm pissing away forty odd megs because someone managed to sneak through such an appallingly stupid change after feature freeze.

Again, I apologise for the tone of this. This is nothing personal against anyone, but is very much against their work in this case.

> evince{a} gnome-icon-theme{a} gnome-keyring{a} libglade2-0{a} libgnome-keyring0{a}
> libgp11-0{a} liblaunchpad-integration1{a} libnautilus-extension1{a} libpam-gnome-keyring{a}
> libpoppler-glib3{a} librsvg2-common{a}

These are not listed anywhere as dependencies, they are pulled in as
recommended packages (see https://wiki.ubuntu.com/IntrepidReleaseNotes),
using apt-get install --no-install-recommends lyx solves your problem.

> I'm not a desktop Nazi, but I use an eeepc, so space is very much at a
> premium. And I'll be damned if I'm pissing away forty odd megs because
> someone managed to sneak through such an appallingly stupid change after
> feature freeze.
>
> Again, I apologise for the tone of this. This is nothing personal
> against anyone, but is very much against their work in this case.

We're human beings, we *do* errors, but this is not the case. No changes
have been made to dependencies fields, it's just how APT now manages
recommends in Intrepid. I'm sorry if this caused you troubles, but
please double-check your statements before blaming anyone. Thanks.

Daniel Miles (themono) wrote :

You are quite right. I throw myself at you mercy and apologise profusely! I still think it is an odd change to make, but not as grave of a problem as I mistakenly thought in my haste.

Again, my apologies all round. I just couldn't bear having something go wrong with my beloved lyx :P

Changed in lyx (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.