during ubiquity install lxterminal will not launch from openbox context menu or pcmanfm.

Bug #1474144 reported by Lyn Perrine
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lxterminal (Ubuntu)
New
Undecided
Unassigned

Bug Description

To reproduce while isntalling a dialy build of lubuntu and selecting install in the menu move the mouse cursor off the installer and right click on the a part of a desktop background. There is a short openbox menu to open firefox and and one that says terminal emulator. Clicking the terminal meulator option will not open.
lxterminal:
  Installed: 0.2.0-1
  Candidate: 0.2.0-1
  Version table:
 *** 0.2.0-1 0
        500 http://archive.ubuntu.com/ubuntu/ wily/universe amd64 Packages
        100 /var/lib/dpkg/status
Description: Ubuntu Wily Werewolf (development branch)
Release: 15.10

I expected this to work like a few times before when doing test installs and I noticed a small problem with the installer and was able to run ubuntu-bug from lxterminal launching from the context menu to easily report bugs from the installer without switching to a tty and exporting DISPLAY or opening Firefox which works from the menu downloading a file on the local filesystem and opening the containing folder to pcmanfm open and then use the applications menu to open a terminal and launch ubuntu-bug. I don't think for end users not reporting from the installer this has any problems.

Workaround 2 to launch ubuntu-bug without exporting display. switch to a tty and run cp ~/.config/openbox/lubuntu-rc.xml ~/.config/openbox/rc.xml switch back to tty 7 right click over the root window and select reconfigure for openbox. Then press control alt D to launch pcmanfm and from applicatoins menu launch a terminal.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: lxterminal 0.2.0-1
ProcVersionSignature: Ubuntu 4.0.0-4.6-generic 4.0.7
Uname: Linux 4.0.0-4-generic x86_64
ApportVersion: 2.17.3-0ubuntu4
Architecture: amd64
CasperVersion: 1.361
Date: Mon Jul 13 14:38:27 2015
LiveMediaBuild: Lubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150713)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lxterminal
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Lyn Perrine (walterorlin) wrote :
Revision history for this message
Lyn Perrine (walterorlin) wrote :

This does not affect the live session thankfully.

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1474144

tags: added: iso-testing
Revision history for this message
Lyn Perrine (walterorlin) wrote :

Hmm one reason for this wierdness is that it appears that when launched choosing install from the menu pgrep -a openbox lists

openbox --config-file /openbox/lubuntu-rc.xml the normal place for this config file when using lxsession. It does not appear to be loading this file right as /openbox as a full path does not exist. But when logged into lxde normally openbox is launched with ~/.config/openbox/lubuntu-rc.xml.

description: updated
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers