lxterminal does not change title of window

Bug #1252451 reported by Daniel Kessel on 2013-11-18
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Manual Tests
Medium
Unassigned
lxterminal (Ubuntu)
Medium
Unassigned

Bug Description

according to Test ID 1601 from:

http://packages.qa.ubuntu.com/qatracker/testcases/1601/info

Steps and expected results:

This test will check that LXTerminal changes the title of the currently displayed terminal from the menu bar

In the menu bar, click on "Tabs", then on "Name Tab"
    Set Title dialog opens
Type the title "qa-lubuntu" and click "OK"
    The terminal shows the name "qa-lubuntu"

- However, if multiple tabs are open, the tab itself is renamed. The window title does not change.
- if there is only one window without multiple tabs, the window title is also not changed.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: lxterminal 0.1.11-4ubuntu3
ProcVersionSignature: Ubuntu 3.12.0-2.7-generic 3.12.0
Uname: Linux 3.12.0-2-generic i686
ApportVersion: 2.12.6-0ubuntu1
Architecture: i386
Date: Mon Nov 18 20:58:51 2013
InstallationDate: Installed on 2013-11-18 (0 days ago)
InstallationMedia: Lubuntu 14.04 "Trusty Tahr" - Alpha i386 (20131118)
MarkForUpload: True
SourcePackage: lxterminal
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel Kessel (dkessel) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1252451

tags: added: package-qa-testing
Jackson Doak (noskcaj) wrote :

The best solution would be to add both possibilities. It should be a 4 line fix.

tags: added: bitesize
Changed in ubuntu-manual-tests:
status: New → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxterminal (Ubuntu):
status: New → Confirmed
Changed in lxterminal (Ubuntu):
importance: Undecided → Medium
Changed in ubuntu-manual-tests:
importance: Undecided → Medium
Elfy (elfy) on 2014-10-03
tags: added: lubuntu
Walter Lapchynski (wxl) wrote :

from what i know, there's no intention in lxterminal to change to window title along with the tab label. i think we just need to clean up language.

Kev Bowring (flocculant) wrote :

@Walter - could you double check what's going to happen with lxterminal (eg intention to change to window title) and then we can progress with the testcase bug and remove lxterminal itself from the bug. Thanks :)

Changed in ubuntu-manual-tests:
status: Triaged → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxterminal - 0.3.0-1

---------------
lxterminal (0.3.0-1) unstable; urgency=medium

  * Enabling parallel build (pass --parallel to dh).
  * Remove empty debian/patches/series file.
  * Bump Standards-Version to 3.9.8:
    - removing menu file.
  * Changing Maintainer e-mail to Alioth based one.
  * Merging upstream version 0.3.0 (Closes: #767060, LP: #1252451,
    #1298664, #1389588, #1513347, #1557113).
  * Using https for VCS fields in debian/control file.
  * Adding override on dh_auto_test, it fails with 0.3.0.
  * Enabling hardening (set DEB_BUILD_MAINT_OPTIONS indebian/rules).

 -- Andriy Grytsenko <email address hidden> Tue, 20 Dec 2016 23:44:54 +0200

Changed in lxterminal (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers