lxsession-default-apps updating database window never closes

Bug #1432276 reported by Lyn Perrine on 2015-03-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lxsession (Ubuntu)
Medium
Unassigned

Bug Description

To reproduce on vivid with latest updates go to the menu and prefrences default applications for lxsession. The defualt apps will open a short popup window saying the database is updating when it is loading. Instead this loading message never closes but default apps for lxsession will change the default it just leaves this window open until you close the main default applicatoins for lxsession window.

lxsession-default-apps:
  Installed: 0.5.2-0ubuntu1
  Candidate: 0.5.2-0ubuntu1
  Version table:
 *** 0.5.2-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
        100 /var/lib/dpkg/status
Description: Ubuntu Vivid Vervet (development branch)
Release: 15.04

I did not get this bug in vivid with 0.5.1-1-ubuntu1 of lxsession in a virtual machine but once I updated to 0.5.2.0-ubuntu1 I was able to reproduce this is a small regression probalby.

I expected the previous behavior of the loading window to close once the database has loaded for defualt apps for lxsession. Instead it stays open until main defualt -apps for lxsession is closed.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: lxsession-default-apps 0.5.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-9.9-generic 3.19.1
Uname: Linux 3.19.0-9-generic x86_64
ApportVersion: 2.16.2-0ubuntu3
Architecture: amd64
CurrentDesktop: LXDE
Date: Sat Mar 14 17:22:06 2015
InstallationDate: Installed on 2014-09-30 (165 days ago)
InstallationMedia: Lubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140930)
SourcePackage: lxsession
UpgradeStatus: Upgraded to vivid on 2014-12-12 (92 days ago)

Lyn Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1432276

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxsession (Ubuntu):
status: New → Confirmed
Changed in lxsession (Ubuntu):
importance: Undecided → Medium
Simon Quigley (tsimonq2) wrote :

Not valid anymore in Ubuntu Xenial as of Sunday, November 29, 2015.

Changed in lxsession (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers