Hibernation from LXDE suddenly requires a password

Bug #1424076 reported by Jens on 2015-02-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lxsession (Ubuntu)
Undecided
Unassigned

Bug Description

Last week we performed the usual upgrade and a lot of packages were updated.

Since then, when I want to hibernate this computer, LXDE locks the machine, switches off the monitor, but doesn't hibernate - instead, the logout window remains and a 'sudo' authentication window is displayed above it, but you can only see it when you unlock the screen again.

Entering the password will hibernate as usual. Standby does not require a password.

What is causing this (new) behaviour? This is a simple desktop office computer that has experienced no fiddling or experimenting at all, except that it has been running an updated kernel due to missing hardware support (but this hasn't changed for months).

Thank you!

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: lxsession 0.4.9.2+git20140410-0ubuntu1.2
Uname: Linux 3.17.0-rc4+ x86_64
ApportVersion: 2.14.1-0ubuntu3.7
Architecture: amd64
CurrentDesktop: LXDE
Date: Fri Feb 20 22:50:24 2015
InstallationDate: Installed on 2014-05-16 (280 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64+mac (20140417)
SourcePackage: lxsession
UpgradeStatus: No upgrade log present (probably fresh install)

Jens (jens-launchpad-net) wrote :
Jens (jens-launchpad-net) wrote :

PS: I enabled hibernation according to the official Ubuntu docs by creating a file /etc/polkit-1/localauthority/50-local.d/enable-hibernate.pkla containing

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

This worked fine until about a week ago.

Jens (jens-launchpad-net) wrote :

Solved - but (IMHO) still a bug: it seems that if you configure your user account NOT to require a password for login (so you can just enter anything, or press ENTER), Lubuntu *will* require a password when you do system actions like shutdown, hibernate or reboot.

But it is impossible to enter this password since the screen is being switched off and locked *before* the password prompt appears.

This is still a bug, but I don't know if lxsession is the right package.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers