lxsession-default webbrowser crashes session

Bug #1347402 reported by Brendan Perrine on 2014-07-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
lxsession (Ubuntu)
Undecided
Unassigned

Bug Description

To reproduce boot a live session of Lubuntu. Then on the run command in the menu run lxsession-default webbrowser. Then the session will exit and you will be at a login screen.
I am on lxsession 0.4.9.2+git20140410-0ubuntu1.1
release Ubuntu 14.04.1 LTS
Also note this this exits the session and on first try you can press enter at lightdm and log in. After that you can no longer log into a session if you run lxsession-default webbrowser again.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: lxsession 0.4.9.2+git20140410-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic i686
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: i386
CasperVersion: 1.340
Date: Wed Jul 23 04:04:24 2014
LiveMediaBuild: Lubuntu 14.04.1 LTS "Trusty Tahr" - Release i386 (20140722.2)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lxsession
UpgradeStatus: No upgrade log present (probably fresh install)

Brendan Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1347402

tags: added: iso-testing
Brendan Perrine (walterorlin) wrote :

This does not happen on a daily build of utopic i386 on a desktop running lxsession 0.4.9.2+git20140410-0ubuntu2. And dbus 1.16.18-0ubuntu9. Which /usr/bin/lxsession-default uses dbus.send.

Mikael LE CALVEZ (mikaelvz) wrote :

Same here but on an installed Lubuntu 14.04.1 LTS.
I can reproduce it when :
- Click on reload in lxsession-default-apps on webbrowser
- execute command : "lxsession-default webbrowser"
- Click on "Internet" on openbox menu

Dave Kokandy (drkokandy) on 2015-01-15
Changed in lxsession (Ubuntu):
status: New → Confirmed
Dave Kokandy (drkokandy) wrote :

I cannot reproduce this in a daily Vivid live session, so it may have been fixed in subsequent updates since occurring in Trusty/14.04 LTS. I'm still new to bug triage, so I will reach out and see what to do in this case.

Dave Kokandy (drkokandy) wrote :

I definitely can reproduce this on an up-to-date version of Trusty.

Will file an upstream bug.

My details:

Linux lubuntu-trusty 3.13.0-44-generic #73-Ubuntu SMP Tue Dec 16 00:23:46 UTC 2014 i686 i686 i686 GNU/Linux

lxsession:
  Installed: 0.4.9.2+git20140410-0ubuntu1.1
  Candidate: 0.4.9.2+git20140410-0ubuntu1.1
  Version table:
 *** 0.4.9.2+git20140410-0ubuntu1.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/universe i386 Packages
        100 /var/lib/dpkg/status
     0.4.9.2+git20140410-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages

Dave Kokandy (drkokandy) wrote :
atrika (atrika) wrote :

I can reproduce this bug on a fully up-to-date version of Trusty.

It also happens when I type lxsession-default calculator or press the reload button in lxsession-default-apps for calculator.

Tamer (tamerikowski) wrote :

No issues with Lubuntu Current
( Linux Vivid-Vervet 3.19.0-26-generic #28-Ubuntu SMP Tue Aug 11 14:16:32 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Tamer (tamerikowski) wrote :

bug reproduced with lxle 64bit 14.04.2
Linux t-dt 3.13.0-49-generic #81-Ubuntu SMP Tue Mar 24 19:29:48 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers