PCManFM 1.2.0 - Open Current Folder in Terminal - Not working with spaces in foldername

Bug #1314931 reported by us2000 on 2014-05-01
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
lxsession (Ubuntu)
Undecided
Julien Lavergne
Trusty
Undecided
Unassigned

Bug Description

PCManFM 1.2.0:

F4 or Tools -> "Open Current Folder in Terminal" normally opens a Terminal in the current folder.

Currently this won't work if the foldername contains spaces: no terminal is opened

I think this could be a "correct escaping" problem.

What I expected to happen: F4 also work in folders with spaces, a Terminal should be opened.

Thanks,

us2000

--------------------------------------
Description: Ubuntu 14.04 LTS
Release: 14.04
Linux a 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
pcmanfm:
  Installed: 1.2.0-1
  Candidate: 1.2.0-1
  Version table:
 *** 1.2.0-1 0
        500 http://de.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

us2000 (q-launchpad-r) on 2014-05-01
affects: ibus (Ubuntu) → ubuntu
affects: ubuntu → pcmanfm (Ubuntu)
us2000 (q-launchpad-r) wrote :

The faulty lxsession-default-terminal is some sort of script which handles foldernames with spaces incorrect:

-rwxr-xr-x 1 root root 1012 Apr 10 23:52 /usr/bin/lxsession-default-terminal

#!/bin/sh
#
# Copyright (C) 2013 Julien Lavergne (<email address hidden>)
#
...
echo "Launching terminal manager"
dbus-send --session --print-reply --dest="org.lxde.SessionManager" /org/lxde/SessionManager org.lxde.SessionManager.SessionLaunch string:"terminal_manager" string:$PWD> /dev/null 2>&1

--> The real bug is the missing escaping around $PWD
Updating this file to ..."$PWD"... solved the Problem.

BR us2000

Julien Lavergne (gilir) on 2014-05-16
affects: pcmanfm (Ubuntu) → lxsession (Ubuntu)
Changed in lxsession (Ubuntu):
assignee: nobody → Julien Lavergne (gilir)
Julien Lavergne (gilir) on 2014-06-07
Changed in lxsession (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxsession - 0.4.9.2+git20140410-0ubuntu2

---------------
lxsession (0.4.9.2+git20140410-0ubuntu2) utopic; urgency=medium

  * debian/patches:
   - 90_fix_autostart.patch: Fix autostarting applications from system
     directories (LP: #1308348).
   - 91_fix_color_scheme.patch: Fix color scheme variable (LP: #1316384).
   - 92_enable_network_gui.patch: Register network_gui variable (LP: #1288115).
   - 93_fix_terminal_escape.patch: Fix lxsession-default terminal with folder
     name with spaces (LP: #1314931).
   - 94_fix_generic_app.patch: Fix initialization of GenericSimpleApp
     (LP: #1316832).
  * debian/lxsession.install:
   - Install lxsession-xdg-autostart new excecutable.
 -- Julien Lavergne <email address hidden> Sat, 07 Jun 2014 16:31:46 +0200

Changed in lxsession (Ubuntu):
status: In Progress → Fix Released
us2000 (q-launchpad-r) wrote :

Thanks!
BR
us2000

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxsession (Ubuntu Trusty):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers