lxsession-default missing lock handler

Bug #1286686 reported by ibere fernandes on 2014-03-02
82
This bug affects 16 people
Affects Status Importance Assigned to Milestone
lxsession (Ubuntu)
Medium
Unassigned

Bug Description

STEPS TO REPRODUCE:
Run `lxsession-default lock` OR use the Ctrl-Alt-L shortcut.

EXPECTED RESULTS:
The screen locks.

ACTUAL RESULTS:
The screen does not lock. In terminal, it feeds back that the screen is being locked, but nothing happens.

AFFECTED VERSIONS:
trusty to vivid

MORE INFO:
lubuntu-rc.xml calls `lxsession-default lock` with Ctrl-Alt-L. This should call `lxlock` as defined in its desktop.conf.

WORKAROUND:
At least for using the shortcut, `lxsession-default lock` can be replaced with `lxlock`. However, anything calling `lxsession-default lock` will still fail.

Revision history for this message
ibere fernandes (ibere-fernandes) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1286686

tags: added: iso-testing
Revision history for this message
ibere fernandes (ibere-fernandes) wrote :

still alive at todays image. pls, check bug.txt.

Revision history for this message
ibere fernandes (ibere-fernandes) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxsession (Ubuntu):
status: New → Confirmed
Revision history for this message
Lyn Perrine (walterorlin) wrote :

also running the command lxsession-default lock
prints
lock

Launching lock manager

but the screen does not lock

A possible workaround for getting a locked screen on control alt l is to make the keybinding in ~/.config/openbox

  <!-- Lock the screen on Ctrl + Alt + l-->
    <keybind key="C-A-l">
      <action name="Execute">
        <command>lxlock </command>
      </action>
    </keybind>
Will hardcode lxlock into the keybinding.

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

It's estimated to have a moderate impact on a large portion of Ubuntu users.

Changed in lxsession (Ubuntu):
importance: Undecided → High
Revision history for this message
Plurtu (plurtu) wrote :

Also in 13.10 it uses:

<command>xscreensaver-command -lock</command>

but xscreensaver is not installed and it should be using lightdm, preferably lxlock which ranks locking programs by preference.

Revision history for this message
bapoumba (bapoumba) wrote :

14.04 here.
<ctrl><alt><l>, lxlock or Logout Menu > Lock Screen do not work.

bapoumba@SonyBlue:~$ light-locker-command
** Message: light-locker is not running
bapoumba@SonyBlue:~$ light-locker &
[1] 5415
bapoumba@SonyBlue:~$ light-locker-command -l
bapoumba@SonyBlue:~$ lxlock

Both light-locker-command -l and lxlock work after starting light-locker-command, but lxsession-default lock does not. Am I on the right tracks ?

Revision history for this message
bapoumba (bapoumba) wrote :

http://ubuntuforums.org/showthread.php?t=2224690
Adding light-locker to the Autostart Applications fixes the issue for one user and myself.

Revision history for this message
Alessandro Magnolo (ale-magnolo) wrote :

light-locker shows the lock screen but you can bypass it by pressing CTRL-ALT-F7, and the session is unlocked with no password asked.

Revision history for this message
Gideon Messer (inventorm91) wrote :

This is not an issue with the Openbox keyboard shortcut. Running the command "lxsession-default -lock" does not lock the screen, despite sending the "lock" command to the session manager through dbus.

$ lxsession-default lock
lock

Launching lock manager

<From dbus-monitor>

method call sender=:1.40 -> dest=org.lxde.SessionManager serial=2 path=/org/lxde/SessionManager; interface=org.lxde.SessionManager; member=SessionLaunch
   string "lock"
   string ""

The fault appears to be with the lxsession program. I checked the source code for lxsession, and could not find a handler for the "lock" argument.

Revision history for this message
Severin Wünsch (sk1d) wrote :

in lubuntu 14.10 it is still not possible to lock screen with ctrl+alt+l

Severin Wünsch (sk1d) on 2014-10-28
tags: added: utopic
Revision history for this message
Born In December (d3c1978) wrote :

This works for me:
dm-tool lock

Edit the File: ~/.config/openbox/lubuntu-rc.xml (line to be changed added for clarity)

     <!-- Lock the screen on Ctrl + Alt + l-->
     <keybind key="C-A-l">
       <action name="Execute">

         <command>dm-tool lock</command>
         <!-- <command>lxsession-default lock</command> -->

       </action>
     </keybind>

Revision history for this message
John L (jlint15) wrote :

I have experienced the same issue in Lubuntu 14.04

To fix the issue I did the following:

1. Opened the /.config/openbox/lubuntu-rc.xml file
2. Changed line 423 from "<command>lxsession-default lock</command>" to "<command>dm-tool lock</command>"

Looks like the same fix a few others did too.

Walter Lapchynski (wxl) on 2014-11-06
summary: - Lock screen shortcut is not working
+ lxsession-default missing lock handler
Walter Lapchynski (wxl) on 2014-11-06
tags: added: vivid
Changed in lxsession (Ubuntu):
status: Confirmed → Triaged
importance: High → Medium
description: updated
Revision history for this message
Walter Lapchynski (wxl) wrote :

Confirmed for trusty through vivid. There was a similar problem with lxsession where `lxsession-default terminal` wasn't being properly called, so this should be a relatively easy fix.

Moved to medium due there being a bit of a workaround and the fact that lxsession is not core to Ubuntu itself.

Revision history for this message
Walter Lapchynski (wxl) wrote :
Revision history for this message
Chris Guiver (guiverc) wrote :

Thank you for reporting this bug to Ubuntu.

Ubuntu 19.10 (eoan) reached end-of-life on July 17, 2020.
Ubuntu 19.04 (disco) reached end-of-life on January 23, 2020.
Ubuntu 18.10 (cosmic) reached end-of-life on July 18, 2019.
Ubuntu 17.10 (artful) reached end-of-life on July 19, 2018.
Ubuntu 17.04 (zesty) reached end-of-life on January 13, 2018.
Ubuntu 16.10 (yakkety) reached end-of-life on July 20, 2017.
Ubuntu 15.10 (wily) reached end-of-life on July 28, 2016.
Ubuntu 15.04 (vivid) reached end-of-life on February 4, 2016.
Ubuntu 14.10 (utopic) reached end-of-life on July 23, 2015.
Ubuntu 14.04 (trusty) reached end-of-life on April 25, 2019.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test. If you then find the bug is still present in the newer Ubuntu version, please add a comment here telling us which new version it is in.

Changed in lxsession (Ubuntu):
status: Triaged → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for lxsession (Ubuntu) because there has been no activity for 60 days.]

Changed in lxsession (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers