lubuntu cosmic lxqt-panel world clock truncated in 12-hr format

Bug #1788068 reported by vmc on 2018-08-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LXQt
New
Unknown
lxqt-panel (Ubuntu)
Undecided
Unassigned

Bug Description

Configuring world-clock to 12-hr format, the first digit gets clipped off.
There is not enough area to accurately display full digits correctly. Especially double digits, as in 12:12PM

Walter Lapchynski (wxl) wrote :

I cannot confirm this in a daily image with lxqt-panel 0.13.0-0ubuntu3, as you can see in the attached. Clear steps to reproduce, perhaps with particular screen sizes, along with images of the bug, would be very helpful.

Changed in lxqt-panel (Ubuntu):
status: New → Incomplete
vmc (vmclark) wrote :

Walter, that's because you "pad" with a zeo. Try without padding.

Walter Lapchynski (wxl) wrote :

Here it is with no padding and set to an hour greater than 9.

Simon Quigley (tsimonq2) wrote :

I've personally confirmed this a few times, it's known upstream.

Changed in lxqt-panel (Ubuntu):
status: Incomplete → Confirmed
vmc (vmclark) wrote :

Notice the "clipped" "9" on my attachment.

Changed in lxqt:
status: Unknown → New
Walter Lapchynski (wxl) wrote :

I'm struggling to reproduce this. I do see you've shown me the problem, vmc, but I don't know how to make my system have the same problem. In other words, it is not that way on a fresh install. I suspect there is something about the settings you have that result in this change. What LXQt theme are you using? What about the font settings?

Changed in lxqt-panel (Ubuntu):
status: Confirmed → Incomplete
Walter Lapchynski (wxl) wrote :

BTW marking as Incomplete regardless of whether or not we've heard other people having the problem. If we can't reproduce it, we don't have enough information to provide a fix.

description: updated
summary: - lubuntu cosmic lxqt-panel world clock area
+ lubuntu cosmic lxqt-panel world clock truncated in 12-hr format
vmc (vmclark) wrote :

Here's how you can reproduce it:
(1) Remove or disable sddm
(2) Install getty autologin: https://wiki.archlinux.org/index.php/getty
(3) Reboot.

Here's my files to allow getty-auto-login:

===.xinitrc:===

[[ -f ~/.Xresources ]] && xrdb -merge -I$HOME ~/.Xresources
exec startlxqt

===.bash_profile:===

#
# ~/.bash_profile
#
[[ -f ~/.bashrc ]] && . ~/.bashrc
if [[ -z $DISPLAY ]] && [[ $(tty) = /dev/tty1 ]]; then
    exec startx -- vt1 &> /dev/null
fi

===getty===

sudo systemctl edit getty@tty1
add the following text:
[Service]
ExecStart=
ExecStart=-/sbin/agetty --skip-login --noissue -a <USER NAME> %I $TERM

===then cat to make sure its correct===
cat /<email address hidden>/override.conf

This work in EVERY LXQT except Lubuntu (manjaro, Sparky)
It works with Xubuntu also.

Walter Lapchynski (wxl) wrote :

Well now that's a really strange use case. Why not just use autologin in SDDM?

vmc (vmclark) wrote :

Its not a really strange case. Its used on many distros, and documented many times as well.
 The point is why it doesn't work on Lubuntu, and only Lubuntu.

Walter Lapchynski (wxl) wrote :

Well, let's ask this: does it work with sddm? Because if it does, sddm
ships with Lubuntu, i.e. Lubuntu implies the use of sddm. So, yes, weird
use case, regardless of whether or not it's common for you. I use
awesome with Lubuntu, but that's frankly pretty weird and I'm capable of
admitting as much.

Furthermore, if removing sddm causes the problem using lxqt-panel on
Xubuntu does not cause the problem, then this isn't an lxqt-panel
problem, either. Or did you mean it works fine with their panel? If
that's the case, did you check the versions of lxqt-panel on these other
OSes? If they're the same, something's really strange…

Alf Gaida (agaida) wrote :

The bug is valid, the steps to reproduce are not - it might be a QSS-Bug - so yes, the widht of the clock wrong under certain circumstances - unfortunately we are not able to reproduce/fix it reliable upstream right now :)

vmc (vmclark) wrote :

Manjaro-lxqt:
Name : lxqt-panel
Version : 0.13.0-2
Description : The LXQt desktop panel
Architecture : x86_64

The above panel works correctly with getty-auto-login

Walter Lapchynski (wxl) wrote :

@agaida tsimonq2 said the bug is known upstream. Is there a bug report
for this? Why is this only a problem in some distributions?

@vmc you didn't answer my question about Xubuntu. Are you saying it
works with their panel or with lxqt-panel installed in Xubuntu? If the
latter, have you tried lxqt-panel in the other flavors of Ubuntu? What
are the results?

vmc (vmclark) wrote :

It woks fine on Xubuntu on xfce-panel. I haven't tried lxqt on Xubuntu

Walter Lapchynski (wxl) wrote :

That's kind of apples and oranges then, unfortunately. I have a sneaking
suspicion this might be some XDG sort of things. Can you collect all the
XDG variables on your Lubuntu, as well as Xubuntu and Manjaro?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.