Keyboard input suddenly stops to work, but when i log off and relog it comes back to normal.(I cant use keyboard after the bug happens, but i can do it normaly after log out- log on)

Bug #1876503 reported by Leonardo on 2020-05-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lxqt-config (Ubuntu)
Undecided
Unassigned

Bug Description

My keyboard stop responding randomly, sometimes during High ram consume, and other times during idling(no high demanding programs opened), when this happen i need to log out and log in again or reset the pc. The mouse is working normally under this "status" where keyboard isnt.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: lxqt-config 0.14.1-0ubuntu3
ProcVersionSignature: Ubuntu 5.4.0-28.32-generic 5.4.30
Uname: Linux 5.4.0-28-generic x86_64
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: LXQt
Date: Sat May 2 15:07:23 2020
InstallationDate: Installed on 2020-04-29 (2 days ago)
InstallationMedia: Lubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
SourcePackage: lxqt-config
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Leonardo (munsko) wrote :
Revision history for this message
Leonardo (munsko) wrote :
Revision history for this message
Leonardo (munsko) wrote :
Leonardo (munsko) on 2020-05-05
information type: Public → Private Security
information type: Private Security → Public Security
information type: Public Security → Private Security
information type: Private Security → Public
Revision history for this message
Chris Guiver (guiverc) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Bug reporting is mostly about finding & fixing problems thus preventing future users from hitting the same bug.

I suspect a Support site would be more appropriate, eg. https://answers.launchpad.net/ubuntu. You can also find help with your problem in the support forum of your local Ubuntu community http://loco.ubuntu.com/ or asking at https://askubuntu.com or https://ubuntuforums.org, or for more support options please look at https://discourse.ubuntu.com/t/community-support/709

For example, you provided no clues as to if any keyboard functions work, does it include trying to switch to a text terminal (ctrl+alt+f4), commands given directly to kernel (ie. to kill your GUI, reboot etc). I get the feeling your issue maybe just thrashing, or if you don't have swap enabled, enabling swap may reduce your issue significantly.. These are areas that support can help with, or if they've already been attempted, those issues mentioned as making no change, or issue remains for each thing tried.

(depending on how your keyboard is powered; I'd also check your hardware including power-supply)

Revision history for this message
Leonardo (munsko) wrote :

Hello Chris.

After all this time i found that when this happens, i can "solve" it pressing the same combination of keys that caused it.
It happens to me when i use Function(Fn) key plus the key that makes volume up (+vol), makes it go down (-vol) or sometimes when i press the mute key.(mute)

For example, if i was lowing the sound and the problem happens, my keyboard stops responding and my volume goes to 0%, even if i was in ,lets say 70%, and i tried to go to 67%(i need to press the key only one time to make that).

If the keyboard becomes "locked", i need to press again Fn+(-vol) key several times to "recover" the keybaord again, and after that i can use it normally.

The same happens sometimes with mute key and (+vol) key, is a bit strange thing to explain for me.

I don't know what could makes this happen, since it happened to me in 18.04 an 20.04 too.

I managed myself to press again the 2 keys that i pressed before the keyboard becomes locked, so it is just an annoying thing, not a big error as you have said.

About the other combinations of keys, when this happens i only can press the key combination that triggered the "keyboard lock", and other keys does not work. The mouse, at the contrary, works perfectly and that is why i managed myself to discover that log off and log in again solves my problem the 1st time i discovered it.

I found in the !shourcut keys" that these actions are related to this commands:

XF86AudioMute
XF86AudioRaiseVolume
XF86AudioLowerVolume

Maybe there is something wrong with those command and my hardware,but i don't have idea about that.

Thanks for see the topic and take a moment to answer me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers