Ubuntu

[11.10 - 12.04] lxpanel crashing randomly. High CPU-Load nothing is clickable correctly. Redraw fails

Reported by Michael Basse on 2011-12-20
56
This bug affects 8 people
Affects Status Importance Assigned to Milestone
LXDE
Unknown
Unknown
lxpanel (Ubuntu)
Undecided
Unassigned

Bug Description

after some time the lxpanel is using a high cpu load

 1561 michael 20 0 239m 6720 4596 R 98 0.7 2:00.89 lxpanel

i cant click anything in my lxpanel. alt-tab is working without problems to switch windows.

It seems like the entries in the crashed lxpanel dont have the correct position.

e.g. i have 3 opened windows. When i close the window (1st entry in lxpanel) , lxpanel is still showing the 3 opened windows. when i click on the first entry (the window which was closed) the 2. window opens, so maybe lxpanel is just not redrawing but still opening entries by a click.

I dont know how to reproduce the crash of lxpanel, also i cant find usefull infos in /var/log/syslog

Would be great if someone has a hint about better debug-options.

At the moment i am calling "lxpanel --profile Lubuntu&". i hope this will get better debug-infos when it is crashing again.

Happening on Ubuntu 11.10 and 12.04. Cant rember that it was happening on 11.04

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: lxpanel 0.5.8-1ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-5.11-generic 3.2.0-rc5
Uname: Linux 3.2.0-5-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Config_Home_Lubuntu:
 [Command]
 FileManager=pcmanfm %s
 Terminal=lxterminal -e
 Logout=lubuntu-logout
Date: Tue Dec 20 11:54:13 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110426)
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: lxpanel
UpgradeStatus: Upgraded to precise on 2011-12-04 (15 days ago)

summary: [11.10 - 12.04] lxpanel crashing randomly. High CPU-Load nothing is
- clickable
+ clickable correctly. Redraw fails

there is

lxpanel --log 5 --profile Lubuntu

i will do some testing about that to get better debug-informations

i can reproduce it by opening 30 libreoffice-files and then clicking very fast on the different libreoffice-tabs in lxpanel. (System-Load and RAM-Usage are very high when having 30 files here opened)

lxpanel --log 5 --profile Lubuntu& does not produce any debug infos on TTY or /var/log/syslog

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxpanel (Ubuntu):
status: New → Confirmed

In my case, lxpanel also takes all the cpu when I disconnect my USB webcam :-?

Jalakas (jalakas) wrote :

I have had this issue many times with only 3-5 documents (pdf-s and libreoffice). I believe it is something related with changes between of windows.

Henry Gebhardt (hsggebhardt) wrote :

Can someone try this patch, please?

The attachment "Fix infinite loop" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

Hi Henry,
thank you for the patch. I will do some testing with it. Maybe others want the same so here is the i386 build

The files can be found here

http://alpha-unix.de/~iceroot/ubuntu/lxpanel/

lxpanel (0.5.8-1ubuntu5) precise; urgency=low

  * Apply patch for lxpanel crash on high load LP: #906825

 -- Michael Basse <email address hidden> Sun, 29 Jan 2012 17:50:28 +0100

You have to download the files and install with "sudo dpkg -i *.deb"

Because i dont have an AMD64 machine i cant build the amd64 version

Stan (sergienko-stanislav) wrote :

unsubscribe

2012/1/30 yan <email address hidden>

> unsubscribe
>
> --
> You received this bug notification because you are a member of Lubuntu,
> which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/906825
>
> Title:
> [11.10 - 12.04] lxpanel crashing randomly. High CPU-Load nothing is
> clickable correctly. Redraw fails
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/lxde/+bug/906825/+subscriptions
>
>

--
best regards
Stanislav Sergienko

jintux (jintux) wrote :

You are now succesfully unsubscribed!

On Mon, Jan 30, 2012 at 2:14 PM, Stan <email address hidden> wrote:

> unsubscribe
>
> 2012/1/30 yan <email address hidden>
>
> > unsubscribe
> >
> > --
> > You received this bug notification because you are a member of Lubuntu,
> > which is subscribed to the bug report.
> > https://bugs.launchpad.net/bugs/906825
> >
> > Title:
> > [11.10 - 12.04] lxpanel crashing randomly. High CPU-Load nothing is
> > clickable correctly. Redraw fails
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/lxde/+bug/906825/+subscriptions
> >
> >
>
>
> --
> best regards
> Stanislav Sergienko
>
> --
> You received this bug notification because you are a member of Lubuntu,
> which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/906825
>
> Title:
> [11.10 - 12.04] lxpanel crashing randomly. High CPU-Load nothing is
> clickable correctly. Redraw fails
>
> Status in LXDE - Lightweight X11 Desktop Environment:
> Unknown
> Status in “lxpanel” package in Ubuntu:
> Confirmed
>
> Bug description:
> after some time the lxpanel is using a high cpu load
>
> 1561 michael 20 0 239m 6720 4596 R 98 0.7 2:00.89 lxpanel
>
> i cant click anything in my lxpanel. alt-tab is working without
> problems to switch windows.
>
> It seems like the entries in the crashed lxpanel dont have the correct
> position.
>
> e.g. i have 3 opened windows. When i close the window (1st entry in
> lxpanel) , lxpanel is still showing the 3 opened windows. when i click
> on the first entry (the window which was closed) the 2. window opens,
> so maybe lxpanel is just not redrawing but still opening entries by a
> click.
>
> I dont know how to reproduce the crash of lxpanel, also i cant find
> usefull infos in /var/log/syslog
>
> Would be great if someone has a hint about better debug-options.
>
> At the moment i am calling "lxpanel --profile Lubuntu&". i hope this
> will get better debug-infos when it is crashing again.
>
> Happening on Ubuntu 11.10 and 12.04. Cant rember that it was happening
> on 11.04
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: lxpanel 0.5.8-1ubuntu3
> ProcVersionSignature: Ubuntu 3.2.0-5.11-generic 3.2.0-rc5
> Uname: Linux 3.2.0-5-generic i686
> ApportVersion: 1.90-0ubuntu1
> Architecture: i386
> Config_Home_Lubuntu:
> [Command]
> FileManager=pcmanfm %s
> Terminal=lxterminal -e
> Logout=lubuntu-logout
> Date: Tue Dec 20 11:54:13 2011
> EcryptfsInUse: Yes
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110426)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> SourcePackage: lxpanel
> UpgradeStatus: Upgraded to precise on 2011-12-04 (15 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/lxde/+bug/906825/+subscriptions
>

Shiki (shiki) wrote :

Oh Jesus, this made my day. =D

Stan: That's not how you unsubscribe. Open the link at the bottom of the e-mail. At the right part of your screen, you will see a "Mute bug mail" option. That will suppress these emails.

Riccardo Rondelli (riccardoro) wrote :

Unsubscribe

Efe Gümüş (efegumus) wrote :
Download full text (5.3 KiB)

unsubscribe

On 30 January 2012 16:19, jintux <email address hidden> wrote:

> You are now succesfully unsubscribed!
>
> On Mon, Jan 30, 2012 at 2:14 PM, Stan <email address hidden> wrote:
>
> > unsubscribe
> >
> > 2012/1/30 yan <email address hidden>
> >
> > > unsubscribe
> > >
> > > --
> > > You received this bug notification because you are a member of Lubuntu,
> > > which is subscribed to the bug report.
> > > https://bugs.launchpad.net/bugs/906825
> > >
> > > Title:
> > > [11.10 - 12.04] lxpanel crashing randomly. High CPU-Load nothing is
> > > clickable correctly. Redraw fails
> > >
> > > To manage notifications about this bug go to:
> > > https://bugs.launchpad.net/lxde/+bug/906825/+subscriptions
> > >
> > >
> >
> >
> > --
> > best regards
> > Stanislav Sergienko
> >
> > --
> > You received this bug notification because you are a member of Lubuntu,
> > which is subscribed to the bug report.
> > https://bugs.launchpad.net/bugs/906825
> >
> > Title:
> > [11.10 - 12.04] lxpanel crashing randomly. High CPU-Load nothing is
> > clickable correctly. Redraw fails
> >
> > Status in LXDE - Lightweight X11 Desktop Environment:
> > Unknown
> > Status in “lxpanel” package in Ubuntu:
> > Confirmed
> >
> > Bug description:
> > after some time the lxpanel is using a high cpu load
> >
> > 1561 michael 20 0 239m 6720 4596 R 98 0.7 2:00.89 lxpanel
> >
> > i cant click anything in my lxpanel. alt-tab is working without
> > problems to switch windows.
> >
> > It seems like the entries in the crashed lxpanel dont have the correct
> > position.
> >
> > e.g. i have 3 opened windows. When i close the window (1st entry in
> > lxpanel) , lxpanel is still showing the 3 opened windows. when i click
> > on the first entry (the window which was closed) the 2. window opens,
> > so maybe lxpanel is just not redrawing but still opening entries by a
> > click.
> >
> > I dont know how to reproduce the crash of lxpanel, also i cant find
> > usefull infos in /var/log/syslog
> >
> > Would be great if someone has a hint about better debug-options.
> >
> > At the moment i am calling "lxpanel --profile Lubuntu&". i hope this
> > will get better debug-infos when it is crashing again.
> >
> > Happening on Ubuntu 11.10 and 12.04. Cant rember that it was happening
> > on 11.04
> >
> > ProblemType: Bug
> > DistroRelease: Ubuntu 12.04
> > Package: lxpanel 0.5.8-1ubuntu3
> > ProcVersionSignature: Ubuntu 3.2.0-5.11-generic 3.2.0-rc5
> > Uname: Linux 3.2.0-5-generic i686
> > ApportVersion: 1.90-0ubuntu1
> > Architecture: i386
> > Config_Home_Lubuntu:
> > [Command]
> > FileManager=pcmanfm %s
> > Terminal=lxterminal -e
> > Logout=lubuntu-logout
> > Date: Tue Dec 20 11:54:13 2011
> > EcryptfsInUse: Yes
> > InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386
> (20110426)
> > ProcEnviron:
> > PATH=(custom, no user)
> > LANG=de_DE.UTF-8
> > SHELL=/bin/bash
> > SourcePackage: lxpanel
> > UpgradeStatus: Upgraded to precise on 2011-12-04 (15 days ago)
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/lxde/+bug/906825/+subscriptions
> >
>
> --
> You received this bug notif...

Read more...

sirens5 (itfactor36) wrote :

unsubscribe

Walter Lapchynski (wxl23) wrote :

had firefox, thunderbird, lxterminal, lxtask, and file-roller going although the latter was idle. i've had this on a rare occassion before. not really sure why. lxpanelctl restart usually puts it in its place.

Henry,
i can confirm that your patch was fixing the issue. Can you put your patch upstream?

Henry Gebhardt (hsggebhardt) wrote :

On Thu, Feb 16, 2012 at 12:54:03AM -0000, Michael Basse wrote:
> Henry,
> i can confirm that your patch was fixing the issue. Can you put your patch upstream?

Thanks for testing, Julien just pushed the patch upstream a few days
ago:

http://lxde.git.sourceforge.net/git/gitweb.cgi?p=lxde/lxpanel;a=commit;h=0c1fb08a70ae10d4e959988752fa2e4320dd2faa

I suppose the bug can be closed?

Cheers,
Henry

Henry,
thank you for the info. The bug can not be closed. I was running "my version" of lxpanel which was using your patch fine for the last weeks. Some days ago i installed the latest lxpanel from the repos. This version has still the bug, so the bug is still affecting the package from 12.04

lxpanel (0.5.8+git20120212-0ubuntu1) precise; urgency=low

  * New upstream snapshot
   - Run dialog opens up in the background (LP: #889414)
   - Abiliy to configure task Bar Font (LP: #690662)
   - Volume applet uses wrong icon (LP: #878117)
   - Add ability for lxpanel sound applet to launch a GUI for sound management
     (LP: #692276)
   - lxpanel indicator support can't be configured (LP: #692260)
   - Task Bar (Window List) - Options on 64bit version are different than 32bit
     version (LP: #909127)
  * debian/patches
   - indicator-support.patch: Remove, merged upstream.
   - fix_indicator_dir.patch: Remove, merged upstream.
   - fix_position.patch: Remove, merged upstream.
   - missing_glades.patch: Remove, fixed upstream.
   - default-config.patch: Refresh.
   - configure_desktop_number.patch: Refresh.
   - 99_refresh_autotools.patch: Refresh.
  * debian/control:
   - Build-depends on libwnck-dev.
  * debian/lxpanel.install:
   - Add new plugins.

 -- Julien Lavergne <email address hidden> Mon, 13 Feb 2012 23:40:40 +0100

@Julien, does this version already contains the patch from henry?

Julien Lavergne (gilir) wrote :

lxpanel snapshot is from 2012-02-12, and the patch was commited on 2012-01-28, so yes the patch is include in precise.

Changed in lxpanel (Ubuntu):
status: Confirmed → Fix Released

defnitly NOT fixed. Today (with the new lxpanel package) i was facing two crashes. 100%cpu load, nothing clickable. alt+tab still working

Also the entrys in lxpanel moved left and were at the same position as my icons

http://alpha-unix.de/~iceroot/ubuntu/lxpanel-crash.png (left in lxpanel is my entry for my terminator session)

strange thing is that i was not facing these bugs with "my packages" were i applied the patch see #10) but with the latest lxpanel from the repos i was facing the bug twice today

Changed in lxpanel (Ubuntu):
status: Fix Released → Confirmed

steps to reproduce:

produce a very high cpu load (in this case it was a very high io-load), then switch windows by clicking on the entrys in lxpanel, after some seconds lxpanel crashed (100%cpu load)

Henry Gebhardt (hsggebhardt) wrote :

On Thu, Feb 16, 2012 at 10:51:27PM -0000, Julien Lavergne wrote:
> lxpanel snapshot is from 2012-02-12, and the patch was commited on
> 2012-01-28, so yes the patch is include in precise.

That is when I created the patch, but the email of you merging it
upstream was from 2012-02-11, and it wasn't mentioned in the changelog
in comment #21. So just maybe it isn't in precise yet after all....

apt-get source lxpanel
...

michael@eeebuntu:~/ubuntu-dev$ grep -r "tk->res_class_flink = NULL;" lxpanel-0.5.8+git20120212/
lxpanel-0.5.8+git20120212/src/plugins/taskbar.c: tk->res_class_flink = NULL;

so the patch is in the latest 12.04 panel but is not fixing the issue

i will do some testing with "my packages" because i am sure with "my package" i am not facing the issue. Maybe another patch from the latest lxpanel is doing something where the patch from henry is not working

Sergej Nikolaev (kinolaev) wrote :

Michael Basse, please, upload sources of your packages anywhere and write step-by-step build manual hier. Thank you and sorry for my english.

Sergej Nikolaev (kinolaev) wrote :

I was already built package with Henry's patch for oneiric amd64. The files can be found here:
https://nora.sytes.net/apps/files_sharing/get.php?token=98a50f9603346b7c0dc9e5b50ffda7d367ff7bb9

Don Mahurin (dmahurin) wrote :

The bug still occurs.
For me, it is easily reproducible. Set panel to autohide. Click on mute/unmute a few times.

Debugging, it seems that the mixer continuously receives G_IO_IN events,
but on processing, snd_mixer_handle_events returns -5 (EIO), so the event is never processed (fd is not read?)

Though I suspect some other corruption, as this not seems to reproduce with volume control with auto hide off.

Don Mahurin (dmahurin) wrote :

To correct myself, while the bug seemed to occur more with autohide, it now seems occurs without autohide at the same rate.

Henry Gebhardt (hsggebhardt) wrote :

On Wed, May 16, 2012 at 01:27:23PM -0000, Don Mahurin wrote:
> The bug still occurs.
> For me, it is easily reproducible. Set panel to autohide. Click on mute/unmute a few times.
>
> Debugging, it seems that the mixer continuously receives G_IO_IN events,
> but on processing, snd_mixer_handle_events returns -5 (EIO), so the event is never processed (fd is not read?)
>
> Though I suspect some other corruption, as this not seems to reproduce
> with volume control with auto hide off.

Does pulseaudio crash or restart when this bug occurs?

I have a patch that saves lxpanel (but the volumealsa plugin doesn't
work anymore when the bug occirs). Does that prevent the 100% cpu usage?

https://github.com/hsgg/lxpanel/commit/adfe25b2b7f06294fde566b3b0b7e67de7f7718b

Don Mahurin (dmahurin) wrote :

> I have a patch that saves lxpanel (but the volumealsa plugin doesn't work anymore when the bug occurs). Does that prevent the 100% cpu usage?

Looks like this does prevent the lxpanel/volumealsa 100% cpu death. Though, as you say, the plugin stops working when it happens.

Thanks.

Henry Gebhardt (hsggebhardt) wrote :

So, does pulseaudio crash/restart? You can check that by seeing if its
PID changes by doing "ps ax | grep pulseaudio" before and after.
(Assuming you are using pulseaudio).

Henry Gebhardt (hsggebhardt) wrote :

I actually made an additional patch that has the plugin recover. You can
find it here:

    https://github.com/hsgg/lxpanel/commit/db1dc50c54bb9d1de171529d4234d59ea1f9d7e9

I intend to make a pull-request with these patches upstream within a
week or so.

But this really is just pampering over the underlying problem, so please
do check if it is caused by a crashing pulseaudio or so.

Don Mahurin (dmahurin) wrote :

yes, pulseaudio crashes when the bug occurs.

I also verified that your patch successfully recovers from the condition.

Thanks Henry.

I can also confirm that pulseaudio is crashing. Noticed yesterday on Lubuntu 12.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.