empty space between time applet and nm-applet

Bug #846878 reported by Michael Krištof
358
This bug affects 73 people
Affects Status Importance Assigned to Milestone
LXDE
Unknown
Unknown
Xfce4 Power Manager
Unknown
Unknown
lxpanel (Fedora)
Fix Released
Medium
lxpanel (Ubuntu)
Invalid
Undecided
Unassigned
Oneiric
Invalid
Undecided
Unassigned
xfce4-power-manager (Ubuntu)
Fix Released
Undecided
Unassigned
Oneiric
Won't Fix
Undecided
Unassigned

Bug Description

There's quite big empty space on panel between time applet and nm-applet.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lxpanel 0.5.8-1ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Config_Home_Lubuntu:
 [Command]
 FileManager=pcmanfm %s
 Terminal=lxterminal -e
 Logout=lubuntu-logout
Date: Sun Sep 11 10:49:33 2011
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lxpanel
UpgradeStatus: Upgraded to oneiric on 2011-09-07 (3 days ago)

Related branches

Revision history for this message
Michael Krištof (gramblavec) wrote :
summary: - emty space between time applet and nm-applet
+ empty space between time applet and nm-applet
Revision history for this message
Erwin Junge (erwin-junge) wrote :

I also have this bug, see attached screenshot for visual example of the effect. It gets larger over time and can be removed by restarting lxpanel (lxpanelctl restart). After restart it does start appearing again over time though.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxpanel (Ubuntu):
status: New → Confirmed
Revision history for this message
Neosano (neosanor) wrote :

Does it increase after suspending your system?

Revision history for this message
Erwin Junge (erwin-junge) wrote :

I just did a couple of suspend-wakeup cycles and don't notice an immediate effect.

Revision history for this message
Erwin Junge (erwin-junge) wrote :

The previous set of suspend-wakeup cycles was while my laptop was on the charger (with full battery, so not actually charging). I just did some more cycles when working on battery and now it does increase after suspending. This is 100% reproducible.

Revision history for this message
amjjawad  (amjjawad) wrote :

Looks like these bugs effecting Laptops ONLY as of now.

https://bugs.launchpad.net/ubuntu/+source/lxpanel/+bug/880010

Revision history for this message
Croque (pcroque) wrote :

I've posted a work-around that fixes it on my laptop over on the other bug:

https://bugs.launchpad.net/ubuntu/+source/lxpanel/+bug/880010

Revision history for this message
Erwin Junge (erwin-junge) wrote :

Shouldn't the comments be merged somehow when bugs are marked as duplicates? I'm hoping this will also be sent to people over at #880010.

@bazonbloch: There is on my install. See the screenshot.

@pcroque: I can confirm this works. I don't agree on this being a workaround though (I need the battery icon to know when to put in the charger), but it's definitely located the source of the bug. It would also explain why this is laptop-only, since desktops generally don't have batteries to run off of.

Revision history for this message
Bazon (bazonbloch) wrote :

@Erwin Junge:
Thanks, now I found it. (I was blind because I was not looking for a dropdowm menu but a selectable list...)

Revision history for this message
Neosano (neosanor) wrote :

@pcroque Yes, it works! But now, when I turned it off, how can I get it back? I mean the power manager icon.

@erwin-junge there's a pannel applet called Battery Monitor. You can use it for now.

Revision history for this message
Julien Lavergne (gilir) wrote :

Confirmed, it happens when using notification-area applet or indicator-application applet to render the icon. Restarting xfce4-power-manager remove the empty spaces.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-power-manager (Ubuntu):
status: New → Confirmed
Revision history for this message
Jonathan Greenblatt (jon-50e) wrote :

I have noticed this on a desktop and nettop.

Revision history for this message
amjjawad  (amjjawad) wrote :

@Julien

It would be better if you mention how to restart "xfce4-power-manager" please.

Also, would you please confirm whether this is the solution for this issue or it is just a workaround?

Thanks :)

Revision history for this message
Julien Lavergne (gilir) wrote :

just "killall xfce4-power-manager", and start it again by Alt-F2, or on a terminal.

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

its also affecting 10.04, 10.10 and 11.04

i posted another workaround here

https://bugs.launchpad.net/ubuntu/+source/lubuntu-meta/+bug/890102/comments/3

tags: added: lucid maverick natty
Revision history for this message
JohnDoe_71Rus (johndoe99) wrote :

ubuntu 10.04 + lxde + lubuntu-desktop
use gnome-power-manager
scren in lxpanel thread

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

Here is a screenshot from lubuntu 11.10 with xfce4-power-manager

http://alpha-unix.de/~iceroot/lxde-indicator-spaces.png

here with 10.04 and gnome-power-manager

http://postimage.org/image/rkk1e3ew5/

Revision history for this message
muppet (muppet317) wrote :

Another screenshot (11.10)

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

i can confirm, that the bug is only happening when the power-manager-icon is used. when i disable the icon the menu does not have the spaces.

Sounds like an upstream-bug.

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

also happening on 12.04

tags: added: precise
Revision history for this message
prasad (gpvprasad-yahoo) wrote :

its not only power manager also the network connection information is also followed by gaps.

Revision history for this message
prasad (gpvprasad-yahoo) wrote :

looks like system tray is not getting resized automatically and having fixed width.

Revision history for this message
Tom Arnold (g0tt) wrote :

This mf is also present in Fedora 15. (LXDE + extra XFCE power manager and NM)

Revision history for this message
In , Thomas (thomas-redhat-bugs) wrote :

Description of problem:
Each time I resume my EeePC 901 the notification area in lxpanel becomes bigger by adding an invisible icon on each side.

Version-Release number of selected component (if applicable):

How reproducible:
Suspend/resume

Steps to Reproduce:
1. Run LXDE with parcellite, xfce power manager and network manager
2. Suspend
3. Resume

Actual results:
Wider notification area

Expected results:
The same notification area as before

Additional info:
https://bugs.launchpad.net/ubuntu/+source/lxpanel/+bug/846878

Revision history for this message
Tom Arnold (g0tt) wrote :
Revision history for this message
In , Christoph (christoph-redhat-bugs) wrote :

Thanks for reporting this bug. I cannot reproduce, therefor I need more input from you.

When you right-click on an empty spot in the notification area, do you see a menu or just nothing happens?

Can you try lxpanel from updates-testing?

Revision history for this message
Christoph Wickert (cwickert) wrote :

Can any of you who has this problem report it upstream to the LXDE developers and add a link to the upstream bug report here?

Revision history for this message
In , Thomas (thomas-redhat-bugs) wrote :

Thanks for responding.
I just see the void of space and nothing happens.
I will try to enable updates-testing and report back.
Greetings from Münster ;-)

Revision history for this message
In , Thomas (thomas-redhat-bugs) wrote :

Did the yum update lxpanel with update-testing enabled and the problem persists.

Revision history for this message
Tom Arnold (g0tt) wrote :

Always those needy Fedora devs ;-)
OK, done that:
https://sourceforge.net/tracker/?func=detail&aid=3458395&group_id=180858&atid=894869

Now what?

Revision history for this message
Steven Harper (stevenharperuk) wrote :

As mentioned further up:

Clean up the Panel
lxpanelctl restart

In xfce4-power-manager
Set "System Tray Icon" to the "Never Show Icon"

Then install the non default batter monitor

sudo apt-get install xfce4-battery-plugin

And add it to your panel

Revision history for this message
In , Freddy (freddy-redhat-bugs) wrote :

I think I have found a workaround for the time being. Put the script below in /etc/pm/sleep.d dir (for example in 01powermanager). Put your own username in the right spot, maybe change your display number if applicable.

#!/bin/bash

case $1 in
    thaw|resume)
        su - <Your username> -c "export DISPLAY=:0 && /usr/bin/xfce4-power-manager --restart"
        exit 0
        ;;
    *) exit $NA
        ;;
esac

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

i will do some testing on the latest lxpanel release

git://lxde.git.sourceforge.net/gitroot/lxde/lxpanel

the lxde-hackers told me to have a look at the latest git-version so see if the bug is still happening

i will put my results here later after i managed to build the lxpanel-package successfully

Revision history for this message
Arne (RDS) (plexus) wrote :

This is likely the same bug as reported here in Debian : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=626224

Not specific to LXDE then. I'm having this same problem with xfce4-power-manager using stalonetray as a system tray.

Revision history for this message
Arne (RDS) (plexus) wrote :

I opened an XFCE bug report for this

https://bugzilla.xfce.org/show_bug.cgi?id=8313

Revision history for this message
In , Thomas (thomas-redhat-bugs) wrote :

The workaround kinda sometimes works, but a real fix it certainly isn't. The notification area is still expanding. Anybody still working on this?

Revision history for this message
Exanime (exanime) wrote :

I can confirm the bug is NOT specific to LXDE as I have been able to reproduce it (with the same steps) in Enlightment

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

So the Bug is coming from "xfce4-power-manager"?

So Xubuntu should also be affected? Maybe someone can test/confirm this?

Revision history for this message
gpvprasad (gpvprasad) wrote :

AS far as I see it comes even for notifications. If notifications comes more than 3 times, I see the space b/w tray items. When I do lxpanelctl restart, everything is normal. looks like issue is with lxpanelctl is not getting reloaded.

Revision history for this message
Na_OH (naoh123) wrote :

This is happening on my system as well. Lubuntu 11.10 x64, and is consistent when waking up from suspends. Each wake/screen unlock gives me one blank unit. This is on a laptop, as well.

Revision history for this message
Doctor Colossus (z-launchpad-doctorcolossus-e4ward-com) wrote :

I'm experiencing this bug in Natty Narwhal using awesome window-manager.

Revision history for this message
Dmitry Tantsur (divius) wrote :

Hi everyone! Do we have a workaround now? Xfce4-battery-applet required Xfce panel, LXDE "Battery monitor" does not work at all (always 100%)

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :
Revision history for this message
Andreas Büsching (crunchy) wrote :

This bug is so annoying that I moved from lubuntu to xubuntu. :-(

I've used lubuntu on my netbook that I suspend once or twice a day so this happens quite often for me.

I've tried to fix the problem bei restarting xfce-power-manager but that just reduced the empty space in the panel but it did not disapear completely. I'm not sure what other applet causes this problem.

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

i have created a upstream-bugreport about that issue and added the bugwatcher to it

Revision history for this message
In , Michael (michael-redhat-bugs) wrote :
Revision history for this message
Ogilvierothchild (ogilvierothchild) wrote :
Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

I dont have much time at the moment so here is a short info

[11:16] iceroot | as it seems this "spaces between lxpanel when using xfce4-power-manager" is an lxpanel bug
[11:17] iceroot | after the latest dist-upgrade, if i move a window over my systray the systray does not get a redraw and i see e.g. my firefox on the nm-applet-icon

i will provide screenshots tomorrow

Revision history for this message
Walter Lapchynski (wxl) wrote :

same here with Lubuntu 11.10. never realized it until today because i've been running without a battery ;) occurs with both suspends AND hibernates.

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

Axel was posting a patch on our mailinglist, i will add the patch here.

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :
tags: added: patch
Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

Hi,
because i am not very familiar with git i have downloaed the source-package from 12.04 with apt-get source xfce4-power-manager

i applied the patch and rebuild the package with "dpkg-buildpackage -rfakeroot"

You can find the result here

http://alpha-unix.de/~iceroot/ubuntu/xfce4-power-manager/

Because i dont have an amd64 system/cpu i can only provide the i386 build but i guess that is ok so some of us can test the patch.

Feedback is welcome

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

i can confirm that "my" packages are fixing the issue, plugging on/off the ac-adapter is NOT producing empty spaces. So the patch is working

Revision history for this message
In , Christoph (christoph-redhat-bugs) wrote :

Argh, I had the necessary patch already in the F16 package for quite a while but I did not update F15. This explains why only a F15 user complains.

Thanks for Michael to the pointer in the LP bug report!

Revision history for this message
In , Michael (michael-redhat-bugs) wrote :
Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

xfce4-power-manager-1.0.10-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xfce4-power-manager-1.0.10-3.fc15

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

Please remember that all lubuntu-versions are affected not only 11.10 and 12.04

Changed in lxpanel (Ubuntu):
status: Confirmed → Invalid
Changed in xfce4-power-manager (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

Package xfce4-power-manager-1.0.10-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-power-manager-1.0.10-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2475/xfce4-power-manager-1.0.10-3.fc15
then log in and leave karma (feedback).

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

Unluckily Henry Gebhardt was discovering a use-case where the empty spaces still appear.

If you remove/add the battery the empty spaces are there again.

I can reproduce it with the latest patched version of xfce4-power-manager on lubuntu 12.04

Revision history for this message
In , Michael (michael-redhat-bugs) wrote :

Unluckily Henry Gebhardt was discovering a use-case where the empty spaces still appear.

If you remove/add the battery the empty spaces are there again.

I can reproduce it with the latest patched version of xfce4-power-manager on lubuntu 12.04

Because i dont have Fedora, can someone of you test this use-case?

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "fix-empty-icons.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Revision history for this message
In , Christoph (christoph-redhat-bugs) wrote :

As far as I can tell this is fixed in the Fedora package, but compared to stock 1.0.10 it contains a number of patches from git. For a complete list see
http://pkgs.fedoraproject.org/gitweb/?p=xfce4-power-manager.git;a=tree;hb=7d8b84e5

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

xfce4-power-manager-1.0.10-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xfce4-power-manager-1.0.10-2.fc15

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

Package xfce4-power-manager-1.0.10-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-power-manager-1.0.10-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2987/xfce4-power-manager-1.0.10-2.fc15
then log in and leave karma (feedback).

Revision history for this message
In , Thomas (thomas-redhat-bugs) wrote :

Btw I have the same problem in F16.

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

xfce4-power-manager-1.0.10-2.fc15 has been pushed to the Fedora 15 stable repository. If problems still persist, please make note of it in this bug report.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-power-manager - 1.0.10-5ubuntu2

---------------
xfce4-power-manager (1.0.10-5ubuntu2) precise; urgency=low

  * debian/patches:
   - 07_fix_broken_empty_icon_battery.patch: From upstream, fix empty icons in
     the systray (LP: #846878)
   - 08_show_preferences_lxde.patch: Hide settings menu only on desktop
     environment which have another power manager.
   - 09_fix_insert_battery.patch: Another patch to fix empty icon when
     removing a battery. Thanks Henry Gebhardt for the patch.
   - 10_dim_brightness.patch: From upstream, only dim brightness if the current
     level is brighter. (LP: #900592)
 -- Julien Lavergne <email address hidden> Sun, 18 Mar 2012 17:38:44 +0100

Changed in xfce4-power-manager (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
JuanMa (chavesjuanmanuel) wrote :

When will this bug fix in Lubuntu 11.10??

Thanks.

Regards.

Revision history for this message
Jendrik Seipp (jendrikseipp) wrote :

On Precise I installed xfce4-power-manager - 1.0.10-5ubuntu2 and restarted, but the empty space is still there. When I remove the indicator-application applet the space is gone, but when I add it back the space returns (after a hibernate).

Revision history for this message
In , Frederik (frederik-redhat-bugs) wrote :

I am experiencing the same problem in Fedora 16. Is there a fix available there as well? I cannot see an update available in the repositories.

Revision history for this message
Aaron Hampshire (aaron-hampshire) wrote :

I've been frustrated by this bug for awhile now on two different computers. This may help those who are bug-fixing, but it's really intended for those who just want their system to work:

Use the ELEMENTARY ICON THEME. I'm not sure which themes are affected by this, but the popular Faenza theme gave me this bug.

As always, if you change an icon theme, you need to restart your panel (lxpanelctl restart) or the problem will appear to persist.

I'd love to see how many of the above were due to Faenza or some other icon theme...

Micah Gersten (micahg)
Changed in lxpanel (Ubuntu Oneiric):
status: New → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-power-manager (Ubuntu Oneiric):
status: New → Confirmed
Revision history for this message
Jendrik Seipp (jendrikseipp) wrote :

Are you sure this is solely caused by xfce4-power-manager? I experience the
problem without xfce4-power-manager. It seems the problem is the
application-indicator applet here. Without it, the spaces are gone.

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

i can not confirm that it is related to something else, before this bug was fixed i removed the xfce4-power-manager for a long time and never was facing the issue.

are you facing the issue with 12.04 where the bug is marked as fixed? or is it related to 11.10?

Revision history for this message
Jendrik Seipp (jendrikseipp) wrote : Re: [Bug 846878] Re: empty space between time applet and nm-applet

> are you facing the issue with 12.04 where the bug is marked as fixed? or
> is it related to 11.10?
I'm on 12.04.

As others have pointed out, the issue could be related to themeing: When
I kill the panel and restart it with "lxpanel" (without the lubuntu
profile), the spaces do not show up.

Revision history for this message
Aviv (ademorga) wrote :

I do not know, as I only use 11.10.

On Sat, Apr 7, 2012 at 7:23 PM, Jendrik Seipp <email address hidden> wrote:

> > are you facing the issue with 12.04 where the bug is marked as fixed? or
> > is it related to 11.10?
> I'm on 12.04.
>
> As others have pointed out, the issue could be related to themeing: When
> I kill the panel and restart it with "lxpanel" (without the lubuntu
> profile), the spaces do not show up.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (908402).
> https://bugs.launchpad.net/bugs/846878
>
> Title:
> empty space between time applet and nm-applet
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/lxde/+bug/846878/+subscriptions
>

--
*------------------------------------------
אני נאבק בהגבלת חופש הדיבור והמידע: נא להמנע מלשלוח לי קבצי Word בפורמט
הסודי הנקרא 'doc' או 'docx' (לחצו כאן כדי לדעת
מדוע<https://www.gnu.org/philosophy/no-word-attachments.he.html>).
**שמרו את הקובץ שלכם כ-txt ,HTML, או PDF ואז שלחו לי. **מסיבה זו גם אינני
משתמש בתכנה שאיננה תכנה חפשית (מה זה?<http://www.gnu.org.il/free-software.php>)
ובכלל זה MS Office או MS Windows.

<https://www.fsf.org/>
*

Revision history for this message
Aviv (ademorga) wrote :

I do not relate this bug definitely to problems with xfce4-power-manager.
It could be a bug in the application-indicator applet. I haven't looked
deeply into this.

On Sat, Apr 7, 2012 at 1:50 PM, Jendrik Seipp <email address hidden> wrote:

> Are you sure this is solely caused by xfce4-power-manager? I experience the
> problem without xfce4-power-manager. It seems the problem is the
> application-indicator applet here. Without it, the spaces are gone.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (908402).
> https://bugs.launchpad.net/bugs/846878
>
> Title:
> empty space between time applet and nm-applet
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/lxde/+bug/846878/+subscriptions
>

--
*------------------------------------------
אני נאבק בהגבלת חופש הדיבור והמידע: נא להמנע מלשלוח לי קבצי Word בפורמט
הסודי הנקרא 'doc' או 'docx' (לחצו כאן כדי לדעת
מדוע<https://www.gnu.org/philosophy/no-word-attachments.he.html>).
**שמרו את הקובץ שלכם כ-txt ,HTML, או PDF ואז שלחו לי. **מסיבה זו גם אינני
משתמש בתכנה שאיננה תכנה חפשית (מה זה?<http://www.gnu.org.il/free-software.php>)
ובכלל זה MS Office או MS Windows.

<https://www.fsf.org/>
*

Revision history for this message
Cyril (thomas-cyril) wrote :

the system tray applet is causing the trouble ... I'm facing just by running the gnome media player. when the player icon is placed in the system tray and creates ugly spacing once the player is closed, same for vlc too! it's not application specific it just the applet is buggy.

Revision history for this message
Cyril (thomas-cyril) wrote :

and i am using 12.04 lubuntu fresh install

Revision history for this message
3t0g0 (freetogo) wrote :

I have created two files so that the lxpanel reset script will run
25s after logon.

eli@eli-powerpc:~$ cat .config/autostart/lxpanel-reset.desktop
[Desktop Entry]
Categories=Utility;GTK;
Comment=Kill lxpanel and restart with LXDE profile
Exec=/home/eli/.bin/cleanpanel2 &
Icon=reload
Name=LXPanel Restart
NoDisplay=false
StartupNotify=false
Terminal=false
Type=Application
eli@eli-powerpc:~$ cat /home/eli/.bin/cleanpanel2
#!/bin/bash
sleep 25
killall lxpanel
find ~/.cache/menus -name '*' -type f -print0 | xargs -0 rm
lxpanel -p Lubuntu &

Revision history for this message
amjjawad  (amjjawad) wrote :

I thought this one is fixed and we are done from it but apparently, it is NOT yet fixed.

Recently, I came to know that when you have Ubuntu 12.04 (whether it is upgraded, for example from 10.04 OR NOT upgraded from a previous release) AND then you install 'lubuntu-desktop' Package on the top of Ubuntu 12.04, you will have this when you login to Lubuntu: http://i46.tinypic.com/34yr8s1.jpg

I have produced myself. I had Ubuntu 12.04 already installed and I just updated it and installed lubuntu-desktop.
It happened with my friend who upgraded from Ubuntu 10.04 to Ubuntu 12.04 and installed lubuntu-desktop.
It also happened with other guys who confirmed that on Mailing List and Lubuntu facebook group.

So, it's very easy IMHO to re-produce that.

Now, what is/are the possible solution(s)? we need to find out. I thought to post here first explaining what is going on then go through these posts to figure out whether there is actually a solution or there is not.

Will keep you updated for sure.

Thanks!

Revision history for this message
sudodus (nio-wiklund) wrote :

I can confirm that it affects me too

nio alias sudodus

Revision history for this message
sudodus (nio-wiklund) wrote :

Thanks!

3t0g0 (freetogo) wrote on 2012-07-05: #64

This tip helps me fix the problem :-)

nio alias sudodus

Revision history for this message
Henry Gebhardt (hsggebhardt) wrote :

On Mon, Sep 10, 2012 at 10:08:39PM -0000, amjjawad wrote:
> I thought this one is fixed and we are done from it but apparently, it
> is NOT yet fixed.

Yes, I agree. There were multiple issues going on, some of which have
been fixed. Here is my take on the matter: Some package in
ubuntu-desktop has similar behavior to what xfce4-power-manager used to
have, that is, it doesn't explicitly hide its icon. It is different,
however, as killing xfce4-power-manager was enough to fix it, whereas I
am pretty sure that killing just that mysterious process from
ubuntu-desktop deps is not sufficient: It might have already exited by
the time the signal to add an icon reaches lxpanel.

I have no idea how to find which process that is, and thus gain an
understanding of what is going on. Commit 1604938f0 in lxpanel does not
prove useful for this. (Although this bug is the reason it was added,
and 82ca42af43b6, too.)

Unfortunately, I don't have time to work on this right now.

Good luck,
Henry

Revision history for this message
autostatic (autostatic) wrote :

#69 fixed the issue for me too. Thanks Igor for the workaround!

Revision history for this message
amjjawad  (amjjawad) wrote :

I haven't noticed this bug with the latest releases like 13.04 and 13.10

Revision history for this message
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in xfce4-power-manager (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Changed in lxpanel (Fedora):
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.