Alt-F2 (or "lxpanelctl run") doesn't work

Bug #769644 reported by Tomasz Rzepecki on 2011-04-23
224
This bug affects 48 people
Affects Status Importance Assigned to Milestone
LXDE
Unknown
Unknown
lubuntu-default-settings (Ubuntu)
Undecided
Unassigned
lxpanel (Ubuntu)
Undecided
Unassigned
lxsession (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: lxpanel

recently, after (but not immediately after) updating my laptop to 11.04, i noticed that the alt-f2 shortcut doesn't work.
i checked to see if i had turned it off somehow, however, typing "lxpanelctl run" into terminal does absolutely nothing - no output to the console, no reaction.
gdb says that the program exits normally.
all packages are at the latest for ubuntu 11.04 as of 23 april 2011.

Tomasz Rzepecki (nub) wrote :

i noticed that killing lxpanel and starting a vanilla session "solves" the problem, so it probably lies in configuration. it's probably still worth checking if it's something i've done, or a problem within some default config file.

Mikael Ståldal (mikaelstaldal) wrote :

I have the same problem. Actually, none of the other commands to lxpanelctl works either, lxpanelctl apparently does absolutely nothing.

Tomasz Rzepecki (nub) wrote :

as for me, the problem persists (i'm currently working around it by simply opening a roxterm tab, but it's obviously not very comfortable, since it sort of clutters up my taskbar).

Jonathan Marsden (jmarsden) wrote :

I am unable to duplicate this.

lxpanelctl run works as expected for me in Lubuntu 11.04 Natty, and also in Lubuntu 11.10 Oneiric Alpha1.

Could this issue possibly be locale-dependent?

Changed in lxpanel (Ubuntu):
status: New → Confirmed
Igor Tarasov (tarasov-igor) wrote :

I've also encountered this problem. I've tried all advices from this page, and nothing helped. As if this problem is locale-specific, I've tried this:

$ LC_ALL=C lxpanel &

** (lxpanel:7100): WARNING **: Group count mismatch, ctrls = 2, groups = 2, symbols = 4

$ LC_ALL=C lxpanelctl run
$ lxpanelctl restart
$ lxpanelctl config
$ lxpanelctl menu

Nothing happens.

However, Run menu item works.

Alan Jenkins (aj504) wrote :

For me, the first "lxpanelctl run" works fine, but then it stops working.

As suggested, re-starting lxpanel makes it work (once) again.

"lxpanel restart" doesn't make it work though.

lxpanel --log 5 ("chatty") doesn't provide any output at all.

Antonio Tozzi (fccdmrd) wrote :

I have a this problem on one of my laptops, running a regular ubuntu 11.10, within a lubuntu session started by lightdm

lxpanelctl run works as expected in another laptop which runs lubuntu 11.10

both systems were upgraded from natty

Alan Jenkins (aj504) wrote :

Weird! For me, it seemed to be fixed in 11.10.

Mikael Ståldal (mikaelstaldal) wrote :

I upgraded to 11.10, and it still doesn't work.

Tomasz Rzepecki (nub) wrote :

I installed lubuntu 11.10 (fresh install), copied all lxde config files and it seems to work just fine.

Ralf G (ralfg1) wrote :

First, the bug does not only affect "lxpanelctl run" but to any lxpanelctl command. Couldn't the
thread be renamed?

I have this problem running a regular ubuntu 11.10, with lubuntu-desktop.
It seems, the bug appears only in this combination and not in clear lubuntu-installations.

According to source code, lxpanelctl sends via XSendEvent() an event to DefaultRootWindow(). As lxpanelctl exits with exit code 0, I suppose the event was sent correctly. However, it seems, this event never reaches the xpanel. Anyone here who knows how to debug X11 events? Somewhere I read, that some window managers/desktop managers replace the X11 root window in some weird ways. Maybe this is the case here?

Ralf G (ralfg1) on 2012-01-15
summary: - lxpanelctl run doesn't work
+ Alt-F2 (or "lxpanelctl run") doesn't work
Jonathan Marsden (jmarsden) wrote :

> Anyone here who knows how to debug X11 events?

One useful tool for debugging X events is xev. You can tell it to display all events seen by a window by doing

  xwininfo

to get the Window ID, and then

  xev -id WINDOWID

will get you information about every window event that window sees. I am less sure about using xev on a root window, but... you can try it :) So, something like:

  xev -id $(xwininfo -root |grep id: |cut -d " " -f4)

should get you what you need.

Ralf G (ralfg1) wrote :

Thanks, jmarsden. OK, I did the following:

    $ xwininfo -root
    xwininfo: Window id: 0xbb (the root window) (has no name)
    [...]

    $ xev -id 0xbb
    [...]
    [ Type "lxpanelctl run" in another terminal ]

    ClientMessage event, serial 16, synthetic YES, window 0xbb,
        message_type 0x1dd (_LXPANEL_CMD), format 8

    [...]

This means, the X event "_LXPANEL_CMD" is indeed sent by lxpanelctl and received by the root window.
However,

    $ xwininfo
     xwininfo: Please select the window about which you
              would like information by clicking the
              mouse in that window.
    [ Mouse Click on the lxpanel ]
      xwininfo: Window id: 0x120001f "panel"
    [...]

    $ xev -id 0x120001f
    [ Type "lxpanelctl run" in another terminal ]
    [ No further output ]

This means, the X event never reaches the lxpanel.

I suppose, there is a configuration file somewhere defining which events are hand on to which windows. Can anyone give a hint?

(Or am I totally on the wrong path? I do not have any experience with debugging X / window managers etc. Maybe I should inspect something else... Any suggestions?)

Jonathan Marsden (jmarsden) wrote :

Comparing behaviour in Lubuntu with behaviour in Ubuntu that has had LXDE added to it later is probably worth doing. I *think* this issue only happens in the Ubuntu-with-LXDE situation, not if you install Lubuntu.

(Total guess: could lxpanelctl be assuming that the root window it sends messages to is created by some part of LXDE which knows about lxpanel? And perhaps in the "Ubuntu-upgraded" situation, that root window actually belongs to/is created by some other app which has no knowledge of lxpanel, so it does not know what to do with the message, and so discards it?).

Ralf G (ralfg1) wrote :

OK, I found the origin of the problem:

In the lxpanel config file

   ~/.config/lxpanel/panels/panel,

there is a plugin "volumealsa" which causes the misbehaviour. I just commented out the three lines

# Plugin {
# type = volumealsa
# }

and after restarting the lxpanel (logout/login), Alt-F2 works. However, the execution window appears unfocused, but this is dealt in bug #889414 (with workaround).

This is a workaround I can live with, but still:
By commenting out volumealsa, I do not have a volume indicator any more. Anyone knows, why the plugin volumealsa makes problems? Is it just, that I would need to install some additional package?

Jonathan Marsden (jmarsden) wrote :

> Anyone knows, why the plugin volumealsa makes problems?

Probably because Ubuntu does not use ALSA, it uses Pulseaudio ? Lubuntu uses ALSA, so under Lubuntu that volumealsa plugin makes sense. Probably fine under Debian, too.

Francisco Villar (villarf) wrote :

I did what Ralf G suggested and the good news is that it worked. The bad news is that it worked only once :-(
Still no Alt-F2 for me.

Gabriel Salles (gabrielpereca) wrote :

I removed the volumealsa plugin from the panel and worked after rebooting. But then I rebooted again and did not worked.

Actually, just after I log in at the Lubuntu session, I can open the menu with Super Key and open the "lxpanelctl run", but just at the first second. After this, I can not do it anymore.

A have a Lubuntu 11.10 instalation, and not a Ubuntu+LXDE

Erik Piper (erikpiper) wrote :

I use Ubuntu with LXDE. (I am a neophyte who dual-boot installed Ubuntu on his netbook to try out Linux, quickly discovered that Unity was unusably slow, and found LXDE installation instructions for Lubuntu on the 'Net.)

I ran into this bug. I commented out the three lines suggested by Ralf G. I logged out and in. Windows and Ctrl-Esc for the panel started working. I rebooted. They continued working.

Hope this data point helps anyone trying to form conclusions...

Erik Piper (erikpiper) wrote :

s/for Lubuntu/for Ubuntu :-)

Erik Piper (erikpiper) wrote :

Now it's not working again, unfortunately. Occasionally I am seeing it work just after boot (or login?), but not after that.

I have the same problem. I am on Ubuntu 11.10, and the lxpanel version is 0.5.8-1ubuntu3. lxpanelctl seems to do nothing at all (not just for run, but for config, menu, etc too).

Ralf G (ralfg1) wrote :

My suggested solution does not fully work for me either... I experience same phenomen like all others: After logging in (or after killing lxpanel and re-starting "lxpanel -p Lubuntu" from terminal), I can call "lxpanelctl run" exactly once. Any further call finishes without response.

The bug appears with default profile, too. I.e. it doesn't matter if I call "lxpanel" or if I call "lxpanel -p Lubuntu".

Tomasz Rzepecki (nub) wrote :

for me it still works fine (as mentioned, i just reinstalled lubuntu&copied my old lxde profiles), EXCEPT for some reason it always appears in the background, so i have to alt-tab it. are you sure that's not your issue?

Ralf G (ralfg1) wrote :

Another hint: While playing around with the source code, I commented out a function call to "setup_auto_complete_with_data()" (in gtk-run.c, line 187). With the modified version, Alt-F2 works twice and more often (without autocompletion, however).

It seems, within "setup_auto_coomplete_with_data()", the GTK library function "gtk_entry_completion_new()" causes the problems. Once again I would like to hand over this hint to someone who knows something about LXDE and/or GTK.

What does the function "gtk_entry_completion_new()" do? Does it read some configuration files or environment variables? Indeed, I do not think that there is a bug in the code. I think, there is just some wrong configuration. But where?

Ralf G (ralfg1) wrote :

@Tomas:
> for me it still works fine (as mentioned, i just reinstalled lubuntu&copied my old lxde profiles),

Yes, you installed Lubuntu. We experience the problem in Ubuntu +LXDE combination. For some reason, I do not want to do a complete reinstall.

> EXCEPT for some reason it always appears in the background, so i have to alt-tab it.

Did you check bug #889414?

PieroCampa (piero-campa) wrote :

Same problem here.
Running Ubuntu Oneiric, with LXDE.

Tried workaround in #15. but worked only for the first Alt+F2.

Any news?

chop (logan1011001) wrote :

I had the same problem. In my case it was because the *menu applet*. It works again after I add it back to the panel. If I don't have the applet on the panel, a segmentation fault error is given.

This cannot be te error's source here as I have the menu applet on the
panel.

Antti Kaihola (akaihola) wrote :

Same problem on Ubuntu 12.04 with lubuntu-desktop:

$ lxpanelctl run
$

...and nothing appears on the screen.

Benjamin Eltzner (b-eltzner) wrote :

Same as described in #17. None of the lxpanelctl commands work for me; neither from the terminal, nor from keybindings.

I'm running Ubuntu 12.04 and installed the lubuntu-desktop metapackage to test the DE. My version of the lxpanel package is the newest one from the standard repository, i.e. 0.5.8+git20120212-0ubuntu3. I have not touched the default WM openbox, the package version of which is 3.5.0-2ubuntu2.

Maybe the following output is helpful in any way:

~$ xwininfo -tree -root
xwininfo: Window id: 0x15d (the root window) (has no name)
  Root window id: 0x15d (the root window) (has no name)
  Parent window id: 0x0 (none)
     [...]
    -0x1200003 "lxpanel": () 10x10+-100+-100 +-100+-100
    -0x1200001 "lxpanel": ("lxpanel" "Lxpanel") 10x10+10+10 +10+10
        [...]
      --0x1200002 (has no name): () 1x1+-1+-1 +9+9
     [...]
    -0xe00100 (has no name): () 1920x24+0+0 +0+0
        [...]
       --0x120001d "panel": ("panel" "lxpanel") WIDTHx24+0+0 +0+0

Where WIDTH is simply my monitors width. (The - signs were added by me to make inheritance/level in the tree visible more easily.)
It seems quite peculiar to me that the window "panel" seems to have an alias(?) of some sort named "lxpanel", while two(!?) other windows named "lxpanel" exist. Even more peculiar to me is that semingly the window "panel" is the lxpanel, as it has the appropriate size. Also all these Windows are unrelated except for the common descendence from the root window. From a complete laymans perspective I figure this might be vaguely related to the problem. I apologize if I am completely off the mark.

Benjamin Eltzner (b-eltzner) wrote :

I forgot: AMD64 here. Do the others who observe the bug also run AMD64 versions of (l)ubuntu?

Francisco Villar (villarf) wrote :

Hi Benjamin, unfortunately it is not related to AMD64 - I have an Intel Core 2 Duo Machine.

Benjamin Eltzner (b-eltzner) wrote :

@ Francisco Villar (#33):
AMD64 is a CPU architecture also generically used by Intel (and https://en.wikipedia.org/wiki/Intel_Core_2 are AMD64 CPUs). Generically, all 64bit-desktop-CPUs are very likely to be AMD64.

The more interesting fact here is however the (l)ubuntu version used: What I meant is, I have the 64bit version of ubuntu installed. Is anybody here having this problem with the 32bit (or, for that matter, ARM) version of (l)ubuntu?

Francisco Villar (villarf) wrote :

@Benjamin: thanks for the clarification. To your question - I am affected by this bug and I am using the 32bit version of lubuntu.

ffuentes (txi-francisco) wrote :

I have the same problem with Ubuntu 12.04. I can run alt+f2 just once.

Benjamin Eltzner (b-eltzner) wrote :

I installed Lubuntu 12.04 (without restricted extras) in a virtualbox-vm to do some additional testing and found that no problems with lxpanelctl occur both before and after upgrading packages. So it seems the problem is related to some software not included in the base lubuntu install or to specific hardware setups.

Some wild guesses: Is anybody having this problem while not having any proprietary drivers installed? If not: Is there somebody with this problem with no proprietary graphics drivers installed? And even more specific: Is somebody having this problem without the proprietary nvidia driver installed? (Shame on me...) Does anybody observe this problem with a clean install including restricted extras (before and/or after upgrading packages)?

Francisco Villar (villarf) wrote :

@Benjamin: I am having this problem and do not have any propietary drivers installed. My graphis chipset is from Intel.

Sam Jansen (sam-jansen) wrote :

Same problem encountered on Ubuntu 12.04 and 12.10 on computers running LXDE but otherwise with very different configurations.

I found a possible patch on the LXDE Sourceforge butracker: http://sourceforge.net/tracker/index.php?func=detail&aid=3427598&group_id=180858&atid=894869

Using this, and updating it for current lxpanel git head, I've now got a working lxpanel.

The attachment "Patch to apply to lxpanel git sources to fix bug" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Francisco Villar (villarf) wrote :

This is now fixed for me under Lubuntu 12.10 with lxpanel 0.5.10+git20120823-0ubuntu1

sebek (sebeeek) wrote :

Ubuntu 12.04.1 is still using lxpanel 0.5.8+git20120212-0ubuntu3 so unfortunately the bug is present in current LTS

David Caspar (daspan) wrote :

Just to confirm #39: I'm also using (L)Ubuntu 12.10 (I installed Lubuntu 12.10 from cd, then I installed the package 'ubuntu-desktop' afterwards), and this bug is still present. Running 'lxpanelctl run' in a terminal just exists, without any error messages. Thus, 'Alt+F2' currently doesn't work ...

sebek (sebeeek) wrote :

David,
Can you specify which lxpanel version you are running ?

Péter Trombitás (trombipeti) wrote :

Here on Ubuntu 12.04 with lxpanel 0.5.8, the problem still exists. However, after I log in, the first lxpanelctl command works (e.g alt+f2 opens the run command window). However, after that, nothing works.
I worked around the problem by using gmrun, though it's not the best solution, because none of the lxpanelctl commands work.

Anton (anton7811) wrote :

I confirmed that on Ubuntu 12.04 lxpanel 0.5.8+git20120212-0ubuntu3 and disabled volume control item run command window apears only ones. If volume control panel item is enabled, run command window doesn't appear by alt-f2 and "lxpanelctl run" doesn't work too. Also enabled volume control item leads on graphic artefacts on lx panel.

Still doesn't work on Lubuntu 13.10 Saucy (all packages up to date, 2013-06-11)
Is it really that hard to fix this? This problem exists since more than TWO YEARS :-o

Vedran Rodic (vrodic) wrote :

This has been fixed very recently in current lxpanel git: http://lxde.git.sourceforge.net/git/gitweb.cgi?p=lxde/lxpanel;a=commit;h=0f83fb71915fd7c87a999ebe83e41b2d033e4340

Hopefully we'll have this soon in ubuntu.

@Vedran Rodic
Could you give me an example or tutorial? I dont know about this http://lxde.git.sourceforge.net/git/gitweb.cgi?p=lxde/lxpanel;a=commit;h=0f83fb71915fd7c87a999ebe83e41b2d033e4340, Im a newbie :). Thanks

autostatic (autostatic) wrote :

In my case removing liboverlay-scrollbar-0.2-0 solved this issue.

Bruce Crowther (bwucie) wrote :

Just installed lubuntu 14.04, and this problem is present. Kind of annoying when I prefer the keyboard over the mouse.

Bruce Crowther (bwucie) wrote :

After much searching, I checked the key-binding section of ~/.config/openbox/lubuntu-rc.xml, and found the command to execute for Alt + F2 was: lxsession-default launcher_manager

I changed that to: lxpanelctl run and now everything is hunky-dory.

Bit staggering to have to get under the hood so early in the piece to spanner a new install, though.

Daniel Kulesz (kuleszdl) wrote :

I am affected too on Lubuntu 14.04 and I can confirm that the temporary fix proposed by Bruce is working for me as well.

If you delete .config/openbox or .config/lxpanel, the problem still is persistent because the skeleton version of lubuntu-rc.xml that is copied over (from etc) seems to be outdated / not supporting the current LXDE version.

Mikaela Suomalainen (mikaela) wrote :

I hadn't noticed this issue ever before, but I just installed two clean Ubuntu 14.04s and on the first computer I wondered why nothing happened and on the second it didn't work either, so I googled it and found this.

Dan Del (deno327) wrote :

Just installed lubuntu 14.04.1 64bit same problem still here ;(

tried Bruce's solution worked like a charm
e.g.

<command>lxsession-default launcher_manager</command>
to
<command>lxpanelctl run</command>

in

~/.config/openbox/lubuntu-rc.xml

pretty significant bug to me, alt-f2 very standard used constantly

thanks Bruce

LStranger (andrej-rep) wrote :

The original issue affects only 12.04 and 14.04 is another issue coming from lxsession package where the lxsession-default executable is, and from lubuntu-default-settings package where that xml file comes from.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.