lxpanel crashed with SIGSEGV in snd_mixer_selem_get_playback_switch()

Bug #690932 reported by Eliah Kagan on 2010-12-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LXDE
Unknown
Unknown
lxpanel (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: lxpanel

This crash occurred with lxpanel package version 0.5.6-0ubuntu2 on a Maverick amd64 system.

Every once in a while, clicking the Volume Control icon in my LXPanel fails to bring up the volume slider. I had not gotten around to reporting this as a bug. I have not figured out what triggers it, though it happens more often when I am running VMware Workstation than when I am not. I have found two ways that are sometimes, but not always, successful at working around the problem. One is to double-click the Volume Control icon in the LXPanel, which usually creates an entry in the Task Bar (Window List) called [lxpanel] -- clicking on that usually brings up the volume slider, and dismissing it (by clicking it again) often causes the Volume Control icon to become responsive to single-clicks again. The second sometimes-effective workaround is to add a new Volume Control to the list of Panel Applets, and remove the old one.

(A third workaround that appears to always be successful is to log out and back in. However, since that requires that I interrupt what I am working on and close all currently running programs using X11, that is an undesirable workaround for me in most situations.)

This bug report is for a crash that I believe is related to that bug. When this crash occurred, I had experienced the problem with the Volume Control becoming unresponsive to single-clicks (VMware Workstation was not running this time), so I tried the first workaround. It was unsuccessful, so I tried the second workaround. The second workaround appeared to have succeeded, but when I tried to change the volume with the new volume control, LXPanel crashed. I have never experienced a crash that seemed related to the Volume Control bug before, and I believe this is the first time LXPanel has ever crashed on my system.

(When LXPanel automatically restarted, the Volume Control applet worked correctly again.)

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: lxpanel 0.5.6-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
Uname: Linux 2.6.35-24-generic x86_64
Architecture: amd64
Config_Home_Lubuntu:
 [Command]
 FileManager=pcmanfm %s
 Terminal=lxterminal -e
 Logout=lubuntu-logout
Date: Wed Dec 15 23:06:08 2010
ExecutablePath: /usr/bin/lxpanel
InstallationMedia: Xubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406)
ProcCmdline: lxpanel --profile Lubuntu
ProcEnviron:
 LANGUAGE=en_US.utf8
 LANG=en_US.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f2bd6d735e9 <snd_mixer_selem_get_playback_switch+9>: mov (%rdi),%r10d
 PC (0x7f2bd6d735e9) ok
 source "(%rdi)" (0x200000483) not located in a known VMA region (needed readable region)!
 destination "%r10d" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: lxpanel
StacktraceTop:
 snd_mixer_selem_get_playback_switch () from /usr/lib/libasound.so.2
 ?? () from /usr/lib/lxpanel/plugins/volumealsa.so
 ?? () from /usr/lib/lxpanel/plugins/volumealsa.so
 g_main_dispatch (context=0xb59aa0) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2149
 g_main_context_dispatch (context=0xb59aa0) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2702
Title: lxpanel crashed with SIGSEGV in snd_mixer_selem_get_playback_switch()
UserGroups: adm admin cdrom lpadmin plugdev sambashare

visibility: private → public

StacktraceTop:
 snd_mixer_selem_get_playback_switch (
 volumealsa_update_display (vol=0xc4ebf0)
 asound_mixer_event (channel=<value optimized out>,
 g_main_context_dispatch (context=0xb59aa0)
 g_main_context_iterate (context=0xb59aa0,

Changed in lxpanel (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Julien Lavergne (gilir) wrote :

Thank you for the bug report. Since the stacktrace is complete, I'm fowarded it upstream.

Changed in lxpanel (Ubuntu):
status: New → Triaged

Should I file another bug report for the bug that I think this crash relates to (where left-clicking the Volume Control lxpanel applet fails to bring up the volume slider)? That problem occurs relatively often, whereas this crash occurred only once.

Julien Lavergne (gilir) wrote :

Yes please. It seems to be 2 different issues, so it should be 2 different bug reports. We can merge them eventually if we discover it's the same bug.

I have filed a separate bug report (Bug 692546) for the issue where clicking the Volume Control icon doesn't raise the volume slider. That report is clearer and more detailed than this report with respect to that issue. It also contains new information about the issue that I discovered since making this report; since this crash may be related to Bug 692546, perhaps that bug should also be linked to on the upstream tracker (sf #3140306).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.