Deepin terminal is installed in base install unintentionally

Bug #1766478 reported by Lyn Perrine on 2018-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Undecided
Unassigned
lxpanel (Ubuntu)
Undecided
Unassigned

Bug Description

To reproduce on an alternate install of lubuntu 18.04 open the menu and see that under system tools deepin terminal is at the the top.

lubuntu-desktop:
  Installed: 0.94
  Candidate: 0.94
  Version table:
 *** 0.94 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status

Description: Ubuntu Bionic Beaver (development branch)
Release: 18.04

I did not expect deepin terminal to be installed by default as it is not expected to be there.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: lubuntu-desktop 0.94
ProcVersionSignature: Ubuntu 4.15.0-19.20-generic 4.15.17
Uname: Linux 4.15.0-19-generic x86_64
ApportVersion: 2.20.9-0ubuntu6
Architecture: amd64
CurrentDesktop: LXDE
Date: Mon Apr 23 22:21:05 2018
InstallationDate: Installed on 2018-04-24 (0 days ago)
InstallationMedia: Lubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180424)
SourcePackage: lubuntu-meta
UpgradeStatus: No upgrade log present (probably fresh install)

Lyn Perrine (walterorlin) wrote :
Lyn Perrine (walterorlin) wrote :

I have attached the /var/log/dpkg.log

Lyn Perrine (walterorlin) wrote :

another log file from apt.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1766478

tags: added: iso-testing
Jb (jebsolutions) wrote :

I noticed deepin was added to the bionic Lubuntu Alternate daily's a few weeks ago.

Here are extract from the /var/log/syslog of the operating system install:

Apr 24 05:37:14 in-target: debconf (developer): starting /usr/bin/debconf-apt-progress --from 150 --to 800 --logstderr -- apt-get -q -y -o APT::Install-Recommends=true -o APT::Get::AutomaticRemove=true -o APT::Acquire::Retries=3 install minimal^ lubuntu-desktop^ standard^

And a few lines later we see the deepin-terminal and friends:

...
Apr 24 05:37:14 in-target: xkb-data is already the newest version (2.23.1-1ubuntu1).
Apr 24 05:37:14 in-target: liblzma5 is already the newest version (5.2.2-1.3).
Apr 24 05:37:14 in-target: xz-utils is already the newest version (5.2.2-1.3).
Apr 24 05:37:14 in-target: zlib1g is already the newest version (1:1.2.11.dfsg-0ubuntu2).
Apr 24 05:37:14 in-target: The following additional packages will be installed:
Apr 24 05:37:14 in-target: apport apport-gtk dbus-x11 deepin-menu deepin-terminal expect fontconfig
Apr 24 05:37:14 in-target: fontconfig-config fonts-liberation fonts-ubuntu gir1.2-wnck-3.0 gtk2-engines
Apr 24 05:37:14 in-target: gtk2-engines-murrine gtk2-engines-pixbuf hicolor-icon-theme libcairo2

There are no reverse dependancies on deepin-terminal:
apt-cache rdepends deepin-terminal

So it's maybe a recommended package. Of what, I'm not sure.

Steve Langasek (vorlon) wrote :

deepin-terminal is pulled into the seed because lxpanel depends on virtual package 'x-terminal-emulator' without specifying a preferred implementation. other lubuntu packages specify 'lxterminal | x-terminal-emulator'.

affects: lubuntu-meta (Ubuntu) → lxpanel (Ubuntu)
Changed in lxpanel (Ubuntu):
status: New → Triaged
Jb (jebsolutions) wrote :

Steve,

I hear you. And I apologize if this is a really dumb follow up question.

But if I run "x-terminal-emulator" what launches...lxterminal. So...??

I thought deepin's tab/ssh approach was interesting and had potential.

Unfortunately, my few minutes of testing deepin found many serious usability problems.

I apologize if this sounds harsh. But the reality with linux is you need the console to get things done/unbreak things. Having to dive under the hood is what users fear most. Anything that clearly makes this experience better or worse has high impact.

Being able to scroll back or resize a terminal window is essential functionality. Anything that makes this in any way complicated or broken is going to be received poorly.

Deepin's borderless windows break consistency with every other Lubuntu app, and make it (even more of) a nightmare to resize the window. The fact that the scrollbar on the right auto-hides completely...after which even clicking and dragging where the scrollbar should be (even when the cursor changes from the text carrot to the pointer arrow!!!) won't allow you to click and scroll back to see past commands...The only non-obvious way to get the scroll bar to appear again (temporarily) is to press enter into the command prompt and then the scroll bar appears for a few seconds. The only way to move the window is to click and drag the top where the window title bar normally be...but the top is the same solid black as everything else so there's no clear delineation of where the top title bar should be.

I think deepin has some nice ideas with the "+" to easily add a new tab and ssh sessions, etc. But a terminal who's ability to scroll back is broken is useless.

Steve Langasek (vorlon) wrote :

In actuality this is being pulled into the seed via apport-gtk, which depends on x-terminal-emulator and alphabetically sorts before any other dependencies of lubuntu-core.

So we need apport-gtk to drop its dependency on x-terminal-emulator. "Depends" is rather strong for this anyway.

Changed in apport (Ubuntu):
status: New → Triaged
status: Triaged → Fix Committed
Changed in lxpanel (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxpanel - 0.9.3-1ubuntu3

---------------
lxpanel (0.9.3-1ubuntu3) bionic; urgency=medium

  * Set the preferred alternative for x-terminal-emulator. LP: #1766478.

 -- Steve Langasek <email address hidden> Tue, 24 Apr 2018 12:23:08 -0700

Changed in lxpanel (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.20.9-0ubuntu7

---------------
apport (2.20.9-0ubuntu7) bionic; urgency=medium

  * debian/control: Drop x-terminal-emulator to Suggests: to avoid pulling
    it in unnecessarily when we only want it to support apport-retrace.
    (LP: #1766478)

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 24 Apr 2018 16:02:54 -0400

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
Jb (jebsolutions) wrote :

This may be a dumb question.

But is "suggests" as mentioned above, the same thing as "recommends" in terms of APT parameter?

From my log the command invoked has "-o APT::Install-Recommends=true". I.e. will it still pull it in if it's "suggests"?

Jb (jebsolutions) wrote :

I was worrying about nothing.

Lubuntu Daily 20180425 does not include deepin!

Thank you. :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers