Cannot set Location in Weather Applet

Bug #1539930 reported by Phill Whiteside on 2016-01-30
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
LXDE
Fix Committed
Undecided
Unassigned
One Hundred Papercuts
Medium
Unassigned
lxpanel (Ubuntu)
Medium
Unassigned

Bug Description

Having added the weather applet, when you set location it reports back 'not found'. Warrington, England does show on my existing system. This is a clean install of 15.10. I even tried London - to no avail.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: lxpanel 0.8.1-1ubuntu2
ProcVersionSignature: Ubuntu 4.2.0-25.30-generic 4.2.6
Uname: Linux 4.2.0-25-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
Config_Home_Lubuntu:
 [Command]
 Logout=lxsession-default quit
CurrentDesktop: LXDE
Date: Sat Jan 30 15:17:19 2016
InstallationDate: Installed on 2016-01-11 (18 days ago)
InstallationMedia: Lubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: lxpanel
UpgradeStatus: No upgrade log present (probably fresh install)

Phill Whiteside (phillw) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxpanel (Ubuntu):
status: New → Confirmed
golisp (golisp) wrote :

Same bug is in Lubuntu 16.04 PowerPC:
lxpanel/xenial,now 0.8.1-1ubuntu2 powerpc [installed]
No one location can be selected.

Walter Lapchynski (wxl) wrote :

I have to wonder if the problem I have in Kubuntu 14.04 isn't related. Perhaps this is an API and/or server/port issue?

Hello Walter,
If you are using LXDE panel with bundled weather applet, then yes.
If yo are using Plasma widgets for KDE (plasma-widget-cwp, plasma-widget-weatherforecast), then you have similar issue with another program.

Weather applet from LXDE panel is usingyahoo api, and I have no firewall. So, issue can be somewhere.

~/src$ git clone http://git.lxde.org/git/lxde/lxpanel.git
Cloning into 'lxpanel'...
remote: Counting objects: 15127, done.
remote: Compressing objects: 100% (6108/6108), done.
remote: Total 15127 (delta 11793), reused 11352 (delta 8903)
Receiving objects: 100% (15127/15127), 7.49 MiB | 336.00 KiB/s, done.
Resolving deltas: 100% (11793/11793), done.
Checking connectivity... done.
~/src$ grep -e http lxpanel/plugins/weather/*
lxpanel/plugins/weather/httputil.c:/* Provides http protocol utility functions */
lxpanel/plugins/weather/httputil.c:#include "httputil.h"
lxpanel/plugins/weather/httputil.c:#include <libxml/nanohttp.h>
lxpanel/plugins/weather/httputil.c:  /* nanohttp magic */
lxpanel/plugins/weather/httputil.h:/* Provides http protocol utility functions */
lxpanel/plugins/weather/yahooutil.c:#include "httputil.h"
lxpanel/plugins/weather/yahooutil.c:static const gchar * FORECAST_URL = "http://query.yahooapis.com/v1/public/yql?format=xml&q=";
lxpanel/plugins/weather/yahooutil.c: * Converts the passed-in string from UTF-8 to ASCII for http transmisison.
~/src$

______________________________________________________________
> Od: Walter Lapchynski <email address hidden>
> Komu: <email address hidden>
> Dátum: 01.02.2016 20:15
> Predmet: [Bug 1539930] Re: Cannot set Location in Weather Applet
>
I have to wonder if the problem I have in Kubuntu 14.04 isn't related.
Perhaps this is an API and/or server/port issue?

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1539930 <https://bugs.launchpad.net/bugs/1539930>

Title:
  Cannot set Location in Weather Applet

Status in lxpanel package in Ubuntu:
  Confirmed

Bug description:
  Having added the weather applet, when you set location it reports back
  'not found'. Warrington, England does show on my existing system. This
  is a clean install of 15.10. I even tried London - to no avail.

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: lxpanel 0.8.1-1ubuntu2
  ProcVersionSignature: Ubuntu 4.2.0-25.30-generic 4.2.6
  Uname: Linux 4.2.0-25-generic x86_64
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
  Config_Home_Lubuntu:
   [Command]
   Logout=lxsession-default quit
  CurrentDesktop: LXDE
  Date: Sat Jan 30 15:17:19 2016
  InstallationDate: Installed on 2016-01-11 (18 days ago)
  InstallationMedia: Lubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  SourcePackage: lxpanel
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lxpanel/+bug/1539930/+subscriptions <https://bugs.launchpad.net/ubuntu/+source/lxpanel/+bug/1539930/+subscriptions>

Changed in lxpanel (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
golisp (golisp) on 2016-02-29
tags: added: powerpc xenial
LStranger (andrej-rep) wrote :

The problem was Yahoo changed YQL so old form ceased to work. This issue is fixed in upstream sources, fix can be extracted from commit http://git.lxde.org/gitweb/?p=lxde/lxpanel.git;a=commitdiff;h=a5a4d42e7f18f413033d1802fb99c59d9d1a2e6f.

LStranger (andrej-rep) on 2016-03-12
Changed in lxde:
status: New → Fix Committed
golisp (golisp) wrote :

Fix commited, source on git deleted. Release was set to obsolete.

Sergey (tsenzuk) wrote :

For future possible hot fixes:
you can manually config applet at ~/.config/lxpanel/Lubuntu/panels/panel
section Plugin type=weather

with such config:

  Config {
    alias=kharkiv, ua
    city=Kharkiv
    state=Kharkiv Oblast
    country=Ukraine
    woeid=922137
    units=c
    interval=15
    enabled=1
  }

appropriate values you can find with similar request:

http://query.yahooapis.com/v1/public/yql?format=xml&q=SELECT%20*%20FROM%20geo.places%20WHERE%20text=%22Kharkiv%22

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxpanel - 0.9.1-1ubuntu1

---------------
lxpanel (0.9.1-1ubuntu1) zesty; urgency=medium

  * Merge with Debian unstable. Ubuntu remaining changes:
  * debian/control:
   - Add libindicator-dev build-depends.
   - Add lxpanel-indicator-applet-plugin binary.
   - Add build-depends on libicu-dev for weather plugin.
   - Update Replaces and Breaks on lxpanel-data (LP: #1417244).
  * debian/lxpanel.install:
   - Install all plugins except indicators.
  * debian/lxpanel-indicator-applet-plugin.install:
   - Install indicator plugin.
  * debian/rules:
   - Add --enable-indicator-support flag.
   - Add dh_install --fail-missing.
   - Re-enable dh_makeshlibs, FTBFS with lxpanel-indicator-applet-plugin.
  * debian/patches:
   - 04_disable_gtk3_indicators.patch: Hide incompatible indicators in the
     preference menu (LP: #1165245).

lxpanel (0.9.1-1) unstable; urgency=medium

  [ Andriy Grytsenko ]
  * Merging upstream version 0.9.1 (Closes: #845060).
  * Using aumix-gtk on !linux-any instead of gnome-alsamixer.

  [ Pino Toscano ]
  * Making sure that ALSA is always disabled for non-Linux architectures.

lxpanel (0.9.0-1) unstable; urgency=medium

  * Merging upstream version 0.9.0 (Closes: #831866, LP: #824071, #1445818,
    #1474936, #1490098, #1537334, #1533308, #1539930, #1555649, #1581708,
    #1583833, #1615326).
  * Bump Standards-Version to 3.9.8.
  * Updating debian/lxpanel.lintian-overrides for multiarch.
  * Updating lxpanel.hints.5 manpage.
  * Updating debian/lxpanel.README.Debian removing section about lxpanel-dev.
  * Updating debian/copyright file.

 -- Julien Lavergne <email address hidden> Sat, 26 Nov 2016 11:39:13 +0100

Changed in lxpanel (Ubuntu):
status: Confirmed → Fix Released
richard (rhubeny76) wrote :

Manually editing the panels config file with my information does not effect the weather plugin. After logging out and logging back in, my local config information is removed from the lxpanel config file.

Is there something I need to do after changing the panels config file to enable the changes?

See Sergey's comment above and also pasted below:
For future possible hot fixes:
you can manually config applet at ~/.config/lxpanel/Lubuntu/panels/panel
section Plugin type=weather

with such config:

  Config {
    alias=kharkiv, ua
    city=Kharkiv
    state=Kharkiv Oblast
    country=Ukraine
    woeid=922137
    units=c
    interval=15
    enabled=1
  }

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers