Intermittent bug with additional applets appearing

Bug #1488660 reported by Phill Whiteside on 2015-08-25
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
lxpanel (Ubuntu)
High
Julien Lavergne

Bug Description

There are instances of duplicate applets appearing in wily, such examples include network-manager applet, online help, skype etc.
Such instances are some what hit and miss, and will appear on one install, but not another even though using the same ISO and machine.
There is an ongoing conversation taking part on the lubuntu QA mailing list at https://lists.launchpad.net/lubuntu-qa/msg05277.html

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: lxpanel 0.8.1-1ubuntu1
ProcVersionSignature: Ubuntu 4.1.0-3.3-generic 4.1.3
Uname: Linux 4.1.0-3-generic x86_64
ApportVersion: 2.18-0ubuntu7
Architecture: amd64
Config_Home_Lubuntu:
 [Command]
 Logout=lxsession-default quit
CurrentDesktop: LXDE
Date: Tue Aug 25 21:53:43 2015
InstallationDate: Installed on 2015-08-25 (0 days ago)
InstallationMedia: Lubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150825)
SourcePackage: lxpanel
UpgradeStatus: No upgrade log present (probably fresh install)

Phill Whiteside (phillw) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1488660

tags: added: iso-testing
Changed in lxpanel (Ubuntu):
status: New → Confirmed
Changed in lxpanel (Ubuntu):
importance: Undecided → High
sudodus (nio-wiklund) wrote :

This bug appears (with doublet icons on the panel) for me in a Toshiba laptop that I bought in April 2013,

http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/

but it does not appear in a desktop computer that I bought in April 2008,

http://www.asus.com/Motherboards/M2NVM_DVI/

See the attached screenshots

sudodus (nio-wiklund) wrote :

Next attached screenshot ...

Phill Whiteside (phillw) wrote :

As described in the initial comment, the bug is very much hit and miss and can even alter between 1st install and a reboot... some work has been done and some theories raised (all in French) We await a report back on how things are progressing.

Phill Whiteside (phillw) wrote :

Julien and melodie have swapped notes and Julien is now on the case. If, like me, you are using wily for production and the duplication is an issue, there is a work around found by Kamilion ....
"if you right click any of them, and select "Indicator Applet" settings, and uncheck and recheck "Indicator Applications", they clean right up and look proper again."

Julien Lavergne (gilir) wrote :

I think I finally find the cause : https://bugs.launchpad.net/ubuntu/+source/indicator-application-gtk2/+bug/1319352
Last revision add files which are already in indicator-application packages, with the consequence that 2 different applications can produce icons on the panel. I'm currently testing the reversion of this revision to see if it's confirmed.

Changed in lxpanel (Ubuntu):
assignee: nobody → Julien Lavergne (gilir)
Julien Lavergne (gilir) wrote :

After some testing, it seems that the change in indicator-application-gtk2 is correct, but it triggered another bug on lxpanel, or the interaction between lxpanel and indicator-application-gtk2. As far as I can see, the startup sequence mess up the applet. I still try to know which event trigger this.

Julien Lavergne (gilir) wrote :

I uploaded a potential fix to ppa:gilir/lubuntu, please test on an installed system to see if you can still reproduce the bug.

Changed in lxpanel (Ubuntu):
status: Confirmed → In Progress
Phill Whiteside (phillw) wrote :

I have added the ppa and installed the new lxpanel. After a reboot, I still have duplicate applets.

Julien Lavergne (gilir) wrote :

Thanks for the testing. Be sure to install also lxpanel-indicator-applet-plugin.

I still can't reproduce it on 2 systems. I think the patch will not do more damage (and we are very short in time), so I'll push it to see how it behaves on a daily. We may adjust it before the release, or as an SRU.

The upload will close the bug, but feel free to reopen if it's still a problem on a daily.

As soon as today's dailies are spun, I'll do a re-install on my test area.

On 14 October 2015 at 07:13, Julien Lavergne <email address hidden>
wrote:

> Thanks for the testing. Be sure to install also lxpanel-indicator-
> applet-plugin.
>
> I still can't reproduce it on 2 systems. I think the patch will not do
> more damage (and we are very short in time), so I'll push it to see how
> it behaves on a daily. We may adjust it before the release, or as an
> SRU.
>
> The upload will close the bug, but feel free to reopen if it's still a
> problem on a daily.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1488660
>
> Title:
> Intermittent bug with additional applets appearing
>
> Status in lxpanel package in Ubuntu:
> In Progress
>
> Bug description:
> There are instances of duplicate applets appearing in wily, such
> examples include network-manager applet, online help, skype etc.
> Such instances are some what hit and miss, and will appear on one
> install, but not another even though using the same ISO and machine.
> There is an ongoing conversation taking part on the lubuntu QA mailing
> list at https://lists.launchpad.net/lubuntu-qa/msg05277.html
>
> ProblemType: Bug
> DistroRelease: Ubuntu 15.10
> Package: lxpanel 0.8.1-1ubuntu1
> ProcVersionSignature: Ubuntu 4.1.0-3.3-generic 4.1.3
> Uname: Linux 4.1.0-3-generic x86_64
> ApportVersion: 2.18-0ubuntu7
> Architecture: amd64
> Config_Home_Lubuntu:
> [Command]
> Logout=lxsession-default quit
> CurrentDesktop: LXDE
> Date: Tue Aug 25 21:53:43 2015
> InstallationDate: Installed on 2015-08-25 (0 days ago)
> InstallationMedia: Lubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150825)
> SourcePackage: lxpanel
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/lxpanel/+bug/1488660/+subscriptions
>

sudodus (nio-wiklund) wrote :

There is a difference compared to yesterday's daily iso tested in a Toshiba laptop that I bought in April 2013,

http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/

There are still double icons for nm-applet, but the double icons for the input method have disappeared. Now there is no icon at all for the input method.

Compare with comments #3-4

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxpanel - 0.8.1-1ubuntu2

---------------
lxpanel (0.8.1-1ubuntu2) wily; urgency=medium

  * debian/patches/05_load_indicator_once.patch
   - Don't load the indicators when creating the applet, they can be loaded
     twice (LP: #1488660)

 -- Julien Lavergne <email address hidden> Wed, 14 Oct 2015 08:14:52 +0200

Changed in lxpanel (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers