lxpanel volume applet settings opens empty terminal window

Bug #1434774 reported by Lyn Perrine on 2015-03-21
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
lxpanel (Ubuntu)
Low
Unassigned

Bug Description

STEPS TO REPRODUCE
 1. Make sure pauvcontrol, alsamixergui, and gnome-alsamixer are not installed (default in Lubuntu)
 2. Right click on the Volume Control item in lxpanel
 3. Click "Volume Control" Settings

EXPECTED RESULTS
 * an x-terminal-emulator (as per lxsession-default-apps) window opens with alsamixer in it

ACTUAL RESULTS
 * an empty x-terminal-emulator window opens

AFFECTS
 * Lubuntu 15.04 from 20150320 on
 * lxpanel 0.7.2-1ubuntu1-2
 * lxsession 0.5.2-0ubuntu1

WORKAROUND
 * install one of the above GUI tools
WORKAROUND2
* in lxpanel, right click → panel settings → advanced → and change terminal emulator to from `lxsession-default-terminal %s` to `lxterminal %s.`

Lyn Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1434774

tags: added: iso-testing
Lyn Perrine (walterorlin) wrote :

Ok this might not be the volume control applet itself not working because if I install pavucontrol it and right click on the volume applet on voume control settings it launches pulse audio volume control.

Another workaround to launch alsamixer is pressing alt +f2 to bring up the run dialog and run lxterminal -e alsamixer. or selecting run in the menu and running lxterminal -e alsamixer.

Lyn Perrine (walterorlin) wrote :

Another way to get the same problem is right clicking panel settings moving to the panel applets tab and then clicking prefrences on the volume control in the list of panel aplets.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxpanel (Ubuntu):
status: New → Confirmed
Changed in lxpanel (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
importance: Undecided → Medium
status: New → Confirmed
Walter Lapchynski (wxl) wrote :

is it specific to this version of Lubuntu and/or lxpanel? when was the last time we knew this worked?

Walter Lapchynski (wxl) on 2015-04-17
Changed in lxpanel (Ubuntu):
status: Confirmed → Triaged
summary: - right clicking on volume applet doesn't open alsamixer
+ lxpanel volume applet settings opens empty lxterminal window
Walter Lapchynski (wxl) on 2015-04-17
summary: - lxpanel volume applet settings opens empty lxterminal window
+ lxpanel volume applet settings opens empty terminal window
description: updated
description: updated
Walter Lapchynski (wxl) on 2015-04-17
description: updated
Walter Lapchynski (wxl) wrote :

ways to open by command line:
 * lxterminal -e alsamixer
 * x-terminal-emulator -e alsamixer
 * xterm alsamixer (or xterm -e alsamixer)

what will not work:
 * lxsession-default terminal alsamixer
 * lxsession-default terminal -e alsamixer
 * lxsession-default terminal "-e alsamixer"

I did set xterm as x-terminal-emulator and it still failed, so my suspicion is that lxsession-default-terminal is being used to make the call, which can't handle parsing the -e switch, apparently.

Walter Lapchynski (wxl) on 2015-04-17
tags: added: lubuntu
Henk Terhell (hterhell) wrote :

Don't know whether this is a related issue but htop also leads to cli when starting from the menu. This is already so in L.14.04LTS, but not in Debian 7.8/LXDE nor in LXQt.

Walter Lapchynski (wxl) wrote :

Henk, I have a feeling they're unrelated since Debian is our upstream but
check the version of lxsession. Which LXQt are you referring to?

Henk Terhell (hterhell) wrote :

According to Synaptic in Debian 7.8 the lxsession of lxde is version 0.4.6.1-4.
LXQt is 0.9 updated (on Xubuntu 14.10).

Walter Lapchynski (wxl) wrote :

Henk, that's an old lxsession and afaik there were major changes in 0.5, so I don't think it's related.

LXQt 0.9 (official upstream) builds off of lxqt-session: https://github.com/lxde/lxqt/issues/349
where as the "official" lxqt-metapackage comments it out: https://bazaar.launchpad.net/~lubuntu-dev/lxde/lxqt-metapackage/view/head:/debian/control
That being said, I'm going to assume that's different enough, too, to not warrant a comparison.

I guess we might have this fixed easy once we go to LXQt XD

LStranger (andrej-rep) wrote :

How LXQt is related to this exact software problem? This should be fixed in whatever setting was done for terminal (apparently it is the same setting in PCManFM and LXPanel configuration window), and if that was "lxsession-default-terminal" then either replace it with working terminal, or fix lxsession package to make it work with -e switch.

tags: added: wily
Phill Whiteside (phillw) wrote :

Not seeing this in Wiley dated 17th June. It behaves as expected for me.

cooloutac (cooloutac) wrote :

I have same issue. lubuntu 15.04.

Phill Whiteside (phillw) wrote :

Correction, i am seeing it in Wily (I had other sound system installed).

Peter Jansson (sm3rek) wrote :

I have this issue on lubuntu 15.10 too. I right clicked on the panel and selected panel settings ->advanced and changed "Terminal Emulator" to lxterminal %s. Now it's working again.

description: updated
Walter Lapchynski (wxl) wrote :

Confirmed this in Lubuntu Xenial Alpha 1.

tags: added: xenial
description: updated
Simon Quigley (tsimonq2) wrote :

Confirmed in Lubuntu Xenial Xerus Alpha 2.

Mathew Hodson (mathew-hodson) wrote :

Changing to Low because an easy workaround exists.

Changed in lxpanel (Ubuntu):
importance: Medium → Low
Nairwolf (nairwolf) wrote :

I confirm this bug is still present on Xenial Xerus Beta 1 (with Lubuntu amd64)

Simon Quigley (tsimonq2) wrote :

This no longer exists with the Lubuntu Xenial Final image.

Changed in lxpanel (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers