Synaptic appears twice when adding things to application launch bar

Bug #1261049 reported by Lyn Perrine on 2013-12-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lxpanel (Ubuntu)
Low
Unassigned

Bug Description

If I click on lxpanel in trusty and right click on application launch bar setting on the right column avaialbe applications under system tools synaptic package manager shows up twice. I think showing up once to add synaptic to the launch bar is enough.

This is on lxpanel 0.6.1-ubuntu1

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: lxpanel 0.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.12.0-7.15-generic 3.12.4
Uname: Linux 3.12.0-7-generic i686
ApportVersion: 2.12.7-0ubuntu2
Architecture: i386
CasperVersion: 1.336ubuntu1
Config_Home_Lubuntu:
 [Command]
 FileManager=lxsession-default filemanager
 Terminal=lxsession-default terminal
 Logout=lxsession-default quit
CurrentDesktop: LXDE
Date: Sat Dec 14 23:06:13 2013
LiveMediaBuild: Lubuntu 14.04 "Trusty Tahr" - Alpha i386 (20131214)
SourcePackage: lxpanel
UpgradeStatus: No upgrade log present (probably fresh install)

Lyn Perrine (walterorlin) wrote :
summary: - Synaptic appears twice in application launch bar settings trusty
+ Synaptic appears twice when adding things to application launch bar
Mélodie (meets) wrote :

Hi,

The reason why Synaptic appears twice is that the Synaptic package comes with two desktop files ("one to bother the other"). Under /usr/share/applications there are synaptic.desktop, and synaptic-kde.desktop.

The last one contains this line:
OnlyShowIn=KDE;

which doesn't seem to make much effect, because it is most often showing twice when it should not. Maybe would it be possible to try a "NotShowIn=LXDE; GNOME; Openbox;" or such instead of a "OnlyShowIn=KDE;"?

At least you can check what I am saying by simply moving the file out of the way ( cd to /usr/share/applications then "sudo mv synaptic-kde.desktop synaptic-kde.desktop-SAVE").

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxpanel (Ubuntu):
status: New → Confirmed
Phill Whiteside (phillw) wrote :

I also suggest that lubuntu simply removes synaptic-kde.desktop from the manifest thus just leaving the synaptic.desktop entry.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1261049

tags: added: iso-testing

Is a non-ideal default configuration.

Changed in lxpanel (Ubuntu):
importance: Undecided → Low
Lyn Perrine (walterorlin) wrote :

On June 7 2014 this is still present in utopic.

Lyn Perrine (walterorlin) wrote :

I am also able to reproduce in vivid.

Lyn Perrine (walterorlin) wrote :

With lxpanel upgraded to 0.7.2 I no longer see synaptic twice in the application launch bar of lxpanel.

Changed in lxpanel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers