Ubuntu

lxkeymap crashed with IndexError in finish_initializing(): list index out of range

Reported by Ladislav Bonita on 2012-03-03
140
This bug affects 28 people
Affects Status Importance Assigned to Milestone
LXKeymap
Undecided
Unassigned
lxkeymap (Ubuntu)
Undecided
Julien Lavergne
Precise
Undecided
Unassigned

Bug Description

SRU explanation :

[Impact] lxkeymap crash when using some keyboard variant / keymap, which make it unusable for some people using those combinaison of keymap / variant.

[Development Fix] The bug was fixed in 0.7.99+dfsg-0ubuntu2, uploaded on quantal. The package in proposed is a backport of this version.

[Stable Fix] A debdiff will be attached to the bug report.

[Test Case] Using lxkeymap with some combinaison of keymap / variant, I can't find an exact one to trigger the crash, but people affected may confirm the fix.

[Regression Potential] Regression should be limited, as this version of the package was tested in PPA, with no regression.

Original bug report:
crash on lxkeymap launch

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: lxkeymap 0.7.99+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
ApportVersion: 1.94-0ubuntu1
Architecture: i386
Date: Sat Mar 3 14:54:19 2012
ExecutablePath: /usr/bin/lxkeymap
InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Beta i386 (20120301.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/lxkeymap
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/lxkeymap']
SourcePackage: lxkeymap
Title: lxkeymap crashed with IndexError in finish_initializing(): list index out of range
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

visibility: private → public
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxkeymap (Ubuntu):
status: New → Confirmed
Paul Gorski (pauliegras) wrote :

Affects me on a G4 eMac PPC 20120304 Lubuntu precise-desktop-powerpc.iso, can't say I remember it happening before this installed version.

Running from terminal the output is:

g@gLuPPb1:~$ lxkeymap

** WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'
Traceback (most recent call last):
  File "/usr/bin/lxkeymap", line 628, in <module>
    window = LxkeymapWindow()
  File "/usr/bin/lxkeymap", line 86, in __new__
    new_object.finish_initializing(builder)
  File "/usr/bin/lxkeymap", line 156, in finish_initializing
    self.config.set('Global', 'Variant', self.variant_current[0])
IndexError: list index out of range
g@gLuPPb1:~$

Lars Noodén (larsnooden) wrote :

Also affects me on a G4 PPC.

$ apt-cache policy lxkeymap
lxkeymap:
  Installed: 0.7.99+dfsg-0ubuntu1
  Candidate: 0.7.99+dfsg-0ubuntu1
  Version table:
 *** 0.7.99+dfsg-0ubuntu1 0
        500 http://ports.ubuntu.com/ubuntu-ports/ precise/universe powerpc Packages
        100 /var/lib/dpkg/status

$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

Ioannis Vranos (cppdeveloper) wrote :

Running Lubuntu 12.04 Beta 1 32-bit, with the latest updates, under VirtualBox 4.1.10.

It happens every time I press ==> "lxkeymap" button, at Preferences-> Keyboard and Mouse->Keyboard.

Fane (i96usa) wrote :

Same here on AMD Athlon 64 X2 3800+ running 64-bit version of 12.04.

user@usa:~$ uname -a
Linux usa 3.2.0-19-generic #30-Ubuntu SMP Fri Mar 16 16:27:15 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
user@usa:~$ lxkeymap

** WARNING **: Trying to register gtype 'GSocketMsgFlags' as flags when in fact it is of type 'GEnum'
Traceback (most recent call last):
  File "/usr/bin/lxkeymap", line 628, in <module>
    window = LxkeymapWindow()
  File "/usr/bin/lxkeymap", line 86, in __new__
    new_object.finish_initializing(builder)
  File "/usr/bin/lxkeymap", line 156, in finish_initializing
    self.config.set('Global', 'Variant', self.variant_current[0])
IndexError: list index out of range
user@usa:~$

Paul Gorski (pauliegras) wrote :

Occurs on clean install of Lubuntu precise-desktop-powerpc.iso 20120324

Exists also on "typical" Lubuntu-Precise Beta 2 (.iso of 20120328).

Reproducible from terminal:

g@pc:~$ lxkeymap
Traceback (most recent call last):
  File "/usr/bin/lxkeymap", line 628, in <module>
    window = LxkeymapWindow()
  File "/usr/bin/lxkeymap", line 86, in __new__
    new_object.finish_initializing(builder)
  File "/usr/bin/lxkeymap", line 156, in finish_initializing
    self.config.set('Global', 'Variant', self.variant_current[0])
IndexError: list index out of range
g@pc:~$

naderra (naderra) wrote :

Quick fix for me was to copy the lxkeymap from a Mint11 natty box over to K/Ubuntu precise ...

$ ./lxkeymap
./lxkeymap:85: RuntimeWarning: missing handler 'on_option_clicked'
  self.builder.connect_signals(self)
./lxkeymap:85: RuntimeWarning: missing handler 'on_removebtn_clicked'
  self.builder.connect_signals(self)
./lxkeymap:85: RuntimeWarning: missing handler 'on_addbtn_clicked'
  self.builder.connect_signals(self)
./lxkeymap:85: RuntimeWarning: missing handler 'on_profiles_activate'
  self.builder.connect_signals(self)

And it worked fine and changed 'keymap es' to 'us'

pawciobiel (pawciobiel) wrote :
Changed in lxkeymap (Ubuntu):
assignee: nobody → pawciobiel (pawciobiel)
status: Confirmed → Fix Committed
sudodus (nio-wiklund) wrote :

This bug affects me too in 32-bit as well as 64-bit computers.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/945603

tags: added: iso-testing
Julien Lavergne (gilir) wrote :

Thanks for the bug report. It's still need to be fixed in Lubuntu itself

Changed in lxkeymap:
status: New → Fix Committed
Changed in lxkeymap (Ubuntu):
status: Fix Committed → New
assignee: pawciobiel (pawciobiel) → nobody
status: New → In Progress
assignee: nobody → Julien Lavergne (gilir)
Julien Lavergne (gilir) wrote :

A fixed package should be available soon on the Lubuntu Staging PPA : https://launchpad.net/~lubuntu-dev/+archive/staging
Please test it and report any problems with it.

SteVe Cook (yorvyk) wrote :

Tested on two machines changed keyboard layouts several times and unable to crash it.

kni (kni) wrote :

Thanks, working now.

Phill Whiteside (phillw) wrote :

Excellent news, should be able to go to 'fix-released' as soon as Julien can get it queued for the next re-spin. :)

Michael Baudino (gornack) wrote :

I was also affected by this bug.
I just installed the package in the Lubuntu Staging PPA and it's now working perfectly.

I'm using Lubuntu 12.04 LTS (Precise Pangolin) with latest update as of today.

Greg Faith (gregfaith) wrote :

Finally got around to installing from the staging PPA works well on amd64 version.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxkeymap - 0.7.99+dfsg-0ubuntu2

---------------
lxkeymap (0.7.99+dfsg-0ubuntu2) quantal; urgency=low

  * debian/patches
   - 02_fix_index_error_start.path: From upstream, fix crash on start
     (LP: #945603)
   - 01_fix_indexerror_options.patch: Remove, replaced by
     02_fix_index_error_start.path.
   - 03_update_status.patch: From upstream, update status on each
     configuration change.
 -- Julien Lavergne <email address hidden> Sat, 05 May 2012 01:30:57 +0200

Changed in lxkeymap (Ubuntu):
status: In Progress → Fix Released
Mörgæs (moergaes) wrote :

Will there be an ordinary bug fix for 12.04 (not through the PPA)?

Workaround for novice computer users, LXKeymap doesn't work in Lubuntu 12.04 LTS?
Install from Terminal:
sudo add-apt-repository ppa:lubuntu-dev/staging
sudo apt-get update && sudo apt-get install lxkeymap

Julien Lavergne (gilir) wrote :
description: updated
Mörgæs (moergaes) wrote :

@Christopher Forster:

You can't use "workaround" and "novice" in the same sentence. A novice does not apply workarounds, he does know what a PPA is and he does not visit Launchpad.

If the solution is more complicated than "Update Manager popped up, and I clicked Install", an ordinary user will never hear of it.

Mörgæs (moergaes) wrote :

Correction: ...does NOT know what...

nemesys (lp-helba) wrote :

Tested "0.7.99+dfsg-0ubuntu2~ppa1" - problem fixed for me.

Novice compter user conservation simulator

Novice: LXKeymap crashes when I try to...

Expert: Google It!

Novice: "lxkeymap crash" & "Bug #945603 “lxkeymap crashed with IndexError in finish_initiali ..." & Oh ok @Christopher Forster (christopherforster) comment #24

Hello Ladislav, or anyone else affected,

Accepted lxkeymap into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in lxkeymap (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Mörgæs (moergaes) wrote :

Updating from Proposed solves the problem.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxkeymap - 0.7.99+dfsg-0ubuntu1.1

---------------
lxkeymap (0.7.99+dfsg-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches
   - 02_fix_index_error_start.path: From upstream, fix crash on start
     (LP: #945603)
   - 01_fix_indexerror_options.patch: Remove, replaced by
     02_fix_index_error_start.path.
   - 03_update_status.patch: From upstream, update status on each
     configuration change.
 -- Julien Lavergne <email address hidden> Mon, 28 May 2012 21:57:52 +0200

Changed in lxkeymap (Ubuntu Precise):
status: Fix Committed → Fix Released
Daniel Clem (clem11388) wrote :

For some reason my system said the bug I was trying to report (via the automatic bug reporter) was the same as this bug. But from the description, its not because the lxkeymap thing won't even start for me at all. I am using CR-48 Chrome notebook. the CPU is a Intel Atom model N455 @ 1.66GHz if that helps.

Also, I will probably try to find how to report another bug on Lubuntu in general. Because I had a strange issue in package management. I wanted to uninstall Chromium from Lubuntu (cause I prefer Midori, much lighter, faster, and has all the needed extensions included by default) But when I did remove Chromium, Firefox was automatically installed. I have no idea why. So I uninstalled Firefox, and then Epiphany was install (also called "Web"), I uninstalled Epiphany, then for some reason, Rhythmbox was installed. And it continued to get more strange from there. The only way I was able to solve this, was use Synaptic, and each time a package was marked to be installed because I was removing another, I "unmarked".

It took about 10 or 15 minutes, but finally got all the strange packages removed. But it was very frustrating to have to go through all that just cause I wanted to remove Chromium. >:-(

That aside, I am still willing to stick with Lubuntu for a while, cause it is WAY too fast to give up on it so easily. Like, crazy insane fast. I may actually put it on my Bigger machine, solely of the speed.

@"Myself" comment #24
LXKeymap from the repository works great know.
@"Myself" comment #29
Correction, I meant: conversation simulator.

BTW Lubuntu 12.04 is not a LTS. I hope that the next Lubuntu release contains packages with overall higher quality.

New to linux and therefore its vocabulary. However this very problem occurs when I select english as primary language and launch lxkeymap to change to my lap tops french keyboard. If i boot and select French as the primary language then lxkeymap loads.

Apparently there is a fix but it is not obvious how to install it. Any suggestions welcome.

pawciobiel (pawciobiel) wrote :

So the fix is to upgrade to saucy 13.10 and use "Keyboard Layout Handler" panel applet.

Thanks

On 04/06/2014 02:00 PM, pawciobiel wrote:
> So the fix is to upgrade to saucy 13.10 and use "Keyboard Layout
> Handler" panel applet.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers