lxinput does not save character repeat values

Bug #989430 reported by Jonas Hellström on 2012-04-27
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
lxinput (Ubuntu)
Low
Unassigned

Bug Description

_How to repeat_
This has been repeatable on 11.10 and now 12.04 of Lubuntu.
* I click the "Start"-button in Lubntu -> Preferences -> Keyboard and Mouse -> Keyboard-tab. I adjust the sliders and click OK. I repeat the process and notice that the sliders are back to their original positions before adjustments.
* I open an lxterminal -> type: lxinput -> click the Keyboard-tab. I adjust the sliders and click OK. I repeat the process and notice that the sliders are back to their original positions before adjustments.

_How to circumvent the problem_
This works as of Lubuntu 12.04.
* I open the file .config/lxsession/Lubuntu/desktop.conf and adjust the [Keyboard]-section values in an editor, save the values, reboot and enjoy the new settings. The adjusted settings are also visible in lxinput after reboot.

_Weird circumstances_
I have not yet pinpointed this in Lubuntu 12.04, but while doing tests with lxinput (running it with sudo, for instance) the settings seem to go back to their defaults of repeat delay of 500 and repeat interval of 30.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: lxinput 0.3.1-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu5
Architecture: i386
Date: Fri Apr 27 08:33:56 2012
InstallationMedia: Lubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lxinput
UpgradeStatus: Upgraded to precise on 2012-04-26 (0 days ago)

I did a bit more testing on "sudo lxinput". This indeed resets the values to their defaults of repeat delay of 500 and repeat interval of 30. It also affects my own user session. Now, I'm not saying that sudo is useful at all in the case of changing settings for my own user but I just didn't expect this to happen. Changing the sliders on the Keyboard-tab and clicking OK does not affect either delay or repeat. They stay at their defaults.

Same problem in Lubuntu 12.10.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxinput (Ubuntu):
status: New → Confirmed
Markus J Schmidt (smiddy84) wrote :

Sorry, I mean 12.04!

tags: added: apport-collected raring

ApportVersion: 2.9.2-0ubuntu8.1
Architecture: i386
DistroRelease: Ubuntu 13.04
MarkForUpload: True
Package: lxinput 0.3.2-1
PackageArchitecture: i386
ProcVersionSignature: Ubuntu 3.8.0-27.40-generic 3.8.13.4
Tags: raring
Uname: Linux 3.8.0-27-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

apport information

apport information

apport information

LStranger (andrej-rep) wrote :

I believe this problem is fixed in the version 0.3.4 which was released recently.

Walter Lapchynski (wxl) on 2014-11-04
Changed in lxinput (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → Low
Walter Lapchynski (wxl) wrote :

confirmed failing with lxinput 0.3.3-1 on an utopic system.

confirmed working with lxinput 0.3.4+bzr269+201410272246 which is available from the lubuntu-dev/lubuntu-daily ppa.

marked as low since we have a workaround.

Walter Lapchynski (wxl) wrote :

oops didn't realized 0.3.4-1 is in vivid. fix released!

Changed in lxinput (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers