Ubuntu

won't save config if missing lxde folder

Reported by olivier-2 on 2010-04-15
58
This bug affects 8 people
Affects Status Importance Assigned to Milestone
lxinput (Ubuntu)
High
Julien Lavergne
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: lxinput

Package: lxinput 0.1.1-2
DistroRelease: Ubuntu lucid (development branch), 10.04 (beta2)
Hardware: Dell mini 10 (1012) touchpad (if relevant)

Description:
lxinput UI accepts configuration changes, but these changes are not taken into consideration when pressing 'OK' button. lxinput shows the default configuration every time it is launched. The default configuration is partially applied when the dialog is dismissed either through Ok or Cancel. Left handed mouse setting seems to persist even though check box stays unchecked when reopening UI (hardware specific?). New mouse acceleration settings are never taken into account.

It seems the configuration changes are not saved if folder ~/.config/lxde does not exist. Creating the folder manually allows lxinput to save a lxde/config file, apply new settings and display them properly upon closing and relaunching lxinput,

This happened after a fresh install of lubuntu 10.04 beta2.

Repro steps:
1- move ~/.config/lxde folder to ~/.config/lxde_
2- start lxinput
3- set new mouse configuration (accel. speed and left handed mode)
4- click Ok
5- launch lxinput

Result:
settings are back to default

Expected:
settings match last configuration seen when closing lxinput

SRU explanation:
1. impact : current settings are not saved to the correct configuration file, making lxinput quite useless.
2. the bug was fixed by updating the location of the configuration files
3. Debdiff included
4. TEST CASE: start lxinput, change a configuration, restart, and see that settings are back to the default ones.
5. Regression : probably no, the configuration doesn't work at all, I can't see how it could be worse. I tested with the patch, no crash, no corruption of the configuration file. I can't see other potential regression.

olivier-2 (olivier-2-martin) wrote :

not sure if this is the right approach, but it works...

olivier-2 (olivier-2-martin) wrote :

same file... marked as a patch

Julien Lavergne (gilir) wrote :

Thanks for the report and the patch. I don't know why it saves the configuration under .config/lxde, it should take it under .config/lxsession/desktop.conf (or /etc/xdg/lxsession/The_name_of_the_session/desktop.conf)

Changed in lxinput (Ubuntu):
status: New → Confirmed
importance: Undecided → High
viktorm (viktor-mastoridis-co) wrote :

I couldn't switch left and right mouse buttons in lxde/lubuntu, but now It works perfectly, remembering the settings after reboot.
 Thanks a lot.

viktorm (viktor-mastoridis-co) wrote :

Me again. What I wrote before was partially true: I logged in-out and the left mouse button worked and I assumed it would work after rebooting (as earlier attempts wouln't work even with log in/out).
Since then , I have restarted the computer and the behaviour is the same - Lubuntu wouldn't recognize the mouse button change.

I do apologize for this, as I was really excited about it - I spent quite a time trying to figure out this show-stopper...

This is what I did:
I created a folder named lxde (and lxde_, just in case) in the .config folder under ~. Then, when I first changed the mouse settings, lxinput created a config file whose content looks like this:

[Mouse]
AccFactor=20
AccThreshold=30
LeftHanded=1

[Keyboard]
Delay=500
Interval=30
Beep=1

But seems to me that initially, Lubuntu isn't reading this file. Only when run lxinput again, the mouse becomes left-handed.

Other strange thing is that some applications, randomly, when they are first opened, behave like right-handed. Meaning, the mouse buttons seems to be swapped for that application only. Clicking aside (anywhere) and back to the application would bring the left-handed mouse behaviour back to that app.

Finally, for the record, I would like to mention that I do not run clean Lubuntu install - I initially installed Xubuntu 10.4, and seeing that my old computer is too slow, via Synaptic I fetched Lubuntu.
Then I removed everything xfce-connected, and reinstalled Lubuntu-desktop in synaptic.

Julien Lavergne (gilir) on 2010-05-19
Changed in lxinput (Ubuntu):
assignee: nobody → Julien Lavergne (gilir)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxinput - 0.1.1-2ubuntu1

---------------
lxinput (0.1.1-2ubuntu1) maverick; urgency=low

  * Switch to dpkg-source 3.0 (quilt) format
  * debian/patches/01-update-config-file.patch
   - Update configuration file location (LP: #563530)
 -- Julien Lavergne <email address hidden> Fri, 21 May 2010 17:29:53 +0200

Changed in lxinput (Ubuntu):
status: In Progress → Fix Released
Julien Lavergne (gilir) wrote :

@ubuntu-sru

Fix uploaded to lucid-proposed as version 0.1.1-2ubuntu0.1
I can't see any regression, as the actual configuration file is wrong and doesn't work at all.

Jonathan Riddell (jr) wrote :

update currently in lucid-proposed Unaccepted queue. Waiting on ack from ubuntu-sru to accept

Julien Lavergne (gilir) wrote :

Bug description updated.
Debdiff included

description: updated

Accepted lxinput into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in lxinput (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
daniele80 (daniele80) wrote :

I installed the updated lxinput,
but it doesn't work at all (even if I create the ~/.config/lxde directory).

I'm using Lubuntu 10.04

Martin Pitt (pitti) wrote :

daniele80,

did the lucid-final lxinput version work for you? I. e. did you see a regression in the lucid-proposed package?

SRU verification for Lucid:
I have reproduced the problem with lxinput 0.1.1-2 in lucid and but the version of lxinput 0.1.1-2ubuntu0.1 in -proposed doesn't fixes the issue.
I have tried to reproduce the problem with a fresh installation of lubuntu-desktop, and neither .config/lxsession nor .config/lxde are created and the configuration settings are not saved.

Marking as verification-failed

tags: added: verification-failed
removed: verification-needed
Julien Lavergne (gilir) wrote :

I confirmed, it still doesn't work if the directory doesn't exist. And even if the directory exist, the created file is incomplete.
I re-open the bug.
Forwarded upstream : https://sourceforge.net/tracker/index.php?func=detail&aid=3049664&group_id=180858&atid=894869

Changed in lxinput (Ubuntu):
status: Fix Released → Confirmed
Changed in lxinput (Ubuntu Lucid):
status: Fix Committed → Confirmed
Julien Lavergne (gilir) on 2010-08-21
Changed in lxinput (Ubuntu):
assignee: Julien Lavergne (gilir) → nobody
status: Confirmed → Triaged
Martin Pitt (pitti) wrote :

I removed the lucid-proposed package again.

Bug is still reproducible on lubuntu 11.10, lxinput-0.3.1-1. Adding the ~/.config/lxde or ~/.config/lxsession doesn't solve anything. Changes are not saved on either folder in $HOME, or under /etc/xdg/lxsession/SESSION_NAME/. However, when ~/.config/lxsession/desktop.conf is manually edited and lxinput is restarted, it displays the correct values, but changes are not applied right away.

I can confirm this bug for Lubunt 11.10, lxinput 0.3.1-1. I observed the following behaviour:

- Originally, changing the mouse to "left-handed" with lxinput would not be remembered between sessions.
- Based on an strace of lxinput, I then created the directory "~/.config/lxsession/Lubuntu" manually
- Once I had done that, lxinput created a "desktop.conf" file in that directory with the following settings:

[Mouse]
AccFactor=20
AccThreshold=10
LeftHanded=1

[Keyboard]
Delay=500
Interval=30
Beep=1

So, I would expect the "left-handed" setting to stick now - at least, it is now correctly shown when lxinput is started. Apparently, lxinput still does not create the necessary directories in the user's home directory when started.

Julien Lavergne (gilir) on 2012-03-29
Changed in lxinput (Ubuntu):
assignee: nobody → Julien Lavergne (gilir)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxinput - 0.3.1-1ubuntu1

---------------
lxinput (0.3.1-1ubuntu1) precise; urgency=low

  * debian/patches:
   - 01_fix_load_save_settings.patch: From upstream, handle settings saving
     correctly, when there is no desktop.conf in user home directory
     (LP: #563530, #898696)
 -- Julien Lavergne <email address hidden> Wed, 28 Mar 2012 01:34:07 +0200

Changed in lxinput (Ubuntu):
status: In Progress → Fix Released
Voron_Shinigami (mail4spam) wrote :

Once had installed lubuntu-desktop to my Ubuntu 10.04 AMD64 system, acquired the same problem; however, creating ~/.config/lxde solved only the issue of SAVING the VALUES, but they didn't actually affect the sensitivity and acceleration, only the button swap (with lxinput 0.3.1 from Precise installed, didn't check the swap with the original package).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.