Ubuntu

Lubuntu live image boots to TTY

Reported by Erick Brunzell on 2011-09-20
56
This bug affects 8 people
Affects Status Importance Assigned to Milestone
lxdm (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

I'm testing the Oneiric Lubuntu 20110920-i386 live image and I notice that booting to a blank hard drive on my old VIA hardware (I'll attach a list later if not collected by apport) results in a TTY prompt which may leave some users confused as how to proceed.

I've repeated this twice and in both instances typing "sudo service lxdm start" (without the quotes) results in a DE, that is no need to login as "ubuntu", leave password blank, etc.

This occurred so far only when booting to a blank 80GB drive (errm - maybe had one existing partition) to perform an "entire disc" installation test. I'm now going to use the same drive to try an auto-resize install and I'll report back accordingly.

I realize this may actually be an lxdm bug but I thought filing against casper would collect the best possible info, hope I was right.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: casper 1.284
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
CasperVersion: 1.284
Date: Tue Sep 20 11:13:46 2011
LiveMediaBuild: Lubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110920)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: casper
UpgradeStatus: No upgrade log present (probably fresh install)

Erick Brunzell (lbsolost) wrote :
Erick Brunzell (lbsolost) wrote :

This is the hardware involved:

VIA PC2500 Mainboard
VIA Esther C7 CPU 1500MHz
System Memory 2GB DIMM
VT8233/A/8235/8237 AC97 Audio Controller
CN700/P4M800 Pro/P4M800 CE/VN800 [S3 UniChrome Pro] Graphics

And a single 80GB hard drive which may have either been a blank drive or had one single partition - according to the installer one partition was going to be erased but it's a testing drive so I'm clueless about what may have been there, most likely some old data transfer because a previous installation would have had more than one partition.

Now to repeat some testing.

tags: added: iso-testing
Erick Brunzell (lbsolost) wrote :

This occurred again on the same hardware booting the Live CD to "live desktop" so I could begin the auto resize test. Please see the attached photo.

Once again 'sudo service lxdm start' boots straight to the DE.

Erick Brunzell (lbsolost) wrote :

Same thing trying a "free space" install so I changed hard drives to a 160GB drive that I typically use for "manual partitioning" tests and I get the same thing.

I'll try this ASAP on my Intel hardware.

Erick Brunzell (lbsolost) wrote :

I'd say it's definitely hardware related because I did a manual partitioning install on my Intel hardware with no problem:

JetWay JATOM-GM1-230-LF Motherboard
Intel Atom 230 CPU @ 1.60GHz
System Memory 2GB DIMM
Intel 82945G/GZ Integrated Graphics
Intel N10/ICH 7 Family High Def Audio Controller

But I wonder if this should be mentioned in the release notes?

Erick Brunzell (lbsolost) wrote :

I have a couple more tests to perform yet but so far I'm not able to reproduce this behavior with 20110921.1-i386.

I'll follow up ASAP.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in casper (Ubuntu):
status: New → Confirmed
Erick Brunzell (lbsolost) wrote :

I did just experience this again with the 20110921.1-i386 Lubuntu image on my old VIA hardware, but I'd had 4 or 5 consecutive boots perform perfectly fine, so the behavior is inconsistent now.

With 20110920-i386 the behavior was quite consistent, that is each boot would end at TTY.

I am thinking we should mention this in the release notes for Lubuntu Beta 2 because the work around, typing "sudo service lxdm start" does work fine.

Julien Lavergne (gilir) wrote :

It seems to be reproductible, on other hardware. Could you provide the casper.log and dmesg.txt using this tutorial : https://wiki.ubuntu.com/DebuggingCasper
Thanks.

amjjawad (amjjawad) wrote :

lubuntu-11.10-beta2-desktop-i386

Try Lubuntu without installation does not work and drop you to CLI. Typing "starx" command will take you to LXDE Desktop with LXDE wallpaper instead of Lubuntu Desktop. There is an icon on the LXDE Desktop to Install Lubuntu.

- Hardware: P4 3.0GHz - 2GB RAM - 40GB IDE HDD - Intel Graphics
- HDD has many partitions and I'm multi-booting several Distros.
- Lubuntu to be installed in sda9 - 3.91GB.

I've had the same issue with Lubuntu 11.04 and it seems I still have it with Lubuntu 11.10 beta 2. Try Lubuntu from "LiveCD" always end to CLI instead of Lubuntu Desktop. This time, with Lubuntu 11.10 beta 2, I ended up with LXDE Desktop instead of Lubuntu Desktop when I typed "startx".

Erick Brunzell (lbsolost) wrote :
Erick Brunzell (lbsolost) wrote :
Erick Brunzell (lbsolost) wrote :

@ Julien, just let me know if you need any more info. It's odd that I can never get the boot to fail with my Intel hardware, but if I keep rebooting with my older VIA hardware I'll get a failure sometimes. It took eight tries with the debug= parameter before I got a failure.

Thanks in advance,

Lance

amjjawad (amjjawad) wrote :

I have done some tests and whenever I boot my PC (checked that on two different PCs) from LIVEUSB and choose "Try Lubuntu without installation", it works and I can see the Live Desktop of Lubuntu. While on LiveCD, it never ended to Lubuntu Live Desktop.

Just to keep you updated!

Julien Lavergne (gilir) wrote :

I don' see anything suspect in the log. Could you attach also /var/log/lxdm.log ? Do you have the same behavior with an Ubuntu or a Xubuntu ISO ?

Erick Brunzell (lbsolost) wrote :

This one was from a failed boot without the debug= parameter.

Erick Brunzell (lbsolost) wrote :

This one was performed with the debug= parameter.

Note that when adding debug= I also drop the "quiet splash" and the frequency of a failed boot is greatly decreased. I'll bet this time it took between 20 and 25 reboots before I got a failure.

Erick Brunzell (lbsolost) wrote :

I also saved one from a successful boot if you should need it, but one thing I notice in common is that they all identify the media as "Build Date: 19 September 2011 06:58:01AM", but the boot.log clearly shows I'm using 'Lubuntu 11.10 _Oneiric Ocelot_ - Beta i386 (20110921.1)'.

Erick Brunzell (lbsolost) wrote :

Oops, forgot to mention that I've not seen this with Ubuntu at all recently, perhaps not at all during Oneiric dev. I haven't tried Xubuntu in several weeks so I don't know about that.

tags: added: rls-mgr-o-tracking
Changed in casper (Ubuntu Oneiric):
importance: Undecided → High
Colin Watson (cjwatson) wrote :

Could you try adding the --debug boot parameter, using F6 at the CD boot menu (make sure --debug goes before the "--" at the end or it won't work)? Since this is surely a race condition, this may perturb timings such that the problem is more or less likely to occur, but if you can manage to reproduce this with --debug then please attach /var/log/syslog here.

So far I haven't managed to reproduce this myself ...

Colin Watson (cjwatson) wrote :

Oh, of course it's possible that https://launchpad.net/ubuntu/+source/initramfs-tools/0.99ubuntu6 has made this go away. I notice that your lxdm log says "(EE) open /dev/fb0: No such file or directory", which suggests a race between lxdm starting and framebuffer drivers being loaded.

Colin Watson (cjwatson) wrote :

Should lxdm's Upstart job perhaps be adjusted too? gdm and lightdm both have:

  drm-device-added card0 PRIMARY_DEVICE_FOR_DISPLAY=1
  or stopped udev-fallback-graphics

... where lxdm has:

  graphics-device-added fb0 PRIMARY_DEVICE_FOR_DISPLAY=1
  or drm-device-added card0 PRIMARY_DEVICE_FOR_DISPLAY=1
  or stopped udevtrigger

... which IIRC is an older form.

Erick Brunzell (lbsolost) wrote :

Colin I've been removing the "--" along with the quiet splash, so I turn this:

file=/cdrom/preseed/lubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --

Into this:

file=/cdrom/preseed/lubuntu.seed boot=casper initrd=/casper/initrd.lz debug=

Should it be:

file=/cdrom/preseed/lubuntu.seed boot=casper initrd=/casper/initrd.lz debug= --

Or should I just be leaving the quiet splash alone and adding it like this:

file=/cdrom/preseed/lubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash debug= --

Thanks in advance.

Colin Watson (cjwatson) wrote :

--debug, not debug=, please - the two leading dashes are important. (These two boot parameters do different things. --debug is an option to Upstart that tells it to log lots of interesting stuff to syslog. debug= is an option to the initramfs.)

So:

  file=/cdrom/preseed/lubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --debug --

Erick Brunzell (lbsolost) wrote :

Thanks Colin, it only took three boots to get the failed boot to TTY.

Julien Lavergne (gilir) wrote :

Thanks Colin, I'll update the lxdm upstart rule. Even if it doesn't fix the problem, it's a good idea to be up-to-date with the upstart commands :)

Steve Langasek (vorlon) wrote :

Is this issue still present with the latest daily, after the changes to the lxdm and initramfs-tools packages?

Changed in casper (Ubuntu Oneiric):
status: Confirmed → Incomplete
Erick Brunzell (lbsolost) wrote :

To all involved, I'll be glad to test any daily build requested, or anything else. ATM my old VIA box has just been "sleeping" after attaching the log requested by Colin.

Well "sleeping" may be misleading. I just tweaked the screensaver settings to let the back-light on the monitor die to save resources, but I'm still booted into that last "failed" boot in case Colin needed more info.

I have not tried any Lubuntu live daily build since Beta 2. I certainly can but I've been operating on the cheap due to extremely high utility bills and remodeling costs.

But I have the resources needed to complete both Ubuntu and Lubuntu final iso-testing, with a very comfortable margin for several rebuilds if needed ;^)

Once Julien says the changes are applied to any given daily build I'm ready to go.

Erick Brunzell (lbsolost) wrote :

Disregard that last post. I'm beginning iso-testing now.

Erick Brunzell (lbsolost) wrote :

Because of bug 283316 causing an optical drive failure I'm stalled ATM!

I'll head over to the brick & mortar puter store tomorrow to get a new drive so I can continue testing.

Erick Brunzell (lbsolost) wrote :

This did occur with the very first boot of lubuntu/daily-live/20111007/oneiric-desktop-i386 so I think this should be changed back to confirmed.

Julien Lavergne (gilir) on 2011-10-09
Changed in casper (Ubuntu Oneiric):
status: Incomplete → Confirmed
Julien Lavergne (gilir) wrote :

I was finally able to reproduce it, with desktop ISO 20111007, converted on an USB stick using usb-creator-gtk.

The system boot, but it seems that lxdm dies during the process. I included the syslog with debug enable.

The boot start on 12:28, and finish to tty.
If I do "sudo start lxdm", the system starts correctly. I did it on 12:35, you can see it on the syslog starting on 12:35, with lxdm process 3953.

Interesting parts :
Oct 9 12:28:37 ubuntu kernel: [ 157.566006] init: lxdm state changed from starting to pre-start
Oct 9 12:28:37 ubuntu kernel: [ 157.572844] init: lxdm state changed from pre-start to spawned
Oct 9 12:28:37 ubuntu kernel: [ 157.586642] init: lxdm main process (2772)
Oct 9 12:28:37 ubuntu kernel: [ 157.586942] init: lxdm state changed from spawned to post-start
Oct 9 12:28:37 ubuntu kernel: [ 157.596770] init: lxdm state changed from post-start to running
Oct 9 12:28:37 ubuntu kernel: [ 157.597577] init: event_new: Pending started event
Oct 9 12:28:37 ubuntu kernel: [ 157.597714] init: Handling started event
Oct 9 12:28:37 ubuntu kernel: [ 157.598218] init: event_finished: Finished started event
...
Oct 9 12:28:50 ubuntu kernel: [ 169.953814] init: event_new: Pending stopped event
Oct 9 12:28:50 ubuntu kernel: [ 169.953971] init: job_change_state: Destroyed inactive instance irqbalance
Oct 9 12:28:50 ubuntu kernel: [ 169.954766] init: Handling stopped event
Oct 9 12:28:50 ubuntu kernel: [ 169.955188] init: event_finished: Finished stopped event
...
Oct 9 12:28:54 ubuntu kernel: [ 174.658768] init: lxdm main process (2772) terminated with status 1
Oct 9 12:28:54 ubuntu kernel: [ 174.659426] init: lxdm goal changed from start to stop
Oct 9 12:28:54 ubuntu kernel: [ 174.659707] init: lxdm state changed from running to stopping
Oct 9 12:28:54 ubuntu kernel: [ 174.662441] init: event_new: Pending stopping event
Oct 9 12:28:54 ubuntu kernel: [ 174.662687] init: Handling stopping event
Oct 9 12:28:54 ubuntu kernel: [ 174.663078] init: event_finished: Finished stopping event
Oct 9 12:28:54 ubuntu kernel: [ 174.663177] init: lxdm state changed from stopping to killed
Oct 9 12:28:54 ubuntu kernel: [ 174.665332] init: lxdm state changed from killed to post-stop
Oct 9 12:28:54 ubuntu kernel: [ 174.672730] init: lxdm post-stop process (3266)
Oct 9 12:28:54 ubuntu kernel: [ 174.673908] init: lxdm post-stop process (3266) exited normally
Oct 9 12:28:54 ubuntu kernel: [ 174.674275] init: lxdm state changed from post-stop to waiting
Oct 9 12:28:54 ubuntu kernel: [ 174.676764] init: event_new: Pending stopped event
Oct 9 12:28:54 ubuntu kernel: [ 174.676931] init: job_change_state: Destroyed inactive instance lxdm
Oct 9 12:28:54 ubuntu kernel: [ 174.678405] init: Handling stopped event
Oct 9 12:28:54 ubuntu kernel: [ 174.678925] init: event_finished: Finished stopped event
...

Steve Langasek (vorlon) wrote :

was not fixed in oneiric; no point in an SRU for casper since we won't roll any more oneiric images from it. I guess this should be documented in whatever Lubuntu-specific release notes there are.

Changed in casper (Ubuntu Oneiric):
status: Confirmed → Won't Fix
tags: added: lubuntu
tags: added: rls-p-tracking
removed: rls-mgr-o-tracking
amjjawad (amjjawad) wrote :

Actually I didn't have this issue on one of my two tests PC. When running from the Live-CD, I got to the Live Desktop after I chose "Try without installation". However, on the other PC, I got this problem because the CD-Drive is falling.

Also, when I used the Live-USB, I did not have that problem on both PCs.

Perhaps it has something to do with the Media. I'm not really sure but I hope someone else will try that from Live-USB and see the difference. Or, is it only me?

Steve Langasek (vorlon) on 2011-10-27
tags: removed: rls-p-tracking
Stéphane Graber (stgraber) wrote :

Looking at the history, this bug seems to be more about a lxdm race condition than about casper, except for the fact that it's mostly happening within a live environment.

Moving the bug over to lxdm.

affects: casper (Ubuntu) → lxdm (Ubuntu)
amjjawad (amjjawad) wrote :

I have marked this bug as invalid since it is an old bug and Lubuntu does not use lxdm anymore.

Changed in lxdm (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers